Instructions

1. Enter substrate, rate data into the data table
2. Watch....
Copyright

Copyright © Erithacus Software Limited, 1989–2001. All rights reserved.

Portions of the software described in this document copyright © Microsoft Corporation 1985–2001. All rights reserved.

Information in this document is subject to change without notice and does not represent a commitment on the part of Erithacus Software Limited. The software is furnished under a license agreement, and the software may be used or copied only in accordance with the terms of the agreement. The purchaser may make one copy of the software for backup purposes. No part of this publication may be reproduced, transmitted, stored in a retrieval system, or translated into any language in any form or by any means, including photocopying and recording for any purpose other than the purchaser’s personal use without the written permission of Erithacus Software Limited.

Erithacus Software Limited
PO Box 274, Horley
Surrey, RH6 9YJ, UK

VERSION 5

Last revision February 2001

Trademarks

GraFit is a trademark of Erithacus Software Limited. Microsoft, Windows, NT are trademarks or registered trademarks of Microsoft Corporation.

Other brands and products are trademarks or registered trademarks of their respective holders and should be noted as such.

Citing GraFit in Publications

When citing GraFit, simply treat this software publication as you would a book. For example:

April 1998.

Version 4 is dedicated to Catherine (right) and Emma; new features that have been added since version 3 was released...
Acknowledgements

Version 5

Version 5 has benefited from the suggestions of many, but most important has been the continued perseverance of Paul Edwards, whose contributions are gratefully acknowledged.


ROBIN J. LEATHERBARROW

Version 4

Well, it took rather longer than I anticipated, but version 4 has finally appeared. The changes from version 3 are far more substantial than a single version number increment may lead one to believe, and represent a radical overhaul to the program. There are many people to thank for their encouragement and assistance, and I would like to mention some of those who have contributed most. Paul Edwards has suffered the various buggy beta versions with great tolerance, and many useful additions have been due to him. My thanks also go to Walter Ward for his help and sound advice. Steve Clarke has made a large number of valuable suggestions, and I am very grateful to Ron Duggleby for his comments and encouragement. Plaudits also to Alessandro Aliverti, Ian Auld, Bogdan Bogdanov, Bjarke Ebert, John Gebler, Florence Guye, Douglas Kell, and Karsten Olsen, for many recommendations and suggestions. As usual, Marcella has been long-suffering in her support, without which this version would still be in development.

Version 3

Many of the improvements in this version are due to the excellent suggestions that have come from various GraFit users. My thanks to all who contributed, particularly to Pietro Belfiore, John Gebler, Douglas Kell, Steve Matthews and David Tew for many valuable recommendations, and to Martin Reddington, Walter Ward, Tim Wells and Marcella, for their continued advice.

Version 2

My thanks to the many people who have given advice for improving the program. In particular, I am grateful to Bjarke Ebert, Bernard Mangold, Sanjoy Ray, Martin Reddington, Walter Ward and Tim Wells for many constructive suggestions. Once again, this program and manual would not have been possible without the help and encouragement of Marcella.

Version 1

In the preparation of this program I have benefited from encouragement and advice from many sources. My thanks to all my friends and colleagues who have given help and advice, including all the members, past and present, of the Biological Chemistry section, Dept. of Chemistry, Imperial College of Science, Technology and Medicine, London U.K., especially Alan Russell, Tim Wells, Alan Fersht and Sanjoy Ray.

I am particularly indebted to my wife, Marcella, who proofread the manual and put up with the ups and downs associated with program development.
## Contents

### Introduction .................................................................1
- Welcome ...........................................................................1
- Key Features of GraFit .....................................................1
- About this Guide ...........................................................2
  - Notational Conventions ................................................2
- Contacting Erithacus Software ......................................2
  - Address ..........................................................................2
  - Technical Support .........................................................3
  - Internet ...........................................................................3

### Installation .................................................................5
- System Requirements ......................................................5
- The GraFit Package .........................................................5
- Installing GraFit .............................................................6
  - CD-ROM Installation ....................................................6
  - Installation from Floppy Disks ........................................7
- Uninstalling GraFit ..........................................................7

### GraFit Basics ..............................................................9
- Running GraFit ...............................................................9
- The GraFit Workspace ...................................................10
- GraFit Items .................................................................11
  - Managing Items ..........................................................11
  - Item Representation ...................................................11
  - Editing the Item Name ................................................12
  - Changing the Item Icon ..............................................12
  - Item-specific Commands ............................................13
- Printing the Item Contents ............................................13
  - Page Settings .............................................................14
- Stock Items .....................................................................14
- GraFit Templates .........................................................15
- Accessing Help ..............................................................15

### Working with Files .....................................................17
- GraFit Workspace Files ..................................................17
  - Opening an Existing File ............................................17
  - Saving a File ............................................................18
  - Loading and Saving Individual Items ............................18
  - Creating a New File ...................................................18
  - Importing Data Files ..................................................18
  - GraFit Template Files ................................................19
## Template Directories ..................................................................................................................... 19

## Data Tables........................................................................................................................................ 23
- The Data Table Item ......................................................................................................................... 23
- Data Types ......................................................................................................................................... 24
- Forcing Text Entry ............................................................................................................................ 26
- Moving the Data Entry Position ......................................................................................................... 26
- Selecting Regions of the Data Table .................................................................................................. 27
  - Selecting Part of the Data Table ...................................................................................................... 27
  - Selecting Entire Columns .................................................................................................................. 28
- Copying and Pasting Data ................................................................................................................... 28
  - Copying and Pasting Regions of the Data Table ............................................................................ 28
  - Copying and Pasting Columns ......................................................................................................... 28
- Removing Data ..................................................................................................................................... 30
  - Clearing a Region of Data ............................................................................................................... 30
  - Deleting a Region of Data ............................................................................................................... 31
- Inserting Values into the Table .......................................................................................................... 31
- Sorting Data ......................................................................................................................................... 32
- Data Table Appearance ..................................................................................................................... 32
  - Colors and Fonts ............................................................................................................................ 32
  - Number Format ............................................................................................................................... 32
  - Magnification ................................................................................................................................... 34
- Importing and Exporting Data .......................................................................................................... 34
  - Importing Data ............................................................................................................................... 34
  - Importing Data as a New Data Table .............................................................................................. 34
  - Exporting Data ............................................................................................................................... 35
- Column Types ...................................................................................................................................... 35
  - (General) Column Type .................................................................................................................. 37
  - Data Types ....................................................................................................................................... 37
  - Column Combinations ...................................................................................................................... 39
  - Statistics ........................................................................................................................................... 39
  - Data Fitting ........................................................................................................................................ 43
  - Calculated Values ............................................................................................................................. 46
  - Data Processing ............................................................................................................................... 50
- Locking a Data Column ...................................................................................................................... 55

## Non-linear Fit Item ............................................................................................................................. 57
- Overview of Non-linear Fitting ........................................................................................................... 57
- Status Bar Indicators ......................................................................................................................... 57
- Settings Pane ....................................................................................................................................... 58
  - Equation ........................................................................................................................................... 58
  - Weighting ......................................................................................................................................... 58
  - Data Table ....................................................................................................................................... 58
  - Data Layout ...................................................................................................................................... 59
  - X Data Column ............................................................................................................................... 60
  - Y Data Column ............................................................................................................................... 61
  - Error Column ................................................................................................................................. 61
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constants Pane</td>
<td>61</td>
</tr>
<tr>
<td>Estimatrix Pane</td>
<td>61</td>
</tr>
<tr>
<td>Interactive Estimator</td>
<td>62</td>
</tr>
<tr>
<td>Fitting Criteria Pane</td>
<td>63</td>
</tr>
<tr>
<td>Fitting Criteria</td>
<td>64</td>
</tr>
<tr>
<td>Results Pane</td>
<td>65</td>
</tr>
<tr>
<td>Number Format Pane</td>
<td>66</td>
</tr>
<tr>
<td>Fonts and Indents Panes</td>
<td>67</td>
</tr>
<tr>
<td>Formatting Item Windows</td>
<td>69</td>
</tr>
<tr>
<td>Formatting Options</td>
<td>69</td>
</tr>
<tr>
<td>Fonts Pane</td>
<td>69</td>
</tr>
<tr>
<td>Indents Pane</td>
<td>70</td>
</tr>
<tr>
<td>Linear Fit Item</td>
<td>71</td>
</tr>
<tr>
<td>Overview of Linear Fitting</td>
<td>71</td>
</tr>
<tr>
<td>Status Bar Indicators</td>
<td>71</td>
</tr>
<tr>
<td>Settings Pane</td>
<td>72</td>
</tr>
<tr>
<td>Equation</td>
<td>72</td>
</tr>
<tr>
<td>Weighting</td>
<td>72</td>
</tr>
<tr>
<td>Data Table</td>
<td>72</td>
</tr>
<tr>
<td>Data Layout</td>
<td>72</td>
</tr>
<tr>
<td>X Data Column</td>
<td>73</td>
</tr>
<tr>
<td>Y Data Column</td>
<td>73</td>
</tr>
<tr>
<td>Error Column</td>
<td>73</td>
</tr>
<tr>
<td>Results Pane</td>
<td>74</td>
</tr>
<tr>
<td>Fonts and Indents Panes</td>
<td>75</td>
</tr>
<tr>
<td>Equation Item</td>
<td>77</td>
</tr>
<tr>
<td>Overview of Equation Definitions</td>
<td>77</td>
</tr>
<tr>
<td>Status Bar Indicators</td>
<td>77</td>
</tr>
<tr>
<td>General Pane</td>
<td>78</td>
</tr>
<tr>
<td>Changing Font Styles</td>
<td>78</td>
</tr>
<tr>
<td>Inserting OLE Objects</td>
<td>78</td>
</tr>
<tr>
<td>Editing OLE Objects</td>
<td>79</td>
</tr>
<tr>
<td>X Variables Pane</td>
<td>79</td>
</tr>
<tr>
<td>Naming Rules</td>
<td>80</td>
</tr>
<tr>
<td>Number of X Variables</td>
<td>80</td>
</tr>
<tr>
<td>Parameters Pane</td>
<td>81</td>
</tr>
<tr>
<td>Constants Pane</td>
<td>81</td>
</tr>
<tr>
<td>Definition Pane</td>
<td>82</td>
</tr>
<tr>
<td>Equation Definition Syntax</td>
<td>83</td>
</tr>
<tr>
<td>Multi-line Equation Definitions</td>
<td>86</td>
</tr>
<tr>
<td>Use of Temporary Variables</td>
<td>86</td>
</tr>
<tr>
<td>Conditional Statements</td>
<td>86</td>
</tr>
<tr>
<td>Comments</td>
<td>87</td>
</tr>
<tr>
<td>Looping Statements</td>
<td>87</td>
</tr>
<tr>
<td>Contents</td>
<td></td>
</tr>
<tr>
<td>------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Fill Properties</td>
<td>114</td>
</tr>
<tr>
<td>Line Properties</td>
<td>114</td>
</tr>
<tr>
<td>Rotation Properties</td>
<td>115</td>
</tr>
<tr>
<td>Location Properties</td>
<td>115</td>
</tr>
<tr>
<td>Arrows Properties</td>
<td>116</td>
</tr>
<tr>
<td>Font Properties</td>
<td>117</td>
</tr>
<tr>
<td>Paragraph Properties</td>
<td>118</td>
</tr>
<tr>
<td>Exporting Graphs</td>
<td>118</td>
</tr>
</tbody>
</table>

**X/Y Scatter Graphs** ........................................................................................................119

The XY Graph Wizard ........................................................................................................... 119
Select Data Source Page ................................................................................................... 119
Set Initial Scaling ........................................................................................................... 121
Select Tick Styles ........................................................................................................... 122
Select Data Point Style .................................................................................................. 122
Enter Curve Parameters ................................................................................................. 123
Enter Curve Constants ................................................................................................... 124
Select Fitting Curve Style ............................................................................................ 124
Select Join Style ............................................................................................................ 125

Modifying Graphs ............................................................................................................ 126
Selectable Regions of a Graph ....................................................................................... 127
Main Graph Region .......................................................................................................... 127
General Page ................................................................................................................... 128
Fill Page .......................................................................................................................... 129
Line Page .......................................................................................................................... 129
X Ticks Page ..................................................................................................................... 129
X Scale Page ..................................................................................................................... 131
Y Ticks Page ..................................................................................................................... 133
Y Scale Page ..................................................................................................................... 133
Location Page .................................................................................................................. 133

Axis Scale Regions ......................................................................................................... 134
Scale Page ......................................................................................................................... 134
Axis Text Regions ............................................................................................................ 136
Legend Box Region .......................................................................................................... 136
Legend Page ....................................................................................................................... 136
Fill Page ................................................................................................................................ 137
Line Page ................................................................................................................................ 137
Location Page .................................................................................................................. 137

Data/Curve Properties .................................................................................................... 138
Data Points Page ............................................................................................................. 138
Join Points Page ............................................................................................................... 139
Fitted Curve Page ............................................................................................................ 140
Data Source Page ............................................................................................................ 141
Data Source Page ............................................................................................................ 142
Error Bars Page ............................................................................................................... 143
Axis Association Page ..................................................................................................... 145
Using Multiple Graph Axes .......................................................... 151
   When to Use Multiple Axis Scaling ............................................. 151
   Overlaying Data that have Different Scales ............................... 151
   Split Axes .............................................................................. 152
Creating and Managing Multiple Axes .......................................... 152
   Running the Axis Manager ....................................................... 152
   Adding a New Axis .................................................................. 153
   Splitting an Existing Axis ....................................................... 154
   Removing an Axis .................................................................... 155
Working with Multiple Axes ......................................................... 156
   Axis Text and Axis Scale Text ................................................ 156
   Data Association ..................................................................... 156
   Axis Scaling and Sizing .......................................................... 157

Column and Bar Charts ............................................................... 161
   The Chart Wizard ................................................................. 161
   Select Data Source Page ....................................................... 161
   Set Initial Scaling .................................................................. 163
   Select Tick Styles ................................................................... 164
   Select Bar Style ..................................................................... 165
   Select Data Point Style .......................................................... 166
   Select Join Style ..................................................................... 167

Histograms .................................................................................. 169
   The Histogram Wizard ........................................................... 169
   Select Data Source Page ....................................................... 169
   Set Initial Scaling ................................................................... 170
   Select Tick Styles ................................................................... 171
   Select Bar Style ..................................................................... 171

Embedding and Linking ............................................................... 173
   What is Embedding and Linking? ............................................. 173
   Original Cut and Paste Model ............................................... 173
   Embedded Objects .................................................................. 174
   Linked Objects ....................................................................... 174
   Using Embedding and Linking ............................................... 174
   Comparison of Data Transfer Types ....................................... 175
   Embedding and Linking without using the Clipboard .............. 175
   Embedding and Linking with GraFit ....................................... 175
   GraFit as an OLE container ................................................. 177
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>GraFit as an OLE source</td>
<td>177</td>
</tr>
<tr>
<td><strong>Data Fitting Basics</strong></td>
<td>179</td>
</tr>
<tr>
<td>When Is Data Fitting Appropriate?</td>
<td>179</td>
</tr>
<tr>
<td>Types of Data</td>
<td>179</td>
</tr>
<tr>
<td>Regression Analysis</td>
<td>181</td>
</tr>
<tr>
<td>Practical Considerations</td>
<td>181</td>
</tr>
<tr>
<td>Types of Regression Analysis</td>
<td>182</td>
</tr>
<tr>
<td>Linear Regression</td>
<td>182</td>
</tr>
<tr>
<td>Polynomial Regression</td>
<td>182</td>
</tr>
<tr>
<td>Non-linear Regression</td>
<td>182</td>
</tr>
<tr>
<td>Additional Considerations for Non-linear Regression</td>
<td>182</td>
</tr>
<tr>
<td>Weighting Scheme</td>
<td>183</td>
</tr>
<tr>
<td>Linear Regression of Transformed Data</td>
<td>183</td>
</tr>
<tr>
<td>Information Obtained from Data Fitting</td>
<td>184</td>
</tr>
<tr>
<td>Multiple Regression</td>
<td>185</td>
</tr>
<tr>
<td>Uses for Multiple Regression</td>
<td>185</td>
</tr>
<tr>
<td>Advantages of Multiple Regression</td>
<td>186</td>
</tr>
<tr>
<td>Disadvantages of Multiple Regression</td>
<td>186</td>
</tr>
<tr>
<td>Defining Equations</td>
<td>186</td>
</tr>
<tr>
<td>Fitting Data by Multiple Non-linear Regression</td>
<td>186</td>
</tr>
<tr>
<td>Data Fitting</td>
<td>188</td>
</tr>
<tr>
<td>Plotting Results from Multiple Regression</td>
<td>188</td>
</tr>
<tr>
<td><strong>Theory</strong></td>
<td>189</td>
</tr>
<tr>
<td>Regression Analysis</td>
<td>189</td>
</tr>
<tr>
<td>Assumptions in Regression Analysis</td>
<td>190</td>
</tr>
<tr>
<td>Linear Regression</td>
<td>191</td>
</tr>
<tr>
<td>Weighting</td>
<td>192</td>
</tr>
<tr>
<td>Weighting Types</td>
<td>193</td>
</tr>
<tr>
<td>Non-linear Regression</td>
<td>194</td>
</tr>
<tr>
<td>Standard Errors of the Calculated Parameters</td>
<td>194</td>
</tr>
<tr>
<td>Robust Weighting</td>
<td>194</td>
</tr>
<tr>
<td>Determining the Most Appropriate Weighting</td>
<td>196</td>
</tr>
<tr>
<td>Plot of Residual Errors</td>
<td>197</td>
</tr>
<tr>
<td>Testing Goodness of Fit — F Test</td>
<td>197</td>
</tr>
<tr>
<td>Mean and Standard Deviation</td>
<td>198</td>
</tr>
<tr>
<td><strong>Worked Data Fitting Examples</strong></td>
<td>199</td>
</tr>
<tr>
<td>Using One of the Equations Provided</td>
<td>199</td>
</tr>
<tr>
<td>Fitting the Data</td>
<td>200</td>
</tr>
<tr>
<td>Checking the Weighting</td>
<td>203</td>
</tr>
<tr>
<td>Drawing Residual Plots</td>
<td>203</td>
</tr>
<tr>
<td>Using Robust Weighting</td>
<td>206</td>
</tr>
<tr>
<td>Defining a New Equation (1)</td>
<td>207</td>
</tr>
<tr>
<td>Defining a New Equation (2)</td>
<td>210</td>
</tr>
<tr>
<td>Defining the Equation</td>
<td>211</td>
</tr>
</tbody>
</table>
Fitting the Equation.......................................................................................... 211
Multiple Regression .......................................................................................... 212
Displaying Multidimensional Data .................................................................... 213
Reading Values from a Calibration Curve........................................................ 215
Choosing an Equation to Fit the Data ............................................................. 215
Reading Values from the Fitted Curve............................................................. 217
Fitting Several Data Sets with Some Parameters Common and Some Specific...... 217
Method Used to Share Variables Between Data Sets......................................... 218
Example — Paired Denaturation Curves ........................................................... 220

**Equations Provided**......................................................................................... 223

- 2 Substrates .......................................................................................................... 224
  - Ping pong .......................................................................................................... 224
  - Ping pong Lineweaver Burk ............................................................................ 224
  - Ternary .............................................................................................................. 224
  - Ternary Lineweaver Burk ................................................................................ 224
- Enzyme Inhibition ............................................................................................... 225
  - Competitive Inhibition ................................................................................... 225
  - Competitive Eadie Hofstee ............................................................................ 225
  - Competitive Lineweaver Burk ....................................................................... 225
  - Mixed Inhibition ............................................................................................... 225
  - No inhibition ..................................................................................................... 225
  - Non-competitive Inhibition ............................................................................ 226
  - Non-competitive Eadie Hofstee .................................................................... 226
  - Non-competitive Lineweaver Burk ................................................................. 226
- Enzyme Kinetics .................................................................................................. 226
  - Allosteric kinetics (Hill) .................................................................................. 226
  - Allosteric kinetics (Hill), Linear plot ............................................................... 226
  - Enzyme Kinetics ............................................................................................... 227
  - Enzyme Kinetics, Eadie Hofstee ................................................................... 227
  - Enzyme Kinetics, Lineweaver Burk ............................................................... 227
  - Enzyme Kinetics, show Km ............................................................................ 227
  - Enzyme Kinetics, show Vmax ........................................................................ 227
  - Enzyme Kinetics, show Vmax over Km ........................................................... 227
  - Kinetics, contaminating S ............................................................................. 228
- Exponential ........................................................................................................... 228
  - Double Exponential ......................................................................................... 228
  - Double Exponential - phase 1 ........................................................................ 228
  - Double Exponential - phase 2 ........................................................................ 228
  - Double Exponential with offset ...................................................................... 228
  - Single Exponential ........................................................................................... 229
  - Single Exponential with offset ....................................................................... 229
  - Triple Exponential ............................................................................................ 229
  - Triple Exponential with offset ....................................................................... 229

**IC 50** ................................................................................................................. 229
Standard Templates

About the Standard Templates
Accessing Templates
Template Layout
Using Your Own Templates

Description of the Standard Templates
Enzyme Kinetics
IC 50
Ligand Binding
Linear Regression
Single Exponential

Hard-coded Equations

Overview of Hard-coded Equations
What are Hard-coded Equations?
Enabling Hard-coded Equations
Inserting a Hard-coded Equation Item
General Pane
Locating the Equation Library File
X Variables Pane
Parameters Pane ................................................................. 252
Constants Pane ................................................................. 253

GraFit Symbols Font ........................................................... 255
GraFit Symbols Font ........................................................... 255

Index ...................................................................................... 257
CHAPTER 1

Introduction

Welcome

GraFit version 5 for Microsoft® Windows™ combines presentation-quality scientific graphs with comprehensive data fitting. The result is a powerful package that is easy to use, produces stunning output, and can also fulfill the needs for quantitative data analysis. Data can be fitted using various types of theoretical models, and your own equations can easily be added to those supplied with the program. Comprehensive graph plotting facilities allow you to display your data on-screen and edit the graphs interactively.

Key Features of GraFit

GraFit provides the experimental scientist with a tool for visualization and analysis of their data. For the occasional user, GraFit can be configured to perform routine analyses with minimal intervention—in many cases it is possible just to enter the data and allow GraFit to calculate the results and plot the graphs in the background. Advanced users can utilize the full power of GraFit for analyzing complex equations, and may create custom fitting templates for routine data processing.
About this Guide

This manual describes how you can use GraFit to examine your data, and to plot graphs. We recommend that you read the manual fully, and try out some of the examples described.

Notational Conventions

The following notational conventions are used throughout this manual:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>SMALL CAPITALS</td>
<td>Small capitals indicate keys to be pressed. For instance, A indicates “press the ‘A’ key”. If more than one key needs to be pressed this is written as (for instance) SHIFT END which would mean “hold down the ‘Shift’ key and then press the ‘End’ key”.</td>
</tr>
<tr>
<td>Monospace</td>
<td>Monospace type indicates text that should be entered on the computer keyboard. For example, to obtain a directory of drive A: when in DOS you would enter DIR A: RETURN</td>
</tr>
<tr>
<td>Bold</td>
<td>Bold text is used for menu item commands, e.g. the Edit menu. Where cascading menus are present, an arrow (➔) is used to separate the sub-menus. For example, the Windows Control Panel application is started from the desktop Start ➔ Settings ➔ Control Panel command.</td>
</tr>
</tbody>
</table>

Important information that should be noted is written in italics, and separated from other text by horizontal rules, as here.

Contacting Erithacus Software

Address

Erithacus Software Limited
PO Box 274
Horley
Surrey
RH6 9YJ
UK
Technical Support

At Erithacus we are working hard to provide you with intuitive technical products. However, if you find yourself with a technical question that you cannot resolve, please contact our technical support department. Registered users can obtain technical support from one of the following sources:

- Fax: [+44] (0)1342 841 939
- Email: support@erithacus.com
- Internet: http://www.erithacus.com/grafit

Note Always quote your serial number and the product version, which are shown on the About screen (Help ➔ About GraFit command).

Internet

Our web site can be found at http://www.erithacus.com and here you will find latest information about our software products. In addition, we post technical notes, tips and answers to common problems.

Tip Be sure to check out http://www.erithacus.com/grafit to download the latest fixes and updates.
CHAPTER 2

Installation

System Requirements

Software
GraFit version 5 is a fully 32-bit program that requires Windows 95 or later, or Windows NT 4.0 or later. The Help system requires installation of Microsoft Internet Explorer version 3.02 or later. Microsoft Internet Explorer version 5 is supplied with GraFit, and unless you already have Internet Explorer version 4 or later installed it is recommended that you install this before installing GraFit.

Hardware
The minimum hardware required is a PC with a 100 MHz Pentium processor with 16 Mbytes RAM, and the recommended configuration is a 200 MHz Pentium with 64 Mbytes RAM or better. You need at least 10 Mbytes free space on your hard disk drive, and a mouse (or compatible pointing device). A CD-ROM drive is highly recommended, and although installation from 3½" disks is possible, 3½" media are not supplied as standard (see Installing GraFit for details on obtaining GraFit on 3½" disks). The CD-ROM includes optional tutorial files in the form of screen-capture movies; these files make use of sound, and so to view these you need a PC with a Windows-compatible sound system.

The GraFit Package
The GraFit package comprises the following:

- GraFit program CD-ROM.
- The GraFit User’s Guide (this manual). Depending upon the GraFit package that was purchased, this guide may only be available in electronic form on the CD-ROM.

When GraFit is first run you will be able to register the product. This will ensure that you are informed of the latest updates to the program.
Installing GraFit

CD-ROM Installation

Insert the GraFit CD-ROM into your CD drive. The Welcome screen will load automatically.

**Note** Some systems are configured so that automatic running of CD-ROM software is disabled. If your system is set up in this way, the Welcome screen can be displayed by selecting the Run command from the Windows Start menu, and entering the command D:\CDRUN where D: is the drive letter of your CD-ROM.

Microsoft Internet Explorer

GraFit uses a new HTML help system that will become a standard feature in the next generation of Windows. To use this help system, it is necessary to have Microsoft Internet Explorer (version 3.02 or later) installed on your computer. If you do not already have this software installed, select the **Install Internet Explorer 5.5** option and follow the instructions.

**Note** The installation of Internet Explorer will update some of the system files on your computer. If you are running Windows NT this will require Administrator privileges. Please consult your computer administrator if your account does not allow you to do this.

GraFit

Select the **Install GraFit** option to install GraFit onto your computer. The installation program will copy the files to your hard disk, and place an entry for the GraFit program on the Start button, under the Programs entry.

Adobe Acrobat Reader

The GraFit CD-ROM includes this user manual saved in Adobe Portable Document Format (PDF). If you wish to read this file, it is necessary to have the Adobe Acrobat Reader (version 3 or later) installed. If you do not already have this software installed, you can choose to do so by selecting **Install Acrobat Reader**.
Installation from Floppy Disks

GraFit is shipped as standard on CD-ROM, and no floppy disk media are provided. If you do not have a CD drive on your system, it is possible to install GraFit by one of the following routes:

- The program on 3½" disks is available from Erithacus Software for a nominal charge that covers media costs, plus postage and handling. Please contact Erithacus Software for pricing and availability (contact details are given in Chapter 1).

- It is possible to create a set of 3½" installation disks if you have access to another computer with a CD drive. You will need a number of blank, formatted 3½" disks. To create this disk set, double-click on the “Make Floppy Disk Set” file located in the root directory of the GraFit CD.

**Note** GraFit on floppy disk only includes the main GraFit program file. The CD-ROM version also includes electronic documentation and tutorials that are too large for 3½" media.

Uninstalling GraFit

GraFit can be removed from your system by the following procedure.

1. From the Windows **Start** menu, launch the Control Panel application from the **Settings** sub-menu.
2. Double-click the Add/Remove Programs icon.
3. Choose GraFit 5 to uninstall, and click the **Add/Remove** button.
4. Follow the instructions
Running GraFit

The GraFit installation program will add a GraFit entry to the Programs list on your Windows Start menu. When you run the GraFit program, the main GraFit window will open.

When initially opened, the GraFit workspace is empty.
The GraFit Workspace

A GraFit file can comprise one or more data tables, graphs, data analyses, equation definitions, transformation definitions, notepads and embedded objects. Collectively, these items make up the GraFit workspace, which can be stored to disk as a single file. After adding a number of items to the workspace, the appearance of the GraFit window is shown below.

In this example, one each of the following items has been added: a data table; a graph window; a non-linear fitting item; a linear fitting item; an equation definition; a notepad; a transformation definition and an embedded Microsoft Word document. All the added items are stored inside the same GraFit workspace, and
can be saved and loaded from disk using the File menu commands. If you run a second copy of GraFit, you can copy items between workspaces by drag and drop or by using the commands on the Edit menu to copy and paste items via the Windows Clipboard. Each item in the workspace is represented by an icon in the project window.

**GraFit Items**

GraFit items are initially created in a new window that resides within the main GraFit window, and are identified by the presence of an icon in the project window. Closing an item window does not delete the item — it simply makes the window invisible. This allows you to keep open only those items that you are currently working on.

**Managing Items**

**Adding New Items**

To add a new item to the workspace:

- Use the Add menu, or click on the item buttons in the workspace toolbar.

**Switching Between Items**

To switch between items:

- Click on the window to activate, or click on the icon that represents this item in the project window.

**Removing Items**

To delete an item from the workspace:

- Select the icon that represents the item in the project window, and choose the Edit ➨ Clear command.

**Item Representation**

When an item window is closed, the contents of the item still remain present in the GraFit workspace file. The item window can be reopened by double-clicking on the icon. The icon that represents the item is shaded so that it indicates the current state of the item, as shown below.
GraFit item, open. The icon is drawn normally.

GraFit item, closed. The icon is drawn as a ghosted image, which is lighter than normal.

Embedded object, open for editing. The object icon is shown overdrawn with hatched lines.

Embedded object, closed. The icon is drawn ghosted.

Linked object, closed. A shortcut overlay (🎁) is added to the icon.

Switch between item windows to edit their contents. Information about using each of the GraFit item types is found in Chapters 5-13.

**Editing the Item Name**

Items are referred to by the name shown in the project window, so it is useful to change this from the default to something more meaningful. To edit the item name, select the icon in the project window, and choose the **Edit ➔ Rename** command. Type in the new name.

Item names can contain any characters, but must be different from any other item name in the workspace.

**Changing the Item Icon**

The icon that represents an item may also be changed. This can be useful to allow similar items to be visually distinguished. To change the icon, select it and choose the **Window ➔ Icon** command. For each item type there are a number of alternative images that can be used. In addition, it is possible to use an icon image that resides in any executable or DLL file on your computer.
**Item-specific Commands**

Although some commands apply to all GraFit items, many are item-specific. For example, the **Fit Data** command applies to the Linear fit and Non-linear fit items, but not to the Data table or Graph items. Commands that are not available are shown grayed. In addition, each item window has one or more specific menus that are only present when this window is selected. For example, only graph items have **Graph** and **Object** menus.

**Printing the Item Contents**

The contents of any item window can be printed using the **File ➤ Print** command, and the printing previewed using the **File ➤ Print Preview** command.
Page Settings

The **File ➤ Page Setup** command allows the paper size and orientation to be specified, and the margin sizes to be entered. These settings are stored separately for each item in the workspace.

A header and footer are printed at the top and bottom of the page, respectively. The header and footer text can contain special strings such as the file name or the time that the item was printed. These special strings are specified by clicking on the **Header Fonts** button. To omit the header and/or footer from the output, leave the entries for the **Header text** and/or **Footer text** blank. The font used to display the header and footer text can be selected by clicking on the **Header Fonts** button.

**Changing the Printer**

To change the printer from the default, click on the **Printer** button.

**Stock Items**

Individual GraFit items can be stored for future reuse by selecting an item and using the **File ➤ Store Stock Item** command. They are reloaded using the **File ➤ Add Stock Item** command. Storing and loading of items is especially useful for saving and restoring equation definitions, but can be used for any GraFit item. See Chapter 4 for more information about the location of item files.
GraFit Templates

Workspace files can be created by adding a number of items as described above. Alternatively, it is possible to load a pre-built workspace from a template, using the File ➔ New command. See Chapter 4 for more information about using templates.

Accessing Help

GraFit includes a complete on-line help system to guide you through learning the product.

To view the help topics:

• From the Help menu, select the Contents command.

To obtain specific help on the function of a menu item, toolbar command or window item:

• Click on the Context Help toolbar button and then on the item for which further information is required.

To obtain specific help within a dialog box:

• Click on the Context Help button in the top right of the dialog box and then on one of the items in the dialog box.

Context sensitive help gives specific information on each item within the dialog box
CHAPTER 4

Working with Files

GraFit Workspace Files

The GraFit workspace consists of all the items displayed in the main GraFit window (data tables, graphs etc.). The contents of the workspace are stored together in a GraFit workspace file, which has the .GFF extension. In addition to the contents of the workspace, the current window sizes and positions are also stored in the workspace file.

Opening an Existing File

Choose the File ➔ Open command to open an existing GraFit workspace file. This will bring up the Open dialog box, as shown below.

![Open dialog box]

The buttons marked User Data and User Template allow you to change directory rapidly to the default data and user template directories respectively. (The locations of these special directories are chosen from the View ➔ Options menu.) By default, GraFit workspace files are listed, but you can elect to display (and open) GraFit template files by changing the Files of type selection.
**Saving a File**

GraFit workspace files are saved using the **File ➤ Save** or **File ➤ Save As** commands. The contents of the workspace are saved, along with the current window positions and order. When the file is reloaded, these positions and order are restored.

**Loading and Saving Individual Items**

**Saving Items**

The GraFit workspace comprises a number of individual items, such as data tables, graphs and analyses. These individual items are saved in one of the following ways:

- Select the item in the Project window, and then issue the **File ➤ Store Stock Item** command.
- From the open item window, select the **File ➤ Store Stock Item** command.

By default, items should be saved in the item store directory, or a subdirectory off this. (The location of the item store directory is specified using the **View ➤ Options** command.)

**Loading Items**

Stored items can be loaded using the **File ➤ Add Stock Item** command.

**Creating a New File**

To reset the GraFit workspace:

- Click on the File New toolbar item  

**Note**  
This command is different to the **File ➤ New** menu command, which loads a new file based on a template.

**Importing Data Files**

Data can be imported into GraFit to create a new data table item that holds the imported data. To create this item, select the **File ➤ Import Data** command from the main GraFit window. Any file for which a filter is available can be imported into GraFit (see the following section on Import/Export Filters).

It is also possible to paste data from a file directly into an open data table. To do this, use the **Edit ➤ Paste From** command of the data table item.
Import/Export Filters

In order to perform conversions between GraFit and other data types, GraFit uses installable import/export filter files. Several standard filter types are supplied by default with GraFit, and other filters may be available from certain instrument manufacturers or from Erithacus Software. These filter files are installed into GraFit from the `View ➔ Options` dialog box, Data Filters tab.

Please contact Erithacus Software if you have special requirements for a specific filter file.

GraFit Template Files

Template files are pre-made workspace files that are used to speed up use of common procedures. Template files differ from workspace files in the following ways.

- They are represented by a different icon.
- Double-clicking on a template file opens a copy of the file rather than the file itself.
- Templates stored in the user or group template directories can be rapidly accessed using the `File ➔ New` command.

Creating a Template File

To store a workspace as a template file, select the `File ➔ Save As` command, and save as type “GraFit Template Files.” If you wish to access this template using the `File ➔ New` command, ensure that the file is saved into your user or group template directory (see the following section on Template Directories). To help with this, the Save As dialog box contains a command button that will jump immediately to your user template directory.

Creating a File Based on a Template

The `File ➔ New` command creates an untitled file based on a selected template. This command in described in the following section. Chapter 23 describes the standard templates that come pre-defined with GraFit.

Template Directories

There are two directories that have special significance when storing template files. These are the user and group template directories, the location of which is specified from the `View ➔ Options` command, Directories tab:
Click on the button to change a directory setting. By having two separate locations for templates it is possible to keep user-specific files separate from general templates that are used by a group of users. It can be useful, as illustrated above, to maintain a group directory on a network server.

Files in a template directory appear on the General tab of the File ➔ New dialog box. Any subdirectories have special significance, and result in additional tabs on this dialog; clicking on the tab accesses the files in these subdirectories. (Note that empty subdirectories do not appear).
The files displayed on this dialog box are the sum of those present in the user and the group template directories. (The specific location of any individual file can be found by right-clicking on the icon, and choosing the **Properties** command. In the event that a file with the same name is found in both the user and group directories, the user file has precedence.) To create a new workspace file based on one of these templates, select the one to use and click **OK**.
The Data Table Item

To add a new, empty data table to the GraFit workspace:

- Click the data icon on the Workspace toolbar, or select the Add ➔ Data Table command.

The parts of the data table window are shown in the following illustration.

Position row 1 column 1 in the above figure is marked by a dark outline; this is the current data entry position. Data entries are edited in situ by typing in the new entry. When the entry is complete, pressing RETURN, TAB or a cursor key, or clicking the mouse on a different position in the data table, will accept the data, and move
the data entry position. To edit the value at the current data entry position, select the Edit ➨ Edit Current Cell command, or press F2.

The following table describes the elements in a data table. Certain sub-regions are distinguished by the mouse cursor changing shape when it is over them.

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
<th>Cursor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data table</td>
<td>The data values themselves are listed in the data table. Click the mouse on a value to move the data entry position; drag the mouse to select larger regions of the data table. Newly entered data is placed at the data entry position, which can be moved using the cursor keys or by clicking the mouse on a different part of the data table.</td>
<td></td>
</tr>
<tr>
<td>Column selection region</td>
<td>Click and drag the mouse on the column numbers to select entire columns of data.</td>
<td>↓</td>
</tr>
<tr>
<td>Column resize region</td>
<td>Click and drag the edges of a column to resize it.</td>
<td>↔</td>
</tr>
<tr>
<td>Row selection region</td>
<td>Click and drag the mouse on the row numbers to select entire rows of data within the data table.</td>
<td>→</td>
</tr>
<tr>
<td>Row resize region</td>
<td>Click and drag the edges of a row to resize it.</td>
<td>↓</td>
</tr>
<tr>
<td>Split table horizontally</td>
<td>Drag the splitter box on the horizontal scroll bar to divide the data table window in two. The two halves can be independently scrolled, allowing distance regions of the table to be viewed simultaneously.</td>
<td>↔</td>
</tr>
<tr>
<td>Split table vertically</td>
<td>Drag the splitter box on the vertical scroll bar to divide the data table window in two. The two halves can be independently scrolled, allowing distance regions of the table to be viewed simultaneously.</td>
<td>↕</td>
</tr>
</tbody>
</table>

**Resizing Rows and Columns**

The row height and column width can be set using the Table ➨ Row Height and Table ➨ Column Width commands, respectively, or by using the mouse to drag the edges of the rows or columns within the row or column selection region. Columns can be sized to fit their contents using the Table ➨ Size Column to Fit command.

**Data Types**

The number of data points that can be entered is limited only by available memory. The data are grouped into columns, and the contents of one or more columns can be used for data fitting or graph plotting.
Within a column, each individual cell holds a data value that may be one of three different types:

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Numbers</strong></td>
<td>Numbers are the most common data form that will be entered into GraFit. They are used to plot ( x/y ) scatter plots, and for data fitting by regression analysis. Very small or large numbers can be entered in exponential format, for example ( 1e7 ) is equal to 10000000, and ( 1e-23 ) represents ( 10^{-23} ).</td>
</tr>
</tbody>
</table>

**Note** The representation of numbers, particularly the symbol used for the decimal point, differs from country to country. By default, GraFit uses the country-specific settings selected for your Windows installation (using the Control Panel application, Regional Settings). However, you can override these from the **View ➔ Options** dialog box, Number Format page.

| **Text**    | Text entries can be used for annotation, and are also used to provide the text for the category axes of charts. Text values are treated as missing data during data fitting. |

| **Missing Data** | Experimental data often contain certain values that are not available (perhaps because that particular experimental sample was the one that fell on the floor!). GraFit allows you to insert “missing” values by leaving the data entry blank. All the graphing and data fitting elements of the program will recognize such points, and omit them from the analysis. |

The representation of these different data types is illustrated in the following diagram.
Forcing Text Entry

GraFit displays text items as they are entered, but formats numbers dependent upon the current column formatting (Table ➨ Column Format command). To force numbers to be treated as a text item, enter them with a preceding ' symbol, for example:

'2.34

Forcing text entry can be useful if a number is used as one of the entries in the category axis of a chart.

Note  Numbers forced to act as text are not available as data items, and will be treated as missing items during data fitting.

Moving the Data Entry Position

When you have entered your data value you will need to move to the next data entry position by pressing TAB, RETURN or DOWN after entering the value. The following keys control movement of the data entry position within the data table.

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the entry point to the right</td>
<td>TAB or RIGHT</td>
</tr>
<tr>
<td>Move the entry point to the left</td>
<td>SHIFT TAB or LEFT</td>
</tr>
<tr>
<td>Move the entry point up</td>
<td>UP</td>
</tr>
<tr>
<td>Move the entry point down</td>
<td>DOWN or RETURN</td>
</tr>
<tr>
<td>Move to the first column of a row</td>
<td>CTRL LEFT</td>
</tr>
<tr>
<td>Move to the last column that contains data entries</td>
<td>CTRL RIGHT</td>
</tr>
<tr>
<td>Move to the first row of a column</td>
<td>CTRL UP</td>
</tr>
<tr>
<td>Move to the last row that contains data entries</td>
<td>CTRL DOWN</td>
</tr>
<tr>
<td>It is often convenient to press RETURN or DOWN between entering data points.</td>
<td></td>
</tr>
</tbody>
</table>

Note  If you have a region of the table selected, pressing RETURN will move the data entry position left to right within the selected region. If you prefer to enter \{x, y\} data pairs in sequence \"x_1, y_1, x_2, y_2, ...\" then it is convenient first to select the columns (see “Selecting Entire Columns”) that will hold the data and then to enter the values, pressing RETURN between each data entry.

Moving the data entry position using the mouse

To move the data entry position using the mouse, move the mouse pointer to the position you require, and click the left mouse button.
Selecting Regions of the Data Table

Selecting Part of the Data Table

To select a portion of the data table, drag the mouse over the required region. Alternatively, hold down the \texttt{SHIFT} key, and use the cursor keys to extend the selection. The selected region is displayed inverted, as shown below.

![Data Table Image]

Clicking the mouse within the row selection area results in the entire row being selected.

**To make a more extensive selection:**
Click on the start position.

- Use the scroll bars to move the window as necessary.
- Hold down the \texttt{SHIFT} key, then click on the end position for the selection.

**Discontinuous selection**

- Hold down the \texttt{CTRL} key and click the required entries.
Selecting Entire Columns

Whole columns of data are selected by clicking on the column selection region. The selected column is displayed inverted.

Drag the mouse along the column selection region to extend the selection. In a similar fashion, clicking in the row selection region allows whole rows to be selected.

Copying and Pasting Data

Selected regions of the data table are copied to the Clipboard using the Edit ➔ Copy command, and pasted using Edit ➔ Paste. Data may also be pasted to and from other applications in the same way.

Copying and Pasting Regions of the Data Table

1. Select the region of data that you wish to copy.
2. Choose the Edit menu, and select Copy.
3. Move the data entry position to where the data is to be copied.
4. Choose Edit ➔ Paste. The data will be inserted at the data entry position.

Copying and Pasting Columns

Entire columns of data can also be copied and pasted. Pasting into the data table when a column is selected results in the pasted values being placed in a new column, in front of the selected column.
1. Select the column(s) of data that you wish to copy.

![Image of data table](image1)

2. Choose the **Edit** menu, and select **Copy**.

3. Select the column in front of which the data are to be inserted.

![Image of data table](image2)

4. Choose **Edit ➨ Paste**. When pasting into a fully selected column, you have the option to overwrite the selected data or to insert the new data in front of the selection (the overwrite option is only available if the number of columns available to paste is the same size as in the selected region).

![Image of paste columns dialog](image3)

The data are then pasted into the table.
Removing Data

Clearing a Region of Data

The Edit ➨ Clear command, or the Del key, can be used to clear the currently selected data or columns.

1. Select the data value(s) (or columns or rows) to be cleared.
2. Choose **Edit ➤ Clear**, or press **DEL**.

![Data Table Example](image)

Data in the selected region are cleared, leaving a gap in the table.

**Deleting a Region of Data**

Select the data value(s) (or columns or rows) to be cleared.

Choose **Table ➤ Delete** command.

When deleting a range of cells, the data values are moved up so that no gap appears in the table. When deleting a column, the remaining columns to the right of the selection are moved along to fill the gap.

**Inserting Values into the Table**

Values are inserted into the data table using one of the **Table ➤ Insert** commands.

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Table ➤ Insert Cells</strong></td>
<td>Inserts blank cells in place of the current selection. Cells are moved down to accommodate the new entries.</td>
</tr>
<tr>
<td><strong>Table ➤ Insert Column</strong></td>
<td>Inserts blank columns in place of the current selection. Columns are moved to the right to accommodate the new entries.</td>
</tr>
<tr>
<td><strong>Table ➤ Insert Row</strong></td>
<td>Inserts blank rows in place of the current selection. Rows are moved down to accommodate the new entries.</td>
</tr>
</tbody>
</table>
Sorting Data

The data in one or more columns can be sorted into ascending or descending order using the **Table ➤ Sort Column(s)** command, after first selecting the columns that you wish to sort.

The **Index column** selection specifies the column on which the sort order is based. In addition to this column, any of the other columns can be included in the sort by checking the box to the left of the column name.

Data Table Appearance

**Colors and Fonts**

The colors used to display the items in the data table, and the font that is used to draw the table, are set using the **Table ➤ Preferences** command.

**Number Format**

The manner in which numbers are formatted for display can be set on a column by column basis. The **Table ➤ Column Format** command is used to control the displayed numerical precision. This command applies to all columns that fall within the current selection.
Chapter 5: Data Tables

Column Format dialog box

<table>
<thead>
<tr>
<th>Specification</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal places</td>
<td>Enter the number of decimal places to be displayed for numbers.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> <em>To ensure that all decimal places are displayed set Trailing zeros in fraction to “Show 0’s.”</em></td>
</tr>
<tr>
<td>Max digits</td>
<td>Enter the maximum number of digits to use when displaying numbers.</td>
</tr>
<tr>
<td>Thousands separator</td>
<td>Check this box to include a grouping separator. The symbol used for this separator, and the number of digits in the group, are set for the View ➤ Options command on the main GraFit window.</td>
</tr>
<tr>
<td>Scientific format</td>
<td>Check this box to display the values using scientific format (e.g. -2.435e003 instead of -2435.000).</td>
</tr>
<tr>
<td>Use scientific format for small values</td>
<td>Check this box to ensure that small values, which would otherwise be displayed as 0.0000, are shown in scientific format (e.g. 2.0987e-008).</td>
</tr>
<tr>
<td>Trailing zeros in fraction</td>
<td>Chooses the way that trailing zeros are displayed in the formatted numbers. It is possible to show the “0” characters, to omit them, or to replace them with spaces.</td>
</tr>
<tr>
<td>Save As Defaults</td>
<td>Stores the current settings as the default for future GraFit sessions.</td>
</tr>
<tr>
<td>Restore Defaults</td>
<td>Restores the current GraFit formatting defaults to the selected columns.</td>
</tr>
</tbody>
</table>
Magnification

The magnification of the data table text can be adjusted to allow more or less values to be visible. Magnification is controlled by the View ➤ Zoom command, or by using the zoom control on the Standard toolbar.

Changing the magnification and altering the font size (Table ➤ Preferences command) both modify the size of text displayed on-screen. However, changing font size using Table ➤ Preferences also changes the size of printed text, while View ➤ Zoom only affects the on-screen appearance.

Importing and Exporting Data

Importing Data

To import data into a data table, position the data entry position where you want the data values to start and select the Edit ➤ Paste From command. Select the file that holds the values to import, and press the Open button. The contents of the file will be inserted into the data table.

Importing Data as a New Data Table

It is also possible to import a file into the GraFit workspace as a new data table item. To import a data file in this way, use the File ➤ Import Data command.
### Exporting Data

To export data from a data table into a file that can be read by other programs, select the range of values to be exported and use the **Edit ➔ Copy To** command.

The **Save as type** entry determines the format in which to save the exported data. GraFit supports a number of data export formats, and the available types are listed in this box. GraFit supports export as ASCII, DIF and CSV formats as standard, though additional formats may be available.

### Column Types

Columns can hold simple data values, or can be set to hold the results of various calculations or data manipulations. For example, a column can hold the difference between the values in two other data columns. The results of these calculations are automatically updated when the source data change, allowing powerful processing of the underlying data.
Example: setting up a difference calculation

As an illustration, we will show how to set up the following data table in which the third data column holds the difference between the values in the first and second columns.

```
<table>
<thead>
<tr>
<th>Column Name</th>
<th>Value 1</th>
<th>Value 2</th>
<th>Difference</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>4.3000</td>
<td>2.1000</td>
<td>2.2000</td>
</tr>
<tr>
<td>2</td>
<td>3.5000</td>
<td>4.6000</td>
<td>-1.1000</td>
</tr>
<tr>
<td>3</td>
<td>6.2000</td>
<td>5.6000</td>
<td>0.6000</td>
</tr>
<tr>
<td>4</td>
<td>4.6000</td>
<td>3.6000</td>
<td>1.0000</td>
</tr>
<tr>
<td>5</td>
<td>4.0000</td>
<td>3.9000</td>
<td>0.1000</td>
</tr>
</tbody>
</table>
```

The column type of the third column needs to be set by moving the data entry position to somewhere within this column and choosing the Table ➤ Column Type ➤ Column Combinations ➤ A-B command. Alternatively, the Column Type submenu can be accessed by double-clicking in the type area of the column. For this column type setting, the following dialog is displayed.

Choosing Value 1 as the first column and Value 2 as the second gives the result above. The values that are displayed in this column cannot be overwritten or edited, and are updated whenever the values in the source columns changes. The text color of the calculated values can be adjusted using the Table ➤ Preferences command, but is typically shown a different color than the editable text in order to distinguish it. The dialog settings for the calculated values can be altered by repeating the command, or by choosing the Table ➤ Column Properties command, which corresponds to the toolbar command.
To reset the column type to the default (non-calculated) settings, choose Table ➔ Column Type ➔ (General).

**Note**  Even though columns that hold calculated values do not allow these values to be edited, it is always possible to modify the column name entry.

**(General) Column Type**

By default, all columns are set to be of (General) type, and hold general data values that can be edited normally.

**Data Types**

The column types under this submenu are used to designate that the column holds a certain type of data, which may have associated additional values. The entries in the column are editable, but the data held in the column may have special significance for data fitting.

**x Data**

You may optionally select this column type if the data in the column are used as the $x$ values for data fitting. Designating a column to contain $x$ data is not essential for data fitting, but can be useful to document the data layout.

**x(n) Data**

When fitting an equation that has more than one independent ($x$) variable, one way to hold the data is to have $n$ separate columns for the different $x_n$ values. During the data fitting, GraFit needs to know which column holds which $x_n$ data set. This is done by setting the column type to **x(n) Data**, which gives the following dialog:

![X (n) Data Column](image)

It is necessary to have one $x(n)$ Data column for each independent variable in the equation, and these must have their **X data set #** entries set to correspond to the $X$ variables number in the equation definition. See Chapter 6 for information about using this option when fitting data.
y Data
You may optionally select this column type if the data in the column are used as the y values for data fitting. Designating a column to contain y data is not essential for data fitting, but can be useful to document the data layout.

y Data with Associated Value
It is common that an equation has two independent (x) variables. Under these circumstances, the most usual way of collecting data is to measure a series of y values at varying x1 for a fixed x2, then to collect a further set of y values at the next x2 value, etc. For example, the variation of enzyme catalyzed reaction rate might be measured as a function of substrate concentration at a certain fixed inhibitor concentration. The measurements are then repeated at the next inhibitor concentration and so on. Here, the second independent variable (x2, in this example is the inhibitor concentration) is the same for an entire set of x1, y (substrate, rate) data pairs. Under these circumstances, it simplifies the data entry to associate a single x2 value with a whole column of different y values. This is done by specifying the column type as y Data with Associated Value. (This command is also available from the Data toolbar, ).

The x2 data value is entered in the above dialog, and is normally displayed in the column type area. Data columns that have associated values are used when fitting to equations with two independent variables. See Chapter 6 for information about using this option when fitting data.

Up to four values can be associated with a data column, allowing x2, x3, x4 and x5 values to be stored, if required, for equations having up to five independent (x) variables. If your equation definition has only 2 independent variables, the values for x3, x4 and x5 are ignored.
**Column Combinations**

These column types allow the values within the designated column to be the result of an arithmetic combination of two other columns. In each case, the number of calculated entries depends upon the number of values in two selected columns, and the values are updated whenever one or more data values in the source columns change.

**A-B**

The column holds the result of subtracting values from the second column from those in the first.

**A+B**

The column holds the sum of adding values in the first and second columns.

**A/B**

The column holds the result of dividing values in the first column by those in the second.

**A.B**

The column holds the product of values in the first and second columns.

**Statistics**

The column types under this submenu allow the result of various statistical procedures to be displayed in the column.

**Mean**

Each row entry in the column is set to be the calculated mean of the corresponding values from the columns selected in the above dialog.

\[
\bar{x} = \frac{1}{N} \sum x_i
\]
The calculated values are updated whenever one or more values within the selected columns is modified.

**No. Data Points**

Each row entry in the column is set to be the number of data values \((N)\) present in the corresponding rows from the selected columns. This will be less than the total number of selected columns if missing data values are present.

**Standard Deviation**

Each row entry in the column is set to be the calculated standard deviation of the corresponding values from the columns selected in the above dialog. Standard deviation, \(\sigma\), is defined as:

\[
\sigma = \sqrt{\frac{1}{N-1} \sum (x_i - \bar{x})}
\]

**Standard Error of the Mean**

Each row entry in the column is set to be the calculated standard error of the mean for the corresponding values from the columns selected in the above dialog. SEM, \(\sigma_{\mu}\), is defined as:

\[
\sigma_{\mu} = \frac{\sigma}{\sqrt{N}}
\]

**Column Summary**

The entries in the column give a summary of the values present within a single selected column.
This summary gives the number of data points, minimum and maximum data values, the data range, sum, mean, median, variance (calculated for a divisor of $n$ and of $n-1$) and standard deviation (calculated for a divisor of $n$ and of $n-1$).

**F Test**

The entries in the column show the results of performing an $F$ test comparing the goodness of fit of two fitting analyses that use different equations. A fuller description of this test is found in the theory section (Chapter 20), but briefly the $F$ test evaluates whether one fit is significantly better than another. This test can be used to ascertain whether it is realistic to use an equation with additional parameters over a simpler version, or whether one equation fits a data set significantly better than does a second. For example, the analysis shown below fits an exponential decay to a single exponential equation:

$$y = Ae^{-kt}$$

In addition it fits the data to an equation that has an additional background parameter:

$$y = Ae^{-kt} + \text{background}$$

A sample set of data fitted to each of these equations is shown below.
Using the $F$ test, it is possible to test whether the data are fitted significantly better by the presence of the extra parameter.
The results show that the probability that the two fits are equally appropriate is 0.0016 or 1.6%, which is low. This indicates that we can have reasonable confidence in the merit of including the extra parameter (generally we require this value to be <5%, but may prefer a value <1% to be sure).

Note Although the F test results have been shown incorporated into the same data table as the raw data, it is also possible to create the analysis in a separate data table. Using separate data tables can be preferable if you wish to keep the raw data separate from any analysis.

Data Fitting

The column types under this submenu allow the results from data fitting to be displayed in a column, or entry of parameter/constants values associated with an equation. This lets the results be viewed, but more importantly allows the values to be used for subsequent analyses. For example, the results of one set of data fitting might provide the source data for subsequent fits.
Results

This column type lists the results from data fitting.

After the fit to be displayed is selected, the parameters available are listed. Some or all of these can be included by clicking in the check box to the left of the parameter name. If more than one set of data were analyzed in the selected fit, the results for each fit are given. It is possible to display either the fitted parameter value, or the fitted standard error value, as chosen in the Display settings. In addition, the name of the parameter can optionally be displayed next to the data value, by checking the Value name option.
**Information**

This column type lists information about a data fitting item. After the fit to be displayed is selected, the available information items are listed. Some or all of these can be included by clicking in the check box to the left of the parameter name. If more than one set of data were analyzed in the selected fit, the information for each fit is given. The name of the information type can optionally be displayed next to the data value, by checking the **Display value name** option.

**Parameter Entry**

The Parameter Entry column type gives a convenient way of entering parameter values for a particular equation into a column. Certain graph plotting options allow these values to be used when displaying graphs. The equation to use is selected, after which it is possible to enter values into the column.
The column display differs from normal in that the name of the parameter remains displayed on the left, with the value on the right. When a new parameter value is entered from the keyboard, the parameter name remains but the revised value is displayed in the table.

**Constants Entry**

The Constants Entry column type allows the values of any constants associated with an equation to be entered in the data table. This option works in the same way as the Parameters Entry option described above, but shows the constants associated with the selected equation.

**Calculated Values**

The column types under this submenu allow the $x$ or $y$ values to be calculated using the results from a data fitting item.
**x Values**

Use this column type to calculate theoretical x values corresponding to user-entered y values, according to the fitting model described in a selected workspace item.

Values are calculated for x values that correspond to the y values present in the selected Y data column entry.

A potential problem with calculating x values for a given y value is that some equations will have multiple solutions. For example, consider the curve shown below:
At $y = 6$ the value of $x$ read from the curve is 3.4; but at $y = 3.5$ there are three $x$ values, 0.55, 1.52 and 2.9. Clearly, whether the curve is single or multiple-valued in $x$ depends upon the equation in use and the value of $y$ that is used.

To overcome this complication it is necessary to specify limits to the $x$ values between which the data are to be calculated. The **Interpolate between X limits** entries in the above dialog control the range between which the values are tested. For example, in the plot above the solution $x = 1.52$ at $y = 3.5$ would be correctly found by setting interpolation limits between $x = 1$ and $x = 2$. 
y Values

Use this column type to calculate theoretical $y$ values corresponding to user-entered $x$ values, using the fitting model described in a selected workspace item.

All fitted GraFit equations have only a single $y$ value that corresponds to each $x$ value, and so there is no need to specify interpolation limits as in the previous column type.

When calculating $y$ values, it is possible to choose whether to use the fitted values or the explicit initial estimates that were used in the Estimatrix (see Chapter 6). This allows the generation of a hypothetical data set, which would result from the initial estimate values. When no initial estimates were used, these options are unavailable (as in the figure above, as the estimates were generated automatically for the equation used).
**Difference**

Use this column type to calculate the difference between the experimental and the calculated $y$ values, using the fitting model described in a selected workspace item.

Plots of difference versus $x$ or $y$ values are very useful to indicate whether the calculation accurately reflects the variation in the data. A good fit is characterized by a random distribution of (small) differences between the raw and fitted data.

**Data Processing**

The column types under this submenu allow various types of processing to be performed to generate data values for the column.

**Calculated Function**

The calculated function column type fills the selected column with the results of a user-defined function. This column type can be used to perform sophisticated processing of data, including background subtraction, calculation of logarithmic values and complex rescaling. The calculated function dialog box is shown below.
The **Number of Rows** of data to be calculated can be a defined number, or can be set to be the same as the number of entries in one of the other columns. The function definition is entered into the **Result** = field, and uses the same syntax as is used for equation definitions (see Chapter 9). By default, the text entered into this field is used to calculate a result without the need for an explicit assignment statement. However, the name “Result” is predefined so that it is possible to assign values using a “Result =” statement. In addition to the standard arithmetic functions (sin, cos etc.), the following can be included within this definition:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data(x,y)</td>
<td>Returns the data value present within the data table at column x, row y.</td>
</tr>
<tr>
<td>ValidData(x,y)</td>
<td>Returns <strong>TRUE</strong> if a valid number is present in the data table at column x, row y, and <strong>FALSE</strong> otherwise.</td>
</tr>
<tr>
<td>SetBlank</td>
<td>If this statement is encountered, the current cell is set to be blank and the calculation skips to the next row.</td>
</tr>
<tr>
<td>Column</td>
<td>Returns the number of the current column. This value is most useful in conjunction with the Data() function.</td>
</tr>
<tr>
<td>Row</td>
<td>Returns the number of the current row. This value is most useful in conjunction with the Data() function.</td>
</tr>
<tr>
<td><em>rnd</em></td>
<td>Returns a random number between 0 and 1.</td>
</tr>
<tr>
<td><em>grnd</em></td>
<td>Returns a random number that falls within a Gaussian distribution that has a zero mean and unit variance.</td>
</tr>
</tbody>
</table>
The following examples show how calculated functions might be specified and used.

<table>
<thead>
<tr>
<th>Process</th>
<th>Result = field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background subtraction</td>
<td>Data(1, Row) - 0.234</td>
<td>Subtracts the value 0.234 from the values in column 1.</td>
</tr>
<tr>
<td>Log calculation</td>
<td>log( Data(2, Row) )</td>
<td>Takes the logarithm (to base 10) of the values in column 2.</td>
</tr>
<tr>
<td>Complex rescaling</td>
<td>(Data(1, Row) * 1.34) - Data(2, Row) / Data(3, 2)</td>
<td>For each row in column 1, multiplies this value by 1.34, then subtracts the data in column 2 which has been divided by the value in column 3 row 2.</td>
</tr>
<tr>
<td>Multiple line statement</td>
<td>If (ValidData(1, Row) Then Result = Data(1, Row) + 23.3 Else SetBlank EndIf</td>
<td>For each valid data entry in column 1, sets the corresponding entry in the current column to be 23.3 greater.</td>
</tr>
</tbody>
</table>

*Note* It is essential to inform the program, by checking the appropriate boxes, which columns (if any) the calculation depends upon. Failure to do this will result in the calculation not being updated correctly when these values change.
**Derivative**

The derivative column type fills the column with the calculated derivative (order 0 to 5) of a selected source data column. The contents of the source column are not affected by this operation.

Calculation of derivatives for a set of data is performed after application of Savitzky-Golay smoothing to the source data, and so it is necessary to set the Savitzky-Golay smoothing factors. A full description of Savitzky-Golay smoothing is found under the **Smooth** data processing type.

**Series**

The series column type provides a convenient way of filling a column with a series of equally spaced values, for example, time-series values.
Smooth

This fills the selected column with the result of applying a Savitzky-Golay smoothing function to a source data column. The contents of the source column are not affected by this operation.

Savitzky-Golay smoothing is probably the most effective means of smoothing a set of data in such a way that noise is removed without too much loss of resolution (as happens with simple moving window averaging). In this smoothing procedure, the underlying function is approximated by a polynomial fit applied to a window of points around each data value. The degree of smoothing is therefore controlled by the window width, and by the order of the polynomial applied. The lower the order of the polynomial or the greater the window width, the smoother the result but at the expensive of losing resolution. For a polynomial order of 4, best results are obtained when the window width is between 1 and 2 times the full width at half of maximum of the desired features in the data. An excellent discussion of the effects of various smoothing parameters can be found in Press, W.H., Teukolsky, S.A., Vetterling, W.T. & Flannery, B.P. (1992) *Numerical Recipes in C*. Cambridge University Press.

Warning  Smoothing of data should always be undertaken with care. Although smoothing can improve the appearance of a set of data, this improvement is cosmetic only. If you are fitting data, it is almost always preferable to fit to the raw data values rather than the smoothed ones.

Subset

Data that are imported from other applications, or obtained from an instrumental source such as a spectrometer, often have more data values than are necessary to define the experimental curve. For example, the data obtained from a spectrometer may contain more than a thousand points; fitting so many points would be extremely time consuming, and would not necessarily give a “better” fitted value
than if (say) thirty points spread over the data range were analyzed. The Subset
type fills the column with a subset of the data values present in one of the other
columns, and provides a convenient means of reducing the number of data values
for analysis.

Select the source data column, and enter a value in the **Retain 1 point in every**
field. For example, choosing to retain one data point in every 10 of a data set that
has 200 data values would fill the column with point 1, 11, 21... giving 20 data
points in this column. The contents of the source data column are not affected by
this operation.

### Locking a Data Column

It is possible to lock a data column to prevent any further modifications being made
to the values that are present. To lock one or more columns:

- Move the data entry point to the column that you wish to lock, or select a
  range of values encompassing the columns that you wish to lock.

- Choose the **Table ➤ Lock Column** command, or click the button on the
  toolbar.

Repeat these actions to unlock the column(s).
Overview of Non-linear Fitting

A non-linear fit item is used to control data fitting by non-linear regression. This item specifies the data source and equation to use, and also presents the results of the data fitting. The item is created from the main GraFit window using the Add ➔ Non-linear Fit command. The non-linear fit window itself contains a tabbed dialog box with several panes that are used to specify how the fit is calculated. Each of these panes is discussed below. Data fitting involves making appropriate selections in the Settings pane (and possibly one or more of the other panes as described below), then selecting the Calculate ➔ Fit Data command. After fitting the data the results can be viewed from the Results pane.

Differences from Linear Fitting

Non-linear regression allows much more general equations to be used for analyzing data. The biggest practical difference, however, is that non-linear regression requires starting estimates of the unknown parameter values; linear regression needs no such estimates.

Status Bar Indicators

When a fitting item is selected, the status bar shows the current fitting status, indicating whether the item is Fitted or Not Fitted. In addition, the status bar shows when a calculation is in progress. Whenever any calculation is being processed, the calculation pane shows an animated abacus.
Settings Pane

The Settings pane is used to specify the main details of the fit.

The Settings pane of the Non-linear Fit item

Equation

Choose the equation to use for the data analysis. The equation must exist as a separate item within the main GraFit window. See Chapter 9 for information about equation items.

Weighting

All types of regression analysis require information about the error distribution in your data. The reason for this is explained fully in Chapter 20, but briefly it is necessary to specify whether the inaccuracies are likely to be the same for each data point ("Simple" weighting), are proportional to the value of the $y$ data points ("Proportional" weighting) or have been individually estimated ("Explicit" weighting). The default Simple weighting is often the most appropriate setting.

Robust weighting is additional weighting that provides a way of removing outliers (see Chapter 20). Check the Robust box to add robust weighting to the fit.

Data Table

The data to be fitted must reside in a separate data table item within the GraFit workspace. Select the table that holds the data from this drop-down list.
Data Layout

The data layout specifies how the data are arranged for data fitting. The default layout, as shown in the figure above, is that the x and y data columns are to be selected individually. This is used to fit a single \{x, y\} data set. It is also possible to specify that multiple data sets are present, which will result in several sets of results being generated. The available options for a standard equation having a single independent variable are given below.

<table>
<thead>
<tr>
<th>Layout</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>y</td>
</tr>
<tr>
<td>x</td>
<td>y_1</td>
</tr>
<tr>
<td>x_1</td>
<td>y_1</td>
</tr>
</tbody>
</table>

Equations with Multiple Independent Variables

Equations that have multiple independent variables (x axes) need to access multiple x data columns. They therefore have a different set of data layout options.

<table>
<thead>
<tr>
<th>Layout</th>
<th>Meaning</th>
</tr>
</thead>
</table>
| x(2) from y header | x | y_1 | y_2 | ... | This option is only available if there are two independent variables. In these circumstances, it is often the case that a series of y data values are collected at a fixed value of the second x variable. For example, the progress of a reaction might be collected with time at a number of different reagent concentrations. The first x variable would be time, the second would be reagent concentration. Within the data table it is possible to associate a value with an entire column; when this layout is selected the associated value is taken as the second x variable. The associated value is set by setting the column type to "y Data with Associated
**Layout Meaning**

Value” and entering a numeric $x_2$ value as appropriate. See Chapter 5 for further details. The $x_1$ and $y$ data need to be arranged contiguously in the data table, and multiple $y$ data sets can be present. The location of the X data column and the Last Y data column are selected, and from the program can work out how many data sets are present. All the $y$ data sets need to be in columns that are of the type “y Data with Associated Value.”

$x(2)$ from y header $x_1$ $y_1$ $x_2$ $y_2$...

This option is only available if there are two independent variables. As with the previous layout, the second $x$ variable is obtained from the column type header. The difference is in the arrangement of data columns. For this layout, pairs of $x$, $y$ data columns are arranged contiguously in the data table, and a separate set of $x$ data values are used for each $y$ data set. All the $x$ data columns hold values corresponding to the first independent variable as defined in the equation; values for the second independent variable are obtained from the type header. The First X data column and the Last Y data column are selected, and from this the program can work out how many data sets are present.

$x(n)$ from table $x(1)$ $x(2)$ $x(n)$ $y$

This layout is available whenever there is more one independent variable, and is the only layout type when three or more independent variables are present. When using this layout, the program determines which column is associated with which independent variable by examining information present in the column type headers of the data table. The column types of the various independent data sets ($x$ axes) need to be set to “$x(n)$ Data” with the “$n$” value representing the order of the $x$ variable found in the equation definition. See Chapter 5 for further details on column types. The position of the $y$ data column is selected from the Y data column entry.

**X Data Column**

This entry specifies the column that holds the $x$ data values. See the Data Layout section (above) for further information.
Limiting X Data Range

It can sometimes be useful to restrict data fitting to a subset of the values in the columns. For example, it can be useful to fit just the initial portion of a data set. Checking the Limit X range box allows a lower and upper limit to be set on data that will be included in the analyses.

Y Data Column

This entry specifies the column that holds the $y$ data values. See the Data Layout section (above) for further information.

Error Column

If explicit weighting is chosen, the error values are read from a separate column, which is selected here.

Constants Pane

Some equations are defined to include Constants, the values of which are passed to the equation when fitting data. If the selected equation includes Constants values, these are entered into the grid found on this pane. For equations that lack Constants, this pane is empty.

Estimatrix Pane

Non-linear regression analysis requires approximate starting estimates for the parameter values. These starting values are then improved upon by iteration, until the best-fit curve is calculated. Some equations provide a means of generating estimates automatically; for other equations it is always necessary to enter explicit estimates (see Chapter 9). For the former case, this pane allows supplementary estimates to be entered; for the latter it is essential to enter initial estimates into the grid found on this pane.
For equations that automatically provide estimates, the **Estimates from matrix** box needs to be checked in order to allow supplementary estimates to be entered into the grid. If automatic estimation is not available then this box is always checked. The grid is used for entry of estimates, which can be done in one of two ways.

1. Just the **Start** value is specified. In this case the value entered is taken as the initial estimate for this parameter.

2. Values are entered under the **Start**, **End** and **Steps** columns. In this case a range of estimates, total number **Steps**, is generated between the Start and End values inclusive.

It is possible to enter just a Start value for some parameters and a range for others. Whenever a range of values is involved, a matrix of permutations is tested. It is important to limit this grid search to a sensible number of combinations, for example if 10 parameters were present and 10 steps were selected for each, this would involve $10^{10}$ values to be tested – clearly an unrealistic number. When data fitting starts, each permutation is tested and the combination that gives the best fit (lowest $\chi^2$ value) is used as the starting estimates for non-linear regression. If both automatic and manual estimates are present, each is tested and the best of the two is used as the starting estimates for regression.

**Interactive Estimator**

Finding suitable initial estimates can be a laborious task, and to simplify things GraFit provides an interactive visual tool that is accessed by pressing the **Interactive Estimator** button. The Interactive Estimator dialog is shown below:
The Interactive Estimator dialog

A simple graph of the data, selected on the Settings pane, is shown. The graph is automatically scaled by default, although the scale can be altered if desired. To see the curve generated by a particular set of parameter values, type in values into the Estimates value column of the grid. When you move the data entry position, the graph will be updated to show the curve generated by the current set of values. These estimates should be such that the calculated curve falls close to the data values. Just how accurate these parameter estimates need to be depends upon the equation in use and the data present. However, it is usually only necessary to produce a curve that roughly follows the data (as shown above) for the subsequent data fitting to find the best-fit values.

When acceptable parameters have been found, pressing OK will return these values into the Start column of the Estimatrix pane.

**Fitting Criteria Pane**

As described in Chapter 20, non-linear regression calculates best-fit parameters by a series of iterations that produce successively more accurate results. It is up to the program to decide at what point the values are deemed acceptable, and at which point the calculations stop. The criteria used to decide this are set from the Fitting Criteria pane. It is likely that for most situations you will not need to change the default values on this page.
Fitting Criteria

GraFit uses three separate criteria to decide when the calculations are acceptable.

<table>
<thead>
<tr>
<th>Criterion</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>% Chi² change</td>
<td>This setting is optional, and is activated by checking the % Chi² change box. When selected, fitting will terminate when the change in the $\chi^2_v$ value is less than the percentage value entered (providing the minimum number of iterations has been reached).</td>
</tr>
<tr>
<td>Minimum iterations</td>
<td>GraFit will always perform the specified number of iterations.</td>
</tr>
<tr>
<td>Maximum iterations</td>
<td>Fitting will terminate when the specified number of iterations has been reached, irrespective of whether the designated change in $\chi^2_v$ has taken place. The maximum iterations limit serves to guard against the possibility that the calculations will never reach a minimum, and so forces control to return to the program eventually.</td>
</tr>
</tbody>
</table>

The settings can be stored as the defaults by clicking the Store settings as defaults button; GraFit will remember these defaults next time the program starts.
Results Pane

The Results pane holds a summary of the fitting results.

If more than one set of data is specified in the Settings pane, each fit can be viewed by clicking the arrow buttons. The File ➤ Print and File ➤ Print Preview commands show the results in a more stylized manner, as illustrated below:
The formatting of these results is controlled from the Number Format, Fonts and Indents panes.

**Showing the Fitted Results on a Graph**

A listing of the fitted parameter values can be displayed in a graph item window by selecting the Draw ➔ Results Listing command from the graph window. See Chapter Error! AutoText entry not defined. for further information.

**Number Format Pane**

The numeric result values are displayed formatted as is specified on this pane.

<table>
<thead>
<tr>
<th>Specification</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal places</td>
<td>Enter the number of decimal places to be displayed for numbers in the results listing.</td>
</tr>
<tr>
<td>Max digits</td>
<td>Enter the maximum number of digits to use when displaying numbers in the results listing.</td>
</tr>
<tr>
<td>Thousands separator</td>
<td>Check this box to include a grouping separator. The symbol used for this separator, and the number of digits in the group, are set for the View ➔ Options command on the main GraFit window.</td>
</tr>
</tbody>
</table>

*Note* To ensure that all decimal places are displayed set **Trailing zeros in fraction** to “Show 0’s.”
### Scientific format
Check this box to display the values using scientific format (e.g. -2.435e003 instead of -2435.000).

### Use scientific format for small values
Check this box to ensure that small values, which would otherwise be displayed as 0.0000, are shown in scientific format (e.g. 2.0987e-008).

### Trailing zeros in fraction
Chooses the way that trailing zeros are displayed in the formatted numbers. It is possible to show the “0” characters, to omit them, or to replace them with spaces.

### Fonts and Indents Panes
These panes control the way that the results are formatted. The contents of these panes are common to several different item windows, and are described in Chapter 7.
CHAPTER 7

Formatting Item Windows

Formatting Options

Several GraFit Item windows are built from a tabbed dialog box that allows various settings to be entered. The Linear Fit, Non-linear Fit, Equation and Transformation definition items are all built in this way. In each case, the settings in the window can be displayed using the **File ➤ Print Preview** command, and printed by the **File ➤ Print** command. Each of these item windows includes a Fonts and an Indents pane that control the way the information is displayed when printing.

Fonts Pane

The Fonts pane selects the fonts to use when displaying the contents of the item window.

The Fonts pane of the Non-linear Fit item

This pane behaves in the same way as a standard Windows font selection dialog. The fonts to use can be set for a variety of different text elements, specified by the...
**Item** selection. To see the effect of changing the font settings, use the **File ➤ Print Preview** command.

**Indents Pane**

The Indents pane controls the organization of information for printing.

Each of the different indent levels can be individually set. To see the effect of changing the indent settings, use the **File ➤ Print Preview** command.
CHAPTER 8

Linear Fit Item

Overview of Linear Fitting

A linear fit item is used to control data fitting by linear regression. This item specifies the data source and equation to use, and also presents the results of the data fitting. The item is created from the main GraFit window using the Add ➔ Linear Fit command. The linear fit window itself contains a tabbed dialog box with several panes that are used to specify how the fit is calculated. Each of these panes is discussed below. Data fitting involves making appropriate selections in the Settings pane (and possibly one or more of the other panes as described below), then selecting the Calculate ➔ Fit Data command. After fitting the data the results can viewed from the Results pane.

Status Bar Indicators

When a fitting item is selected, the status bar shows the current fitting status, indicating whether the item is currently Fitted or Not Fitted. In addition, the status bar shows when a calculation is in progress. Whenever any calculation is being processed, the calculation pane shows an animated abacus.
**Settings Pane**

The Settings pane is used to specify the main details of the fit.

![The Settings pane of the Linear Fit item](Image)

**Equation**

Choose the equation to use for the data analysis. All the available equations are linear, and are of the form given below:

\[ y = a + bx + cx^2 + dx^3 + \ldots \]

The default linear regression equation is \( y = a + bx \).

**Weighting**

All types of regression analysis require information about the error distribution in your data. The reason for this is explained fully in Chapter 20, but briefly it is necessary to specify whether the inaccuracies are likely to be the same for each data point (“Simple” weighting), are proportional to the value of the \( y \) data points (“Proportional” weighting) or have been individually estimated (“Explicit” weighting). The default Simple weighting is often the most appropriate setting.

**Data Table**

The data to be fitted must be in a separate data table item within the GraFit workspace. Select the table that holds the data from this drop-down list.
Data Layout

The data layout specifies how the data are arranged for data fitting. The default layout, as shown in the figure above, is that the $x$ and $y$ data columns are to be selected individually. This is used to fit a single $\{x, y\}$ data set. It is also possible to specify that multiple data sets are present, which will result in several sets of results being generated. The available options for a standard equation having a single independent variable are given below.

<table>
<thead>
<tr>
<th>Layout</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>$x$ $y$</td>
<td>A single data set is present and the columns holding the $x$ and $y$ data values are specified individually from the X data column and Y data column entries. The $x$ and $y$ data columns do not need to be in any particular order within the data table.</td>
</tr>
<tr>
<td>$x$ $y_1$ $y_2$...</td>
<td>Multiple data sets are present, although all data sets have common $x$ data values. The $x$ and $y$ data columns are consecutive in the data table. The location of the $x$ column is set from the X data column entry; the location of the final $y$ column is set from the Last Y data column entry. The number of data sets present is determined automatically.</td>
</tr>
<tr>
<td>$x_1$ $y_1$ $x_2$ $y_2$...</td>
<td>Multiple data sets are present, and the data sets have different $x$ data values. Pairs of $x$, $y$ data columns are present consecutively in the data table. The location of the first $x$ column is set from the First X data column entry; the location of the final $y$ column is set from the Last Y data column entry. The number of data sets present is determined automatically.</td>
</tr>
</tbody>
</table>

X Data Column

This entry specifies the column that holds the $x$ data values. See the Data Layout section (above) for further information.

Limiting X Data Range

It can sometimes be useful to restrict data fitting to a subset of the values in the columns. For example, it can be useful to fit just the initial portion of a data set. Checking the Limit X range box allows a lower and upper limit to be set on data that will be included in the analyses.

Y Data Column

This entry specifies the column that holds the $y$ data values. See the Data Layout section (above) for further information.

Error Column

If explicit weighting is chosen, the error values are read from a separate column, which is selected here.
**Results Pane**

The Results pane holds a summary of the fitting results.

![Image of Results Pane](image)

The Results pane of the Linear Fit item

If more than one set of data is specified in the Settings pane, each fit can be viewed by clicking the arrow buttons. The **File ➤ Print** and **File ➤ Print Preview** commands show the results in a more stylized manner, as illustrated below:

![Image of Print Preview](image)

Using Print Preview from the Linear Fit item

The formatting of these results is controlled from the Number Format, Fonts and Indents panes.
**Showing the Fitted Results on a Graph**

A listing of the fitted parameter values can be displayed in a graph item window by selecting the **Draw ➔ Results Listing** command from the graph window. See Chapter 21 for further information.

**Fonts and Indents Panes**

These panes control the way that the results are formatted. The contents of these panes are common to several different item windows, and are described in Chapter 7.
Overview of Equation Definitions

Equation definitions are used for non-linear fitting (see Chapter 6 for more information about non-linear fitting items). The item is created from the main GraFit window using the **Add ➔ Equation** command. The equation window itself contains a tabbed dialog box with several panes that are used to define the equation. After defining the equation, it must be compiled using the **Equation ➔ Compile** command before it can be used. Each of the panes in this item window is discussed below.

Status Bar Indicators

When an equation definition item is selected, the status bar shows whether the equation is **Compiled** or **Not Compiled**.

![Compilation status pane](image)
General Pane

The general pane allows a description of the equation to be entered.

![General pane of the Equation item](image)

The description is optional, but adding a text description of your equation definitions is strongly recommended. As illustrated in the figure above, the descriptive text allows rich formatting options, with multiple font types, styles, sizes and colors allowed. It is also possible, as shown above, to include any OLE object in the text. In this particular example, a Microsoft Equation 3.0 object has been embedded within the text.

Note The Microsoft Equation editor, which comes with Microsoft Word, is not provided with GraFit.

Changing Font Styles

To alter the style of a selected region of text, use the Edit ➤ Font command.

Inserting OLE Objects

To insert an OLE object into the description text, position the cursor where you wish the object to be placed, and select the Edit ➤ Insert New Object command.
Choose the object type to create, and then click OK.

**Editing OLE Objects**

An inserted OLE object can be edited by double-clicking on the object, or by choosing the appropriate menu command from the **Edit** menu.

**X Variables Pane**

The X Variables pane is used to define the names of the independent (x) variables that are used in the equation. All equations must have at least one independent variable, and can include more than one.

---

*The X Variables pane of the Equation item*
**Naming Rules**

All name definitions for use in an equation definition are entered into a grid that has space for a Symbol and a Description entry. All names must have a Symbol entry, but the Description field is optional.

**Description Entry**

If a Description entry is made, GraFit will use this long name whenever it refers to the name, for example when listing results. If no Description entry is present, GraFit will use the Symbol entry. Description entries can incorporate any characters, including spaces and punctuation characters that are illegal in Symbol entries.

**Symbol Entry**

The symbol entry is the name used in the equation Definition page. Symbol names must obey a number of rules, in a similar way to variable names within a computer program.

- The name must begin with a letter, and contain only letters and numbers. In particular, a symbol name cannot contain the space character.

The following names are legal symbols:

- Fred
- k_on
- x23

The following names, however, are invalid:

- 2nd (starts with a number)
- k off (contains a space)
- test-2 (contains a minus sign)
- ten: (contains a punctuation character)

- No distinction is made between upper and lower case characters within a symbol definition. Therefore the symbol names grafit, GraFit, GRAFIT and gRAfIT are all considered identical.

We recommend using meaningful names wherever possible when defining symbol names. Using Final to represent the final concentration of a substance rather than z will make understanding your definitions far easier for others as well as yourself. In addition, it is often useful to add a full descriptive name.

**Number of X Variables**

After entering an x variable definition, the data entry grid will show a blank entry position immediately below the defined variable. If you enter a second definition in this location, a further blank entry position will appear. The number of rows of information that are entered into the grid therefore defines the number of x variables in the equation.
When to use Multiple X Variables

Most equations are of the form $y = f(x)$, and so have just a single independent ($x$) variable. In equations with multiple independent variables, the observed value ($y$) varies as a function of more than one variable condition. For example, the rate of an enzyme reaction may vary as a function of both substrate and inhibitor concentrations. In this case, there are two independent ($x$) variables. In principle it is possible to have any number of independent variables, although in practice it is rare to fit data where more than two independent variables are present.

Parameters Pane

The Parameters pane is used to define the parameter values in the equation definition. The parameter values are the “unknowns” in the equation, and non-linear regression allows data to be fitted in order to find optimal values for these parameters.

The organization of the Parameters pane is very similar to that of the X Variables pane, and the definition of Symbol and Description names is performed in an analogous manner (see the X Variables Pane section above). The number of rows of information that are entered into the grid defines the number of parameters in the equation. At least one parameter must be defined. There is no formal limit to the number of parameters allowed in a GraFit equation definition, but it is rare to find equations that involve more than four or five parameters.

Constants Pane

The Constants pane is used to define constants in the equation definition. Constants are used to allow the entry of a value into an equation definition that is
fixed in any single experiment, but varies from experiment to experiment. The presence of constants is optional, but when present an equation definition can include any number of constants. When constants are included in an equation used for non-linear regression, their values are entered into the non-linear fit item window as described in Chapter 6.

![Enzyme Kinetics](image)

The organization of the Constants pane is very similar to that of the X Variables pane, and the definition of Symbol and Description names is performed in an analogous manner (see the X Variables Pane section above). The number of rows of information that are entered into the grid defines the number of parameters in the equation. If no constants are required, as will be the case for many equations, this page should be left blank.

**Definition Pane**

The definition pane describes the functional form of the equation using the Symbol names of the x variables, the parameters and constants (if any) entered as on the earlier panes.
All equation definitions that are used within GraFit must have the functional form $y = f(x)$, i.e. it must be possible to describe the variation of $y$ as some defined function of $x$. The information on this pane describes the required equation in symbolic form. At the top of the pane is an entry for **Y name**, which allows the $y$ axis to be given a Symbol name (using the rules described earlier).

**Equation Definition Syntax**

The equation definition is built up from the symbols representing parameters and constants (if any) with whatever arithmetic operators and mathematical functions are required. For the example shown in this Chapter, we have used the following equation:

$$v = \frac{k_{\text{cat}} \cdot [E_0] \cdot [S]}{K_m + [S]}$$

In the **Equation definition** entry, this becomes:

$$v = k_{\text{cat}} \cdot E_0 \cdot S / (K_m + S)$$

The syntax used is similar to that of a programming language, and uses the rules described below.
### Arithmetic Operators

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Operation</th>
<th>Example</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
<td>x + y</td>
<td>Add x and y</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
<td>lim-off</td>
<td>Subtract off from lim</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
<td>m * x</td>
<td>Multiply m by x</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
<td>a/b52</td>
<td>Divide a by b52</td>
</tr>
<tr>
<td>^</td>
<td>Exponentiation</td>
<td>23^N</td>
<td>Calculate $23^N$</td>
</tr>
<tr>
<td>=</td>
<td>Assignment</td>
<td>y = x*2</td>
<td>Assign y to be twice the value of x</td>
</tr>
</tbody>
</table>

### Logical Operators

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Operation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;</td>
<td>Is greater than</td>
<td>k&gt;7</td>
</tr>
<tr>
<td>&lt;</td>
<td>Is less than</td>
<td>x_value&lt;con1</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Is greater than or equal to</td>
<td>test&gt;=23.87</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Is less than or equal to</td>
<td>rate &lt;= maxrate</td>
</tr>
<tr>
<td>=</td>
<td>Is equal to</td>
<td>i76=0</td>
</tr>
</tbody>
</table>

**Note** The “=” symbol is used for both assignment and as a logical operator. Which action is taken depends on the context.

Logical operators allow a comparison to be made. The result of the comparison is either 0 if FALSE, or -1 if TRUE. To see how these operators work, consider a graph of the form:

$$ y = (x < \text{test}) \times -1 + 3 $$

Here, $x$ is the $x$ axis, and $\text{test}$ is a constant that has the value 2. This function is plotted below.
These comparisons can be used to introduce a discontinuity into a curve, and though they will seldom be used in equations, are extremely useful for displaying limits etc. to annotate a graph. An alternative method to obtain discontinuities is to use the If Then Endif constructs described below.

**Note** To obtain a sharp discontinuity it is necessary to create the curve with Resolution set to High (see page 124).

Numbers can be entered directly into the equation definitions, and can include exponents, e.g. 27.87e-12.

**Functions**

A large number of functions are provided for use in equation definitions.

<table>
<thead>
<tr>
<th>Function</th>
<th>Returns</th>
</tr>
</thead>
<tbody>
<tr>
<td>abs(x)</td>
<td>Absolute value of x, i.e. if x &lt; 0 returns -x, otherwise returns x.</td>
</tr>
<tr>
<td>acos(x)</td>
<td>Cos⁻¹ of x.</td>
</tr>
<tr>
<td>alog(x)</td>
<td>Antilogarithm to base 10 of x.</td>
</tr>
<tr>
<td>asin(x)</td>
<td>Sin⁻¹ of x.</td>
</tr>
<tr>
<td>atan(x)</td>
<td>Tan⁻¹ of x.</td>
</tr>
<tr>
<td>cos(x)</td>
<td>Cosine of x.</td>
</tr>
<tr>
<td>exp(x)</td>
<td>e^x.</td>
</tr>
<tr>
<td>frac(x)</td>
<td>The fractional part of x. The fractional part of 13.387 is 0.387.</td>
</tr>
<tr>
<td>int(x)</td>
<td>The integer part of x. The integer part of 13.387 is 13.</td>
</tr>
<tr>
<td>log(x)</td>
<td>The logarithm to base 10 of x.</td>
</tr>
<tr>
<td>ln(x)</td>
<td>The natural logarithm of x.</td>
</tr>
<tr>
<td>sin(x)</td>
<td>Sine of x.</td>
</tr>
<tr>
<td>sqr(x)</td>
<td>The square of x, x².</td>
</tr>
<tr>
<td>sqrt(x)</td>
<td>The square root of x, ( \sqrt{x} )</td>
</tr>
<tr>
<td>tan(x)</td>
<td>Tangent of x.</td>
</tr>
</tbody>
</table>

The expression within the brackets may be of arbitrary complexity, for example

\[
\exp(-k \times \sqrt{j - 1})
\]

All the geometric functions (sin, cos etc.) use radians as their units.

The following predefined constants are also available:
### Constant Value

<table>
<thead>
<tr>
<th>Constant</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>pi</em></td>
<td>$\pi = 3.1415926536$</td>
</tr>
<tr>
<td><em>e</em></td>
<td>$e = 2.7182818285$</td>
</tr>
<tr>
<td><em>rnd</em></td>
<td>A random number between 0.0 and 1.0.</td>
</tr>
<tr>
<td><em>grnd</em></td>
<td>A random number with Gaussian error distribution. The number has a zero mean and unit variance.</td>
</tr>
</tbody>
</table>

### Multi-line Equation Definitions

In its simplest form as described earlier, the equation definition is a single line that calculates the $y$ value. For example, if the equation to be used was $y = ax + b$, then the equation definition might be written as:

$$y = a \times x + b$$

Here, $a$ and $b$ have been declared to be the symbols that represent the parameters, $x$ has been declared to be the symbol that represents the $x$ data and $y$ the symbol that represents the $y$ data. Note that the multiplication between $a$ and $x$ needs the explicit inclusion of the multiplication operator, *.

The equation definition can also be defined over several lines in order to simplify a complicated definition. This allows the calculation to be broken up into several steps.

### Use of Temporary Variables

Temporary variables can be used to hold intermediate calculation results and simplify definitions. For example, the following definition uses three temporary variables, $a$, $b$ and $c$.

```plaintext
a = 1
b = Kd + total + Capacity
c = total * Capacity
y = -(-b + sqrt((b) - 4 * a * c)) / (2*a)
```

The remaining symbols ($Kd$, $total$, $Capacity$) are defined in the equation editor as parameters or constants. Values are assigned to the temporary variable using the assignment operator, =, after which they may be used in expressions as normal. Use of temporary variables makes the above definition more easily read, and speeds up the calculation as the value for $b$ need only be calculated once. Each line of the definition is separated from the next by pressing the RETURN key.

### Conditional Statements

The values that are evaluated can be controlled using the **If** statement. This takes the form

```plaintext
If condition Then
    .....statements.....
Endif
```
or alternatively,

```plaintext
If condition Then
    .......statements......
Else
    .......statements......
Endif
```

For example, it is possible to return different values to the program depending upon the value of a parameter, constant or independent variable:

```plaintext
If extra=1 Then
    Return( a1 + b*x )
Endif
If extra=2 Then
    Return( a2 + b*x )
Endif
If extra=3 Then
    Return( a3 + b*x )
Endif
Return( a4 + b*x )
```

**Comments**

Comments can be added to annotate the equation definitions.

```plaintext
' Anything after an apostrophe is a comment 
; as is anything after a semi-colon
```

**Looping Statements**

The `For` statement has the following syntax.

```plaintext
For varname = startValue To endValue
    .......statements......
Next
```

or alternatively

```plaintext
For varname = startValue To endValue Step stepValue
    .......statements......
Next
```

**Goto Statement**

Another statement that will be familiar to programmers is the `Goto` statement. In GraFit equations this is implemented in the following manner:

```plaintext
:labelName
    .......statements......
Goto labelName
```
labelName can be any valid name, using the same rules as apply to the names for symbol names. The label may come before or after the Goto statement.

Note  Indiscriminate use of Goto could result in an infinite loop.

Estimates Pane

The Need for Starting Estimates

Non-linear regression works by taking initial estimates for the best-fit parameter values, and by an iterative process calculates successively better values until the best-fit values are reached. It is therefore necessary to provide the program with suitable starting estimates, which should generally be of the same order of magnitude as the actual ones. If an equation definition alone is provided, the program cannot know what initial estimates are appropriate. In this event, when the equation is used the program will ask you to enter initial estimates before fitting the data.

To relieve users the inconvenience of estimating parameter values, GraFit provides a means of generating these estimates automatically. It should be noted that the method used is not foolproof, and requires familiarity with manipulating equations. It does, however, make data fitting simpler, and can be over-ridden if the estimates provided are inappropriate. In addition, equations can be defined without provision for automatic initial estimation.

Method Used to Obtain Initial Estimates

The method used is based on performing linear regression on rearranged data. It is often possible to rearrange data in such a way that a linear plot is obtained, with the parameter values being related to the gradient and intercept. As linear regression needs no initial estimates, this can be used to estimate these parameter values providing the program knows the following.

1. The rearrangement that is needed.
2. How the parameter values relate to the gradient and intercept.

This process is illustrated using the previous example, where the equation is:

\[ v = \frac{k_{\text{cat}}[S][E_0]}{K_m + [S]} \]

We can rearrange this to a linear form by plotting \( \frac{v}{[S]} \) against \( v \):

\[ \frac{v}{[S]} = \frac{k_{\text{cat}}[E_0]}{K_m} - \frac{v}{K_m} \]

This is the so-called Eadie-Hofstee equation. Plotting \( \frac{v}{[S]} \) against \( v \) and allows the slope and intercept to be found, from which it is possible to calculate \( k_{\text{cat}} \) as
(-intercept/gradient)/\[E_0\], and \(K_m\) as -1/gradient. It must be stressed that this approach does not provide strictly correct values for \(k_{cat}\) and \(K_m\)—this is why we wish to use non-linear regression in the first place! (Further information can be found in Chapter 19.) The values provided are suitable, however, to use as initial estimates for the non-linear regression analysis. (It is instructive to compare the initial estimates provided by this method with the final values produced by the non-linear regression analysis. As they are demonstrably different, this illustrates the danger of using linear regression of a linearized function for analyzing data.)

The Estimates Pane

The Estimates Pane of the Equation item

To specify that initial estimates are provided for an equation, the **Estimate from linear transform** box should be checked. If you do not want the program to calculate initial estimates, simply leave the box unchecked.

Defining How to Rearrange the Data Points

For our current equation, the rearranged plot that we require is of \(v/\[S]\) against \(v\), i.e., \(y/x\) versus \(y\). The **X Data** and **Y Data** entries are used to define the data points for such a plot (note that the stored data points in the data table are, of course, unaffected). For this equation the definitions are:

\[\text{ydata}\]

and

\[\text{ydata/xdata}\]

respectively. The symbols “\text{xdata}” and “\text{ydata}” are predefined by the program to represent the \(x\) and \(y\) data points.
These definitions allow the program to perform the rearranged plot, and any valid single line expression can be used. The grid at the bottom of this page is used to define how we obtain our initial estimates from linear regression on the rearranged plot. Shown in the previous figure is the definition of $k_{\text{cat}}$ as $(-\text{intercept}/\text{gradient})/E_0$, and $K_m$ as $-1/\text{gradient}$. Use the scroll bar to bring any further parameters into view. The symbols “intercept” and “gradient” are predefined, and represent the intercept and gradient of the rearranged linear plot.

Other predefined symbol names may also be used when defining initial estimates of your variables. The symbol $\min$ will give the value of the minimum $y$ data point, and $\max$ the value of the maximum $y$ data point. The corresponding minimum and maximum $x$ data points are $\min x$ and $\max x$, respectively. These values can be of benefit if you need to obtain rough estimates of limits, where the limiting value can be approximated by the maximum recorded value. It is also possible to enter numeric values directly as estimates. In some situations, rough numerical values provide suitable estimates without recourse to the more complex methods described above.

If the **Omit values equal to zero** box is checked then any data values ($x$ or $y$) that are equal to zero will not be used during the data transformation. This is useful with several transformations that involve taking logarithms or dividing by one of the data values (as here). If this box is not checked then a data point which happens to have a value of zero might cause an arithmetic error, resulting in the estimates routine failing.

### Compiling the Equation

To compile the equation, choose the **Equation ➨ Compile** command. Compilation translates your definition into an internal form that can be executed rapidly. During compilation the definition is comprehensively checked to ensure that the correct syntax has been used. If an error is detected a message box will be displayed informing you of the mistake; after pressing the **OK** button to continue the cursor will be placed at the most likely place of error.

![An Error Message Box](image)

To obtain further information on the specific error, click the **Help** button, or press the **F1** key.

Once the equation has been correctly compiled, it can be used for data fitting and/or graph plotting.
CHAPTER 10

Transformation Item

Overview of Transformation Definitions

Transformation definitions are used in order to allow data and curves to be displayed on a graph after application of a user-defined transformation. For example, one use of a transformation definition would be to allow a double-reciprocal plot to be displayed. Transformations describe methods for rearranging data and equations that can be applied during graph drawing without the need to create a separate set of rearranged data.

An example of a transformed double-reciprocal plot. The transformation definition defines the way that the data points and the fitted curve are rearranged.

The transformation item is created from the main GraFit window using the Add ➔ Transformation command. The transformation window itself contains a tabbed dialog box with several panes that are used to define the transformation. After defining the transformation, it must be compiled using the Transformation ➔ Compile command before it can be used. Each of the panes in this item window is discussed below.
Status Bar Indicators

When an equation definition item is selected, the status bar shows whether the equation is **Compiled** or **Not Compiled**.

General Pane

All transformations are associated with an equation definition item, which must also be present in the GraFit workspace. See Chapter 9 for more information about defining equations. The general pane also allows a description of the transformation to be entered.

The description is optional, but adding a text description of your transformation definitions is strongly recommended. As illustrated in the figure above, the descriptive text allows rich formatting options, with multiple font types, styles, sizes and colors allowed. It is also possible, as shown above, to include any OLE object in the text. In this particular example, a Microsoft Equation 3.0 object has been embedded within the text.
Chapter 10: Transformation Item

Data Points Pane

The Data Points pane describes how data points are transformed for plotting. If the Transform data points box is unchecked, no data point transformation is used. Otherwise, the remainder of the window describes how the data are to be rearranged when this transformation is applied.

In the sample shown above, the data transformation involves plotting the reciprocals of the x and y data.

Data Transformation Definitions

Two transformation definitions need to be entered, one each for the transformed x and y data. Use the edit fields to enter the transformation definitions. The rules for these transformation definitions are the same as described in Chapter 9 for equation definitions, although the definition is limited to a single line and only the right hand side of the “Definition =...” equation is entered. The definition can be of arbitrary complexity, and can include mathematical functions, parameter names etc. The pre-defined symbols xdata and ydata represent the original x and y data values respectively. The symbol xdata2 can be used to access any data values associated with the y data column (“y Data with Associated Value” column type—see the discussion of column types in Chapter 5). In the example illustrated above we wish to take reciprocals of these data; the definitions are therefore 1/xdata and 1/ydata. Any algebraic expression may be entered, for example

xdata/(ydata + sqrt(xdata))
is a perfectly valid transformation definition. It is permissible to access the values of parameters and constants in the equation, if desired. The symbol names of these are listed at the bottom of the Data Points pane.

**Generating Residuals Plots**

A very useful symbol that is specific to the data transformation definition is $y_{calc}$. This returns the $y$ value that is calculated from the fitted parameters. Therefore, to generate a residuals plot, define the transformed $y$ data as:

$$y_{data} - y_{calc}$$

**Axis Name Settings**

When first creating a transformed plot, the text used to name the $x$ and $y$ axes is taken from the Default X name for graph and Default Y name for graph entries. The following special entries can be used:

<table>
<thead>
<tr>
<th>Entry</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>All occurrences of this are replaced by the name of the untransformed $x$ data column.</td>
</tr>
<tr>
<td>%2</td>
<td>All occurrences of this are replaced by the name of the untransformed $y$ data column.</td>
</tr>
</tbody>
</table>

**Curve Pane**

The Curve pane describes how fitted curves are transformed for plotting. If the Transform curve box is unchecked, no curve transformation is used. Otherwise, the remainder of the window describes the transformed curve definition.
Chapter 10: Transformation Item

The Curve pane of the Transformation item

In the sample shown above, the curve transformation displays a line through the transformed data points making use of the fitted parameter values.

**Transformed Curve Definition**

To draw the transformed curve (which in the example above gives the linear Lineweaver Burk plot) it is necessary to have an appropriate equation definition. For the example that we are using, the transformed equation is:

\[
\frac{1}{v} = \frac{1}{[S]} \cdot \frac{K_M}{k_{cat}[E_0]} + \frac{1}{k_{cat}[E_0]}
\]

What is being plotted is \(1/v\) (the y axis) versus \(1/[S]\) (the x axis). To show this line, we therefore need an equation that is defined as:

\[
y' = x' \cdot \frac{K_M}{k_{cat}[E_0]} + \frac{1}{k_{cat}[E_0]}
\]

Here, \(x'\) and \(y'\) are the transformed data. The transformed curve definition uses the **X name** and **Y name** entries, which correspond to \(x'\) and \(y'\) in the above equation. The syntax used for this definition is as described for equations (see Chapter 9), and can occupy more than one line if required.
Fonts and Indents Panes

These panes control the way that the results are formatted. The contents of these panes are common to several different item windows, and are described in Chapter 7.

Compiling the Transformation

To compile the equation, choose the Transformation ➨ Compile command. Compilation translates your definition into an internal form that can be executed rapidly. During compilation the definition is comprehensively checked to ensure that the correct syntax has been used. If an error is detected a message box will be displayed informing you of the mistake; after pressing the OK button to continue the cursor will be placed at the most likely place of error.

![An Error Message Box](image)

To obtain further information on the specific error, click the Help button, or press the F1 key.

Once the transformation has been correctly compiled, it can be used for graph plotting.
CHAPTER 11

Notepad Item

Uses of Notepad

The notepad provides a text editor window where information can be stored in the GraFit workspace. Uses include making notes about the data, the analysis of the results, and writing brief documentation on how to use a particular data file or template. The notepad item is created from the main GraFit window using the Add ➔ Notepad command.

The Notepad Item Window

The font styles are set from the formatting toolbar, or using selections from the Font menu. Notepad windows automatically wrap their contents so that the line width is equal to the width of the window.

Alternatives to the use of Notepad Items

The notepad item provides a simple text editor that has many of the capabilities of the Windows WordPad application. However, it does not provide the wealth of features present in a dedicated word-processing application such as Microsoft
Word. It is, however, possible to harness the power of applications such as Word by embedding documents into the GraFit workspace. For example, a Word document can be embedded as an OLE item within the main GraFit window, as described in Chapter 18. If you have access to OLE-compatible editors such as Word, incorporating notes in this manner can be a more suitable alternative to using a notepad item.
CHAPTER 12

Creating Graphs

How to Create a New Graph

To create a new graph, first add a graph item window to the workspace using the Add ➔ Graph command. You will then be given a choice of graph type to create from the Select Graph Type dialog (below). The resulting graph will be created using the default size. If you want a graph of a specific size, press the Cancel button, which will result in a blank graph page. Then use the Graph tool ✏ to add the graph at a specific location and size.

Adding Graphs to an Existing Graph Item

It is possible to create as many graphs as required on each graph item page. To add an additional graph to an existing graph item window, either select the Graph ➔ New Graph command, which will create a graph of a default size, or click the Graph tool and drag to position the new graph where you wish it to be placed.

Available Graph Types

Although GraFit can create a large variety of different graphs, the initial choice when making a new graph is between four fundamental graph types. These differ in the data that they use; for example, X/Y Scatter Graphs hold data with separate numeric x and y values whereas a Column Chart has data values that associated with named categories.
After selecting the type of graph to create, clicking the Create button will result in a specific graph creation wizard that allows the graph to be customized. A description of the kind of graphs that can be created for each type is given below, and more detailed information is found in the following chapters.

**X/Y Scatter Graph**

X/Y Scatter Graphs have numeric ranges on both $x$ and $y$ axes. Some of the types of graph that can be created are illustrated below.

*This graph shows data points joined by a smooth Bezier curve*  
*This graph shows data and a fitted curve; inset is a linear transformation of the data*
Chapter 12: Creating Graphs

This graph shows a semi-log plot with a split axis scale

This graph shows a single graph having multiple axis scales

This graph shows offset axes and error bars

This graph shows multiple data sets fitted simultaneously to an equation with two independent variables

Column Chart

Column Charts are categorized by having a numeric range on the y axis and named categories on the x axis. Some of the types of chart that can be created are illustrated below.

Simple comparison of a set of parameter values

Summed area plot
A Low/High column chart

A chart with different y axis scales for the two data sets plotted.

**Bar Chart**

Bar Charts are categorized by having a numeric range on the x axis and named categories on the y axis, and have the same range of styles available as column charts. Some of the types of chart that can be created are illustrated below.

Comparison of values using a bar chart

A Low/High bar chart

**Histogram**

Histograms have numeric ranges on both x and y axes, but the x axis represents value ranges and the y axis shows the number of occurrences within the range. Some histogram styles are shown below.

---

Note  Despite the similar appearance, a histogram is fundamentally different to a column chart.
A distribution of data

Comparison of two distributions
Overview of Graph Items

Graph items display a page of information that can hold one or more graphs, and may also display results or contain OLE objects. This item window is created from the main GraFit window using the Add ➔ Graph command. The appearance of a blank graph item window (at 50% magnification, in landscape orientation) is shown below.
Controlling the Page View

The orientation of the printed page is controlled using the File ➤ Page Setup command. The magnification is set from the View menu, or using the Zoom selection on the toolbar.

Grid Lines
By default, the graph is displayed with a background grid to help position the various items that form part of the graph. This grid does not show during print preview, and is not printed. It can be turned off by the View ➤ Grid Lines command, which toggles their display. The color of the grid lines, and whether GraFit graphs show gridlines by default, can be controlled from the Graph ➤ Preferences command.

Element Outlines
By default, text elements and OLE objects are displayed with dotted and solid outlines, respectively. These do not show during print preview or printing, and can be hidden by the View ➤ Show Outlines command, which toggles their display. Whether GraFit graphs show outlines by default, can be controlled from the Graph ➤ Preferences command.

Adding Drawing Objects
Various drawing objects can be added to the graph, as controlled by the Draw menu or the Drawing toolbar.
Selection Tool
When the selection tool is selected, the mouse pointer displays as an arrow. Clicking on a drawing object will select it, allowing moving or resizing. Clicking on the graph background and dragging will allow selection of a number of items, which can also be achieved by clicking on items while holding down the SHIFT key.

All Other Tools
Use of all other drawing tools follows a simple procedure. The tool is selected, which results in the mouse cursor being shown as a cross. Click the left mouse button where you wish the element to be drawn and drag until it is the correct size. When the button is released, the element is drawn using the current fill, line and font settings (these can be specified, see later). Creating graphs using the graph wizard will be discussed in the next chapter.

Manipulating Drawing Objects

Selecting Objects
To select an object, move the mouse pointer over it and left-click.

Moving Objects
To move an object or group of objects, select the objects required and then drag them to where you wish them to be placed.

Duplicating Objects
If the CTRL key is held down while dragging an object, a duplicate of the object will be moved to the new location.
Sizing Objects

To resize an object, first select it and then drag one of the resizing handles that are drawn in the corners of the object. Solid resizing handles are drawn on objects that can be resized; hollow handles are found on objects that do not permit resizing.

This selected object has solid resizing handles that permit resizing.

This selected object has hollow resizing handles, and cannot be resized.

The resizing action can be modified by holding down the SHIFT or CTRL keys while dragging the handle. It is possible to combine these effects by holding down both keys together.

<table>
<thead>
<tr>
<th>Key</th>
<th>Effect on dragging</th>
</tr>
</thead>
<tbody>
<tr>
<td>SHIFT</td>
<td>The aspect ratio of the object is maintained during resizing.</td>
</tr>
<tr>
<td>CTRL</td>
<td>The object remains maintains its current center position during resizing.</td>
</tr>
</tbody>
</table>

Resizing Text Objects

Text objects have slightly different resizing behavior to other graph objects. Text objects always wrap their text to fit, so the height of a text object is determined by its width, the text it contains and the current formatting. Resizing a text object will therefore change the text wrapping.
# Common Actions

The following actions are common to many of the objects that are found on the graph.

<table>
<thead>
<tr>
<th>Action</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left click</td>
<td>The object under the cursor is selected, and any selected objects are deselected. If the cursor is not over a drawing object, then any selection is removed.</td>
</tr>
<tr>
<td>SHIFT + left click</td>
<td>The object under the cursor is added to the current selection.</td>
</tr>
<tr>
<td>Right click</td>
<td>An object-specific context menu is displayed.</td>
</tr>
<tr>
<td>Left click + drag</td>
<td>The selected object (s) are moved. Dragging can be stopped by right-clicking or by pressing the <code>ESCAPE</code> key.</td>
</tr>
<tr>
<td>CTRL + left click + drag</td>
<td>The selected object (s) are duplicated, and a copy of these of these is moved to the new location. This procedure can be stopped by right-clicking or by pressing the <code>ESCAPE</code> key.</td>
</tr>
<tr>
<td>SHIFT + left click + drag</td>
<td>The selected object (s) are moved, but the movement is constrained to a purely horizontal or vertical direction, depending upon the initial direction of the drag.</td>
</tr>
<tr>
<td>ALT + left click + drag</td>
<td>Certain objects are normally constrained in their locations. For example, graph scale text is normally only allowed to be moved normal to the axis orientation. Holding down the <code>ALT</code> key removes such constraints and allows arbitrary positioning.</td>
</tr>
<tr>
<td>Double left click</td>
<td>For most objects, this displays the object Properties dialog. The exceptions are text objects, for which this results in editing of the text, and OLE objects, for which this results in executing the default object action (normally opening the item for editing).</td>
</tr>
<tr>
<td>Cursor shape</td>
<td>Meaning</td>
</tr>
<tr>
<td>--------------</td>
<td>---------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Cursor 1" /></td>
<td>The cursor is over a selected object that can be moved in any direction, only in a horizontal direction, or only in a vertical direction, respectively.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Cursor 2" /></td>
<td>The cursor is over a selected object that can be moved in any direction, and the CTRL key is down. This means that dragging the element(s) will result in creation of a copy of the selection.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Cursor 3" /></td>
<td>(Polygon objects only.) The cursor is over one of the lines of the polygon, and the CTRL key is down. Under these circumstances, left clicking will add an additional control point to the polygon.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Cursor 4" /></td>
<td>(Polygon objects only.) The cursor is over one of the control points of the polygon, and the CTRL key is down. Under these circumstances, left clicking will delete this control point from the polygon.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Cursor 5" /></td>
<td>(Text objects only.) The cursor is over the text object, which is currently open for editing.</td>
</tr>
</tbody>
</table>

**Grouping Objects**

Drawing objects can be grouped in order to ensure that they can be moved as one. To group objects, select those required and choose the **Object ➔ Group** command. Objects that have been grouped can have their grouping removed using the **Object ➔ Ungroup** command.

**Aligning Objects**

Selected objects can be aligned by selecting those required, and choosing the appropriate **Object ➔ Align** command. Objects are aligned relative to the last object that was selected.

**Setting the Z-Order**

Objects are drawn on the graph page in a defined order, with the uppermost item overlaying ones beneath. This z-order can be changed for a selected object by using commands found on the **Object** menu.

<table>
<thead>
<tr>
<th>Command</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bring to Front</strong></td>
<td>The selected object is brought to the front of all objects on the graph.</td>
</tr>
<tr>
<td><strong>Send to Back</strong></td>
<td>The selected object is placed underneath all objects on the graph. This may result in the object becoming obscured by others on the page.</td>
</tr>
<tr>
<td><strong>Move Forward</strong></td>
<td>The selected object is moved one place forward in the z-order.</td>
</tr>
</tbody>
</table>
Chapter 13: Graph Item

Command | Meaning
---------|-------------------------------------------------
Move Back | The selected object is moved one place back in the z-order.

**Setting the Object Color**

The fill, pen and text colors of an object are specified separately, and can be set using the **Object** menu. A quicker, and more convenient, way to set these colors is using the Color toolbar located (by default) at the bottom of the graph window.

<table>
<thead>
<tr>
<th>Color selection</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>§</td>
<td>Fill color is specified.</td>
</tr>
<tr>
<td>§</td>
<td>Pen color is specified.</td>
</tr>
<tr>
<td>§</td>
<td>Text color is specified.</td>
</tr>
</tbody>
</table>

The toolbar item is used to specify that no color should be used. For example, making this selection for the fill color of an object results in the object being drawn transparently. The **Other** button is used to make more specific color selections than are available from the toolbar.

**Note** Some objects (notably graph objects) have more complex color settings than can be made using the Color toolbar. For these it is possible to select other color options from the object **Edit ➤ Properties** dialog.

**Setting Default Colors**

The default fill, line and text colors for new graph objects can be specified by altering the color when no object is selected. The new default colors will be used next time an object is added. Alternatively, the **Graph ➤ Preferences** command can be used to set these defaults. This command also lets the default settings be stored for subsequent GraFit sessions.

**Setting Text Properties**

Text properties are specified by commands found on the **Text** menu, or alternatively, on the Formatting Style toolbar.
The font, size, style, alignment and orientation of the text can be specified from this toolbar. Further text properties are also available from the Edit ➤ Properties dialog, including superscript and subscript settings.

If a text object is selected by clicking on it, changing text properties will alter the appearance of the entire object. For example, if a text item is selected and the color set to red, then all the object text will become red. Finer control of text settings is possible for editable text by double-clicking on the text item, then selecting just a portion of the text. The Edit ➤ Properties command (or the Formatting Style toolbar buttons) will then apply only to the selected text.

### Setting Default Text Properties

The default font properties for new text objects can be specified by altering a property (for example, changing the font size) when no object is selected. The new defaults will be used next time a text object is added.

### Using Field Codes

Text within graphs can contain field codes that are substituted with values such as entries from a data table. This allows graph text to incorporate information from other item windows; such information is updated dynamically. Field codes are entered between curly braces ("{}") and have the following syntax:

```
{"item name" command parameters}
```

The first entry is that of the item window from which the information is to be obtained. This name must be surrounded by quotes if the item name contains space characters. The next entry is a command name, which is specific to the item window type. Finally, there are one or more optional parameters, which are specific to the command and separated by spaces.
### Data Table Command

<table>
<thead>
<tr>
<th>Command</th>
<th>Parameter(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AssValue</td>
<td>col index</td>
<td>gets the associated value “index” for column “col” (the lowest allowed index number is 2)</td>
</tr>
<tr>
<td>ColumnName</td>
<td>col</td>
<td>The parameter col is the number of the column. The value returned is the name of the column within the data table</td>
</tr>
<tr>
<td>Data</td>
<td>col row</td>
<td>The data entry from column “col” and row “row” is returned.</td>
</tr>
</tbody>
</table>

### Result Item Command

<table>
<thead>
<tr>
<th>Command</th>
<th>Parameter(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>xColumn</td>
<td>no</td>
<td>Returns the name of the $x$ data column. For data with a single dependent variable, “no” is the fit number; for data with two independent variables, “no” is the data set number; for data with multiple independent variables then “no” is the $x$ data number.</td>
</tr>
<tr>
<td>yColumn</td>
<td>no</td>
<td>Returns the name of the $y$ data column. For data with a single dependent variable, “no” is the fit number; for data with two independent variables, “no” is the data set number.</td>
</tr>
<tr>
<td>errColumn</td>
<td>no</td>
<td>Returns the name of the error data column. For data with a single dependent variable, “no” is the fit number; for data with two independent variables, “no” is the data set number.</td>
</tr>
</tbody>
</table>

### General Object Properties

Selecting the **Edit ➔ Properties** command, or double-clicking on a graph object, shows the object properties dialog box. This dialog box contains a number of pages, some which are common to many objects and some which are specific to the object selected. The common property pages are shown below; specific property pages discussed later.
Fill Properties

Check the Fill box to fill the object with the selected color. If this box is unchecked, the object will be transparent.

Line Properties

The Line page sets the width, style and color of the line. It is possible to set the Style to “No line” if you do not wish a line to be drawn.
Chapter 13: Graph Item

Rotation Properties

Objects can be rotated, and their rotation is specified from the Rotation page. Rotation is entered in degrees, which is measured in a counter-clockwise direction. The rotation can be set as an absolute figure, or relative to the current rotation.

Location Properties

The location of the selected object is set from the Location page. This allows the object position to be specified exactly, relative to the current margin or to the edge of the page.
Objects that can have lines with terminating ends allow the end type to be specified via the Arrows page. Choose from a variety of arrow styles for each end of the line, together with the end size and width. The arrowhead color is set to be the same as the line color.
Font Properties

The Font page sets the font to use, together with the style, size and various effects including superscript and subscript options.
Paragraph Properties

This page sets the formatting for the selected paragraph(s) or text.

Exporting Graphs

While it is possible to insert graphs into other applications via the Clipboard, for publishing purposes it is often important to create image files in a portable format. The **File ➤ Export Graph** command allows graph images to be saved using a file format that can be used by other applications. The following graph file types can be generated:

- Windows Metafile (WMF)
- Enhanced Metafile (EMF)
- Bitmap file (BMP)
- Tagged Image Format File (TIFF) (compressed or uncompressed)
CHAPTER 14

X/Y Scatter Graphs

The XY Graph Wizard

Chapter 12 described the basics of creating graphs. Selection of an X/Y Scatter Graph produces the “XY Graph Wizard” to assist with the procedure (all settings can be adjusted later, if required).

Select Data Source Page

![XY Graph Wizard - Select Data Source](image)

The Select Data Source page allows you to choose the source and type of the data to plot.

Legend text

The data set plotted is associated with an entry in the data legend. The entry shows the symbol used to represent the data, and a descriptive text. By default, the text used is taken from the y data column. However, if Name from Y is
unchecked then you can enter your own text into this field. This text field can also contain two special entries that allow the data set number or the fit number to be inserted into the data legend:

<table>
<thead>
<tr>
<th>Entry</th>
<th>Linear/non-linear Fit</th>
<th>Equation</th>
<th>Data table</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Replaced by the fit number</td>
<td>Replaced by the data number</td>
<td>Replaced by the data number</td>
</tr>
<tr>
<td>%2</td>
<td>Replaced by the data number</td>
<td>(not applicable)</td>
<td>(not applicable)</td>
</tr>
</tbody>
</table>

A data legend showing the symbol and descriptive text.

**Source**

Graphs are plotted using data that are present in one of the items found in the GraFit workspace. The Source selection lists all items that contain suitable data for plotting, and one of these must be selected. GraFit graphs can plot three different types of plot on an X/Y graph, depending on the source selected.

<table>
<thead>
<tr>
<th>Item Type</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data</td>
<td>When raw data are plotted, the data table item is selected and the x and y columns are selected for display. The data points can optionally be joined with lines or curves. If the data have been fitted to an equation, it is usually better to select the data fitting item as this will also show the fitted curve.</td>
</tr>
<tr>
<td>Equation</td>
<td>To plot a theoretical curve, select the equation item for the curve you want.</td>
</tr>
<tr>
<td>Linear Fit</td>
<td>Selecting a data fitting item (linear or non-linear fit) results in the data being plotted together with the fitted curve. This is usually the way of plotting data fitting results. Data fitting items may contain multiple fits, so when a data fitting item is selected, you have the option of displaying a single fit (and selecting which you require) or of plotting all fits.</td>
</tr>
<tr>
<td>Non-linear Fit</td>
<td></td>
</tr>
</tbody>
</table>

**X data column / Y data column**

When the Source is a data table item, it is necessary to select which columns hold the x and y data values to be plotted. For all other source types, these selections are not available.

**Error column**

Checking the Error column box allows a quick way of producing an error plot when the Source is a data table item. Select the column that holds the error
values from the list. More extensive error plotting options are available once the graph has been produced (see page 143).

**Transform as**

Check the **Transform as** box to plot the data after transformation using the selected transformation item. All available transformations (which must be present in the workspace) are listed. Transformation of data is only available if the **Source** is a data table or a non-linear fit item. See Chapter 10 for more information about plotting transformed data.

**Set Initial Scaling**

The Set Initial Scaling page allows the scale of the $x$ and $y$ axes to be specified. By default the scale is set automatically, and linear axes are chosen. These can be altered as required (it is also possible to adjust the scale settings later). The text used for the $x$ and $y$ axis can also be entered.
**Select Tick Styles**

The Select Tick Styles page allows rapid selection of some of the more common axis tick styles. More extensive tick style choices can be made once the graph has been created.

**Select Data Point Style**

(not equation items)

The Select Data Point Style page allows the data point representation to be chosen.
Size
Data points are scaled relative to the overall graph width, and so the absolute size will depend upon the graph dimensions. Choose a size that represents your data appropriately; with more data you should use smaller data points. If very many points are present it can be more effective to set the Style as None, and to join the data points with lines (next page).

Pen
Check this box to draw an outline around the data point. The size and color of the outline can be specified.

Fill
Check this box to fill the point with the solid color selected. If Fill is not checked, the data points will be transparent.

Mask curves
Check this option to ensure that any curves on the graph are not drawn immediately adjacent to the data points.

Enter Curve Parameters
(Equation items only)

When plotting theoretical curves, this page allows the parameter values that describe the curve to be entered.

Read from table
When this option is selected, the parameter values are read from the data table item and column that are selected. Any column in the data table can be selected,
but it is most convenient to use a column that has been specifically created to facilitate parameter entry (see page 45).

**Direct Entry**
When this option is selected, the parameter values are entered directly into the grid.

**Enter Curve Constants**
(Equation items only)
If the equation definition uses constants, their values are entered into this page. The operation of this page is analogous to that of the Enter Curve Parameters page described above.

**Select Fitting Curve Style**
(Fitting and equation items only)

![XY Graph Wizard - Select Fitting Curve Style](image)

**Fitting curve**
Choose the width, line style and color of the curve that represents the fit.

**X limits**
By default, the fitted curve is drawn over the entire range of the x axis. Some equations, however, are undefined over certain ranges (for example, at $x < 0$). When the **Start** or **End** box is checked, GraFit will set the limit automatically, but by unchecking these boxes it is possible to define the range over which the curve should be displayed.
Resolution

Fitted curves are calculated for a range of values between the Start and End limits. The Resolution entry controls how many points are used in this range. High resolution uses more points, which takes longer and uses more memory. In general, use the medium resolution unless the curve has a sharp discontinuity (e.g. when plotting a step function). Under such circumstances use the high resolution setting.

Select Join Style

(not equation items)

![Select Join Style](image)

**Type**

Chooses the type of join to use.

<table>
<thead>
<tr>
<th>Effect</th>
<th>Join Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Effect" /></td>
<td>None</td>
</tr>
</tbody>
</table>
Effect  

Join Type

<table>
<thead>
<tr>
<th>Effect</th>
<th>Join Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td></td>
</tr>
<tr>
<td>Bezier</td>
<td></td>
</tr>
<tr>
<td>Spline</td>
<td></td>
</tr>
</tbody>
</table>

Bezier
Three degrees of curvature are available: slight, medium and strong. The illustration shows a medium curve. Bezier curves give smooth lines between the points, and always pass each data point.

Spline
Four orders of spline curve are available: 3, 4, 5 and 6; the illustration is created using order 3. Higher orders give smoother curves. Spline curves smooth out variation in the data, and do not necessarily pass through the data points.

Width, Style and Color
These options control the appearance of the line that is drawn joining the points.

Modifying Graphs
Once created, graphs can be customized as required. This involves selecting the appropriate part of the graph, and invoking a specific property sheet by double-clicking, right-clicking or choosing the Edit ➔ Properties command.
Selectable Regions of a Graph

The illustration below shows the various parts of a graph that can be selected. For each, a specific property sheet is available that controls the formatting options.

Main Graph Region

The main graph region acts as the “parent” of the other selectable regions and is always visible (the other parts of the graph can optionally be hidden). Moving the main graph region will also move all the other “child” parts of the graph; however, the child regions can be moved individually to position them. This ensures that the whole graph can be moved around the page while maintaining the relative positioning of the constituent parts.
Note The $x$ and $y$ axis scales have a particular relationship with the main graph, as it is usual to ensure that their numbers line up with the scale marks. For this reason, by default it is only possible to move the $x$ axis scale in a vertical direction, and the $y$ axis scale in a horizontal direction. This effect can be overridden by holding down the ALT key when moving the axis scale texts.

General Page

Graph frame
Check the various boxes to draw a line on the various edges of the graph.

Drawing options
Check this box to specify that the graph frame, axes and tick marks should be drawn after the data points, which will result in these items lying on top of the data points. By default, XY graphs have this option unchecked and column graphs have it checked.

Visibility
The components of the graph are listed here, and their visibility can be set by checking the appropriate box. Individual items on the graph can also be hidden selecting the Edit ➨ Hide Object command.
**Fill Page**

The fill style applies to the graph background.

**Line Page**

The line style applies to the frame drawn around the graph, as set on the General page. It does not apply to the color of the tick marks, which are set on the appropriate tick page.

**X Ticks Page**

*X axis selector*

X/Y graphs can have multiple x axes, and the tick settings for each are set individually. Set the x axis number from this box (when first created, only a single x axis will be available).

**Tick settings**

Ticks can be drawn on the inside, outside, both sides or neither side of the Upper graph edge, the Lower graph edge, or on the X axis itself (assuming the scale settings are such that this lies in the center of the graph). The tick sizes can be set to small, medium or large, which are scaled relative to the overall graph width, or to “specific,” where the exact tick size is entered into the edit field.
**Axis offset**

The axis offset controls the distance that the axis scale is drawn from the frame. If the offset is 0, the scale is drawn immediately adjacent to the central graph frame; increasing offset results in the scale being removed from the frame, as shown below:

![No offset](image1)

![x axis offset](image2)

![x and y axes both offset](image3)

If more than one x axis is present, it can be useful to set each to have a different axis offset. This allows the two scales to be differentiated.

**Tick marks**

These settings control the width and color of the pen used to draw the tick marks.
**Major grid / Minor grid**

These settings control the display of grid lines drawn across the axis at intervals determined by the **Major increment** and **Minor increment** settings (Scale Page).

![No grid](image1)

![x axis with major grid (solid lines)](image2)

![x axis with major grid (solid lines) and minor grid (dotted)](image3)

**X Scale Page**

![XY Graph Properties](image4)
**Scale Type**
Select linear or logarithmic scaling.

![Graph with linear x axis scale](image1)

**Graph with linear x axis scale**

![The same graph with a logarithmic x axis scale](image2)

**The same graph with a logarithmic x axis scale**

**Scale Start**
If the box is checked, this value is set automatically from the graph data. Uncheck the box to specify the starting value of the x axis (left edge).

**Scale Finish**
If the box is checked, this value is set automatically from the graph data. Uncheck the box to specify the finishing value of the x axis (right edge).

**Scale major increment**
If the box is checked, this value is set automatically from the graph data. Uncheck the box to specify the major increment value. The major increment value controls how often scale numbers and major ticks are drawn.

**Scale minor increment**
If the box is checked, this value is set automatically from the graph data. Uncheck the box to specify the minor increment value. The minor increment value controls how often major ticks are drawn.
**Scale y axis position**

If the box is checked, this value is set automatically from the graph data. Uncheck the box to specify the axis position, which should lie in-between the **Start** and **Finish** values.

*The y axis position has been set so that it appears between the **Start** and **Finish** values. If required, tick marks can be drawn on the y axis line from the Y Ticks page (Y axis Tick settings).*

**X axis selector**

X/Y graphs can have multiple x axes, and the scale settings for each are set individually. Set the x axis number from this box (when first created, only a single x axis will be available).

**Axis extent**

By default, the **Entire graph size** box is checked, which ensures that the axis is drawn over the whole graph width. Unchecking this box allows the axis to be drawn over just a portion of the graph, which can be useful when multiple axes are present. Enter the **Start** and **End** values as percentages of the whole graph width. The **Axis break symbol** setting controls whether a break mark is drawn at the end of the axis. This setting is used when drawing split axis scales (see Chapter 15 for more information about multiple axes).

**Y Ticks Page**

The Y Ticks page controls the tick settings on the y axis in the same way as the X Ticks page controls the tick settings on the x axis (see page 129).

**Y Scale Page**

The Y Scale page controls the scale settings for the y axis in the same ways as the X Scale page controls scale settings on the x axis (see page 131).

**Location Page**

This sets the location of the graph within the graph page.
Axis Scale Regions

The axis scale region controls the display and formatting of the scale numbers.

Scale Page

Number format
These settings determine the way that the numbers are displayed.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal places</td>
<td>Enter the number of decimal places to display. Note that trailing zeros will be removed if the <strong>Trailing zeros in fraction</strong> setting is “Omit 0’s.”</td>
</tr>
<tr>
<td>Max digits</td>
<td>Enter the maximum number of digits to be used. The displayed values will be rounded to ensure that only the requested precision is displayed.</td>
</tr>
<tr>
<td>Thousands separator</td>
<td>Check this option to separate groups of digits by a separator. Typically, digits are grouped into threes and separated by a comma. However, the grouping and the separator used depend on values set by in the <strong>View ➤ Options</strong> command, Number Format pane, available from the main GraFit workspace window.</td>
</tr>
<tr>
<td>Scientific format</td>
<td>Check this option to display numbers using scientific format. For example, 1.234e+003 rather than 1234.</td>
</tr>
</tbody>
</table>
### Chapter 14: X/Y Scatter Graphs

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Power format</strong></td>
<td>Check this option to display numbers using a power representation. For example, $1.234 \times 10^3$ rather than 1234.</td>
</tr>
<tr>
<td><strong>Trailing zeros in fraction</strong></td>
<td>This controls the way that trailing zeros are displayed in a fraction.</td>
</tr>
</tbody>
</table>

Some examples of different formatting are shown below; all have **Decimal places** set to 4, and **Max digits** set to 10.

<table>
<thead>
<tr>
<th>Effect</th>
<th>Settings</th>
<th>Effect</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.01</td>
<td></td>
<td>1e-2</td>
<td></td>
</tr>
<tr>
<td>0.005</td>
<td>Omit 0’s</td>
<td>5e-3</td>
<td>Omit 0’s, scientific format</td>
</tr>
<tr>
<td>0</td>
<td></td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>0.0100</td>
<td>Show 0’s</td>
<td>$10^2$</td>
<td></td>
</tr>
<tr>
<td>0.0050</td>
<td></td>
<td>$5 \times 10^3$</td>
<td>Omit 0’s, power format</td>
</tr>
<tr>
<td>0.0000</td>
<td></td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

### Text

These settings control the text display.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Alignment</strong></td>
<td>The scale text can be aligned to the left, right or centrally.</td>
</tr>
<tr>
<td><strong>Orientation</strong></td>
<td>Select the orientation of the text. The following orientations are available:</td>
</tr>
<tr>
<td></td>
<td>![Alignment Options]</td>
</tr>
<tr>
<td><strong>Format string</strong></td>
<td>Check this option to embed the numeric value within a text string. The number is substituted for any occurrences of “%1” within the entered text.</td>
</tr>
</tbody>
</table>

### Values

The **Scaling power** setting allows a scaling factor to be applied to the numbers. Before display, the scale numbers are multiplied by 10 raised to the power of the value entered. The power must be a whole number, and may be positive or negative. For example, an entry of -4 would cause the value of 40,000 to be displayed as 4. An entry of 3 would cause the value 0.002 to be displayed as 2 ($0.002 \times 10^3 = 2$). A scaling power of 0 results in the actual value being displayed ($10^0 = 1$).

Scaling power entries are very useful when dealing with large or small data values. By scaling the displayed numbers it is possible to produce graphs that are correctly...
scaled, but to enter conventionally ranged values into the data table. For example, time values in nanoseconds could be entered into the data table as whole numbers of nanoseconds then a **Scaling power** of -9 applied.

**Axis Text Regions**

Axis text properties are controlled in exactly the same way as normal text objects. See Chapter 13 for further information.

**Legend Box Region**

The legend box lists all the data sets currently present within the graph.

**Legend Page**

![Legend Box Properties](image)

**Order**

The current arrangement of items within the legend box is displayed. This order can be changed by selecting an entry and clicking the **Move Up** or **Move Down** buttons.

**Layout**

This section controls the number of columns into which the data entries are arranged.
4 data entries, with **Number of columns** set to 1 (the default setting).

4 data entries, with **Number of columns** set to 2.

**Custom Margins and Spacing**

Checking the **Custom margins and spacing** box allows the spacing of the elements within legend box to be set explicitly.

**Fill Page**

This page sets the fill settings for the legend box.

**Line Page**

This page specifies the line used to draw the surround of the legend box.

**Location Page**

This page controls the position of the legend box within the graph page.
Data/Curve Properties

Data Points Page

This page is equivalent to the Data Point Style page of the XY Graph Wizard. See page 122 for further information.
Join Points Page

This page is equivalent to the Join Style page of the XY Graph Wizard. See page 125 for further information.
**Fitted Curve Page**

(fitted data and equations only)

This page is equivalent to the Fitting Curve Style page of the XY Graph Wizard. See page 124 for further information.
Chapter 14: X/Y Scatter Graphs

Data Source Page

(fitted data only)

Select the data fitting item to be plotted from the Results selection, which lists all the available linear and non-linear fits in the GraFit workspace. Fitting items can hold several fits, and the Fit number can be chosen. The first fit is fit 1, which in most cases will be the only fit present.

Check the Transform as box if you wish to display the data points and fitted curve transformed as defined in the selected transformation. All the transformations present in the workspace are listed. See Chapter 10 for information about defining transformation items.
Data Source Page

(raw data only)

Select the **Data table** item that holds the data, together with the columns that hold the $x$ and $y$ data.

Check the **Transform as** box if you wish to display the data points transformed as defined in the selected transformation. All the transformations present in the workspace are listed. See Chapter 10 for information about defining transformation items.
**Error Bars Page**

The error bars are drawn for the $x$ and $y$ axes separately.

**XY type**

- **Cross**
  - Error bars are drawn for the $x$ and $y$ axes separately.

- **Diagonal 1**
  - A single error bar is drawn, which extends diagonally to show the $x$ and $y$ error extents.

- **Diagonal 2**
  - A single error bar is drawn, which extends diagonally to show the $x$ and $y$ error extents.
The **Source data** entry must be completed if **Explicit** errors are specified for either $x$ or $y$ errors. Select the data table that is used for the explicit errors from the list given.

**X error bars**
This section is used to specify the type of errors present on the $x$ axis.

<table>
<thead>
<tr>
<th>Error type</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>No error bars are drawn. This is the default setting.</td>
</tr>
<tr>
<td>Absolute</td>
<td>The size of the error bar is the same for each data point of the data set; this size is entered into the field to the right of this button.</td>
</tr>
<tr>
<td>Proportional</td>
<td>The size of the error bar depends upon the magnitude of the data point; the size is expressed as a percentage of the data point value and is entered into the field to the right of this button.</td>
</tr>
<tr>
<td>Explicit</td>
<td>The size of the error for each data point is specified individually. The error values must be stored in a data table, which is specified in the <strong>General</strong> section, and the size of the positive and negative parts of the error bar is set separately. The data column that holds the positive error values is selected from the list marked “+.” If only this option is chosen, the error bar just has a single lobe. To specify additionally the size of the negative lobe, click the “−” button, and select the column that holds the value of this error. If you select the same column as selected for the positive error, this will result in symmetrical error bars.</td>
</tr>
</tbody>
</table>

The **Invert** check boxes allow the direction of the error bars to be reversed, drawing the error bar in the opposite direction.

Some examples of error bar types are shown below.


Y Error bars

This section is used to specify the type of errors present on the y axis. The settings are analogous to those described above for x error bars.

**Axis Association Page**

The Axis Association page allows the data to be associated with the various axes that are present (see Chapter 15 for information on multiple axes). XY graphs can contain many different x and y axes, and the data can be associated with one (the
minimum) or many different axis scales. Check the boxes of all axes that you wish to be associated with this data set.

**Equation Page**

(equation data only)

This page selects the equation that describes the curve to be plotted. All equation items present in the GraFit workspace are listed.
Chapter 14: X/Y Scatter Graphs

**Parameters Page**

(equation data only)

![Parameters Page](image)

This page is equivalent to the Curve Parameters page of the XY Graph Wizard, see page 123 for further information.

**Constants Page**

(equation data only)

![Constants Page](image)
This page is equivalent to the Curve Constants page of the XY Graph Wizard, see page 124 for further information. This page is present even for equations that do not define any constants, as is the case for the figure above.

Legend Text Regions

Legend text properties are controlled in the same way as normal text objects, except that legend text cannot be displayed rotated. See Chapter 13 for further information on text formatting.

Note The overall width of the data legend depends on the size of the individual legend text elements. Each of these can be individually sized using the mouse.

Adding Extra Data to the Graph

Additional data sets, fitted results or equations can be added to the graph by selecting the main graph region, then choosing the Graph ➤ Add Data command. This re-invokes the XY Graph Wizard to allow further data to be added. Most of pages are equivalent to those described earlier for creating new graphs, although those pages that control initial scaling are not relevant, and so are not displayed.

Set Axis Associations Page

When graphs are first created, they have a single x and y axis, with which the selected data sets are associated. However, after creation it is possible that a graph may have additional axes, and so the axis association needs to be specified when adding data. This results in an additional Axis Associations page being added to the Wizard.
This is equivalent to the Axis Association parameters page described on page 145. Check the boxes of the axes with which your data should be associated. In the figure shown above, the graph has a single x and y axis and so no modification is needed.
CHAPTER 15

Using Multiple Graph Axes

When to Use Multiple Axis Scaling

Graphs created using GraFit can optionally have several different x and/or y axes, which are independently scaled.

Overlaying Data that have Different Scales

Multiple axes are useful when data need to be overlaid, but have quite different numerical ranges. For example, in the plot below there are two separate y axes, but a common x axis. Two different data sets are plotted, each associated with different y scales.

XY scatter graphs can have as many different x or y axes as you require; bar charts and column charts allow unlimited numeric axes (the x and y axes, respectively, for these plots).
Split Axes

Split axes are used when it is necessary to show some region(s) of a data set at a different scale to the remainder. The example drawn below has a single split x axis. GraFit uses multiple axes to construct the splits, and permits any number of splits on both x and y axes.

Creating and Managing Multiple Axes

By default, GraFit graphs have just a single x and y axis. Any additional axes must be added to the graph using the Axis Manager, which allows axes to be created or deleted, and simplifies generation of split or multiple axes.

Running the Axis Manager

To activate the Axis Manager, select the graph to modify and choose the Graph ➨ Axis Manager command. This will launch the Axis Manager Wizard.
Six options are available on the initial page:

- Add a new x axis
- Add a new y axis
- Split an existing x axis
- Split an existing y axis
- Remove x axis
- Remove y axis

If only a single axis is present, the Remove axis options will not be available, as a minimum of one axis must exist. Select one of the options, and click the Next button.

**Adding a New Axis**

Choosing to add a new axis will give the following page.
A number of initial tick styles and axis text locations can be chosen, and in addition it is possible to specify that the new axis is created offset from the main graph. All new axes have associated axis and scale text, which needs to be positioned as appropriate. In addition, the new axis ticks are set and scaled independently of any tick settings already present on the graph. When you have made your initial choices, press the Finish button to add the new axis.

**Splitting an Existing Axis**

Choosing to split an existing axis from the Axis Manager will give the following page.

The axis to be split should be selected from the list available. The initial split position can be set using the slider control. By default, the axis is split in the middle, i.e. at 50%. Use the slide to set this to an appropriate position. The axis is
split so that the scale for two new axes is set as below, using the **Split value** to set the end of the first scale and the start of the second.

![Diagram of original and split axes]

After entering a suitable **Split value**, click the **Finish** button to create the new axis.

**Removing an Axis**

If you elect to remove an axis using the Axis Manager, you will be presented with a list of all axes that can be deleted.

![Axis Manager - Remove x Axis]

Choose the axis to remove, then click the **Finish** button to delete it from the graph. Any data or curves that are associated with the deleted axis become reassociated with the default (first) axis. You can modify axis associations by editing the properties associated with the data set. To do so, select the data symbol found in the data legend, and choose the **Edit ➔ Properties** command (or double-click on the data symbol).
Working with Multiple Axes

Axis Text and Axis Scale Text

Each axis has a separate text legend that can be positioned and edited as required, and a separate scale text that can also be formatted as required.

Visibility of Axis Text and Axis Scale Text

There are often cases where it is not necessary to show a separate axis text and/or axis scale text for each axis. The various items can be hidden by selecting the item, then choosing the Edit ➔ Hide Object command. Objects can also be hidden and unhidden from the General page of the graph properties (double-click on the main graph area, or choose the Edit ➔ Properties command when the main graph is selected).

Data Association

Any data that is added to a graph can be associated with one or all axes. When using multiple axes to display data that have distinct ranges, it is usual to associate each data set with one specific axis. For split axes, it is usual to associate all data sets with each axis. The data association for an axis is set from the Axis Association Page, found by double-clicking on the appropriate Data/Curve Properties region of the data legend (see figure above). Further information about modifying data properties is found in Chapter 14.
Axis Scaling and Sizing

Each of the multiple axes has separate scaling, size and tick settings. These are modified from the Scale or Ticks pages of the graph properties. To access these, select the graph and choose the Edit ➔ Properties command, or double-click on the main graph region. For more detailed information about setting these properties, see Chapter 14.

**Scaling**

Use the **Axis selector** to choose which axis is to be scaled, then set the scale as appropriate.

**Sizing**

The **Axis extent** settings on the page shown above control the proportion of the graph over which the current axis extends. When using multiple axes to show data of with different numerical ranges, it is normal to have the axis set to occupy the **Entire graph size**. However, in some circumstances it can be useful to limit the axis to a small region. For example, this can be a good way to overlay residuals, as illustrated below.
In this graph there are two $y$ axis scales, the first which holds the normal fitted data, and the second that is used to plot the residual error. The first $y$ scale is set to occupy from 0 to 70% of the graph size, the second is set from 70 to 100%.

**Setting the Split Position**

Split axes are created by using axis extents less than the full graph size, and by including a suitable Axis break symbol. In order to modify the split position along the axis, it is necessary to change the Start and/or End position of the Axis extent. This must be done for each axis concerned.

**Tick Settings**

Each axis has full control over where, and how often, ticks are drawn. For this reason, when a new axis is created it often the case that the initial tick settings overlap existing settings from existing axes. If this is the case, it is necessary to modify the tick settings for one or more axis in order to obtain a suitable appearance.
The **Ticks** page also includes an **Axis selector** section, which allows each different axis to be selected. After choosing the axis to modify, alter the tick settings as required.
CHAPTER 16

Column and Bar Charts

The Chart Wizard

Chapter 12 described the basics of creating graphs. Selection of Column Chart or Bar Chart produces the “Chart Wizard” to assist with the setup (all settings can be adjusted later, if required). Column and bar charts differ only in their orientation, and so the same process is carried out for each. The process of editing charts is broadly similar to editing X/Y graphs, and Chapter 14 should be consulted for further information.

Select Data Source Page

The Select Data Source page allows you to choose the source and type of data to plot.

(You can use the Graph | Add Data command to add more data sets to the plot)
Legend text
The data set plotted is associated with an entry in the data legend. The entry shows the symbol used to represent the data, and a descriptive text. The initial text used to describe the entry can be entered into this field.

Source
Graphs are plotted using data that are present in one of the items found in the GraFit workspace. The Source selection lists all items that contain suitable data for plotting, and one of these must be selected.

Category axis
Select which column holds the category names that are to be plotted.

Upper data
The Upper Data selection is used to choose the data column that holds the values to be associated with the selected categories.

Error column
Checking the Error column box allows a quick way of producing an error plot. Select the column that holds the error values from the list. More extensive error plotting options are available once the graph has been produced.

Lower data
Check the Lower data box to generate a High-Low chart (where the entries have both an upper and lower value). If this box is unchecked, a standard chart will be produced; if checked then it is necessary to choose the column that holds the lower data values for the High-Low chart.

Lower error column
When the Error column and Lower data boxes are both checked, the error values for the lower data are selected from this box.
Set Initial Scaling

The Set Initial Scaling page allows the scale of the data axis to be specified. By default the scale is set automatically, and a linear data axis is chosen. These can be altered as required (it is also possible to adjust the scale settings later). The text used for the data and category axes can also be entered.
Select Tick Styles

The Select Tick Styles page allows rapid selection of some of the more common axis tick styles. More extensive tick style choices can be made once the graph has been created.
Select Bar Style

The Select Bar Style page allows the chart bar representation to be chosen.
Select Data Point Style

It is possible to use data points to represent the values, if required. By default, no data point style is selected.
Select Join Style

It is possible to draw lines that join the points, if required. By default, no lines are drawn.

Click the Finish button to create the chart.
The Histogram Wizard

Chapter 12 described the basics of creating graphs. Selection of Histogram produces the “Histogram Wizard” to assist with the procedure (all settings can be adjusted later, if required). The process of editing histograms is broadly similar to editing X/Y graphs, and Chapter 14 should be consulted for further information.

Select Data Source Page

The Select Data Source page allows you to choose the source and type of data to plot.

Legend text

The data set plotted is associated with an entry in the data legend. The entry shows the symbol used to represent the data, and a descriptive text. The initial text used to describe the entry can be entered into this field.
**Source**

Graphs are plotted using data that are present in one of the items found in the GraFit workspace. The **Source** selection lists all items that contain suitable data for plotting, and one of these must be selected.

**Values column**

Select which column holds the data values whose distribution is to be plotted.

**Numbers column**

Check this box if a second column is present that holds a count of the number of items an item in the **Values column** is present. If unchecked, that it is assumed that each entry in the **Values column** is represented once only; if checked then the column that holds the number of entries must be selected.

**Start position**

Enter the starting position for the histogram grouping. The histogram records the number of occurrences of data values within a specified data range. This range is defined as having an origin at the **Start position** value, and the group size is set by the **Increment** value.

**Increment**

Enter the histogram increment value, as defined above.

**Set Initial Scaling**

The Set Initial Scaling page allows the scale of the data axis to be specified. By default the scale is set automatically, and linear axes are chosen. These can be
altered as required (it is also possible to adjust the scale settings later). The text used for the x and y axes can also be entered.

**Select Tick Styles**

The Select Tick Styles page allows rapid selection of some of the more common axis tick styles. More extensive tick style choices can be made once the graph has been created.

**Select Bar Style**
The Select Bar Style page allows the histogram bar representation to be chosen. Click the **Finish** button to create the chart.
CHAPTER 18

Embedding and Linking

What is Embedding and Linking?

Embedding and linking are two related ways that information from one application can be incorporated into a different program. Also known as Object Linking and Embedding (OLE), it provides a uniform mechanism for Windows programs to cooperate and to share information. Most Windows applications allow information to be copied between programs using the Clipboard. For example, a picture could be copied from one application and pasted into a second. The problem with simple cut and paste is that the second application often has no idea what information is being transferred. In non-OLE applications, this often means that once the information is copied it is impossible to make any subsequent changes to the image. OLE gets around this by allowing two cooperating applications to pass information between themselves in such a way that editing is still possible, even after pasting into an application that has no knowledge about the information transferred. Both embedding and linking are extensions of the standard Clipboard cut and paste mechanism.

Original Cut and Paste Model

The original use of the Clipboard was to pass a representation of the object being copied. For example, copying a graph might place an image of the graph on the Clipboard. Pasting would then insert this picture, as distinct from inserting the information required to draw the graph.

Standard cut and paste inserts an image representing the source object into the target application. This image is simply a picture, and contains no information about the underlying data in the source application.
Embedded Objects

Embedded objects hold both a display representation and the underlying data. A copy of the current state of the source object is created and is passed to the target application. This means that subsequent changes within the source application do not affect the newly pasted object. In turn, although the embedded object can be edited, any changes are not reflected in the original source document. Because a complete copy of the source data is placed in the target application, files containing embedded objects can be large.

![Diagram showing embedding process]

*Embedding places a copy of the internal data into the target application, as well as an image representing the source.*

Linked Objects

Linked objects also copy a representation of the original data, but do not copy the data itself to the target. Instead, the target application maintains a link to the original source file. Changes to this source data file result in the information copied to the target application also changing. In addition, if the linked object is edited from within the target, this will change the original document. Because linking must always involve files, it is only possible to create a link after the information in the source application has been saved to disk.

![Diagram showing linking process]

*Linking does not copy the original data, but allows the target application to maintain links to the original source file. Changes to the source result in the target application being updated.*

Using Embedding and Linking

Windows applications that are able to employ OLE use the convention that Edit ➔ Copy from the source program will place the necessary information on the Clipboard, and Edit ➔ Paste from the target application will embed an object.
Therefore, it is the standard that embedding is used by default. To link to an object, the same Edit ➤ Copy command is used in the source program, but, depending upon the target application, the object is inserted with the Edit ➤ Paste Link or Edit ➤ Paste Special command.

The OLE object can be activated by double-clicking on its representation within the target, or by accessing the object menu that resides on the Edit menu (and is often also available by right-clicking on the object).

**Comparison of Data Transfer Types**

The following table compares the various ways that data can be transferred between applications via the Clipboard.

<table>
<thead>
<tr>
<th>Non-OLE Clipboard transfer</th>
<th>Embedding</th>
<th>Linking</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>How to paste information in this format</strong></td>
<td>For non-OLE applications, Edit ➤ Paste</td>
<td>For OLE applications, Edit ➤ Paste</td>
</tr>
<tr>
<td>For OLE applications, Edit ➤ Paste Special and select a non-OLE format</td>
<td><strong>Advantages</strong></td>
<td><strong>Advantages</strong></td>
</tr>
<tr>
<td>Compact data format</td>
<td>Allows information to be edited after pasting</td>
<td>Allows information to be edited after pasting</td>
</tr>
<tr>
<td>Pasted information is stored within the target document</td>
<td>Since data are kept within the source file, this allows efficient use of space when several documents may wish to link to the same object</td>
<td></td>
</tr>
<tr>
<td><strong>Disadvantages</strong></td>
<td>No editing allowed after pasting</td>
<td>No link maintained with the source document</td>
</tr>
<tr>
<td>Documents containing embedded objects tend to be large</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
**Note** The default action for a Windows application that supports OLE is to embed information whenever possible if the **Edit ➔ Paste** command is used. As described in the table above, embedding is not always the most appropriate way of sharing the information, and linking is frequently more desirable, for which you need to select the **Edit ➔ Paste Special** command.

**Embedding and Linking without using the Clipboard**

Data objects can also be inserted into a target application directly, using an **Insert Object** command, which is often found on the **Edit** menu.

![Insert Object dialog box](image)

The **Insert Object** command allows the insertion of OLE objects into a document.

When the **Create New** button is selected, an empty object of the selected type is inserted as a new embedded OLE item. If the **Create from File** button is chosen, it is possible to initialize the embedded item using the contents of an existing file, or to create a linked object.

The **Create from File** option allows creation of an embedded object based on the contents of an existing file. If in addition the **Link** button is checked, a linked object will be created rather than an embedded one.

**Embedding and Linking with GraFit**

GraFit can act as both a container of OLE items that come from other source applications, and as the source of OLE items that are inserted into other targets. The situations where GraFit can act as container (target) or source are discussed below.
**GraFit as an OLE container**

There are several places where it is possible to insert OLE items into GraFit.

**GraFit Project Window**

The main GraFit project window can hold OLE objects, which are inserted from the Clipboard using the **Edit ➔ Paste** or **Edit ➔ Paste Special** commands or created anew using the **Edit ➔ Insert New Object** command. Objects inserted into the project window are always displayed as icons. Activation of these objects will always launch their source application in a separate window.

**Graph Window**

All graph windows can hold OLE objects, which can be inserted from the Clipboard as usual or created anew using the **Edit ➔ Insert New Object** command. Objects inserted in a graph window can be moved and sized as required. In-place editing is available by double-clicking on the item. The size of the object can be reset using the **Edit ➔ Reset Original Size** command.

**Equation and Transformation Definition Windows**

These GraFit item windows hold textual comments, which can incorporate embedded OLE objects. See Chapters 9 and 10 for further details.

**GraFit as an OLE source**

The contents of a GraFit workspace can be embedded or linked into other applications. What is displayed is the contents of a particular graph window, although the entire workspace information is copied. To embed a GraFit graph into another application, first activate the graph to use, then choose the **Edit ➔ Select All** command to ensure that all graph items are selected.

> **Note** It is extremely important to use the **Select All** command, as no OLE information is copied unless all items are selected). When all objects are selected, the **Edit ➔ Copy** command is replaced by **Edit ➔ Copy All**.

Next choose the **Edit ➔ Copy All** command. Insert the information into an OLE-compliant application using **Edit ➔ Paste** or **Edit ➔ Paste Special** as appropriate to the application in question.
This chapter describes some of the basic principles behind data fitting. A more complete description of the theory is given in Chapter 20, and additional information can be found in several reviews.\textsuperscript{1-6} Within GraFit, data are fitted using the Non-linear Fit or Linear Fit item windows, which are described in Chapters 6 and 8, respectively.

**When Is Data Fitting Appropriate?**

Data fitting is the mathematical analysis of a data set in order to analyze trends in the data values. This will usually involve linear or non-linear regression analysis of these data values, in order to define a set of parameter values that best characterize the relationship between the data points and an underlying theoretical model. While many types of data can be usefully presented in graphical form, not all such data are suitable for data fitting.

**Types of Data**

In general, data can be divided into three groups.

1. **No Systematic Trend**
   There are many examples of such data, and two are displayed below.

\begin{itemize}
\item Bevington, P.R. (1969) *Data Reduction and Error Analysis for the Physical Sciences* McGraw-Hill.
\item Leatherbarrow, R.J. (1990) *TIBS* 15, 455-458.
\end{itemize}
Such data are typically presented as bar or column charts, or as scatter plots with the data points joined by lines (or possibly by a smooth curve). As no systematic relationship describes the data, they are not suitable for data fitting.

2. The Trend is described by a Known Equation

This is the situation where data fitting is most useful. In this case, based on knowledge of the experiment, and the laws that govern it, the data are described by a known equation, i.e.

\[ y = f(x, p_1, p_2, p_3, \ldots) \]

In non-mathematical terms, the observed data, \( y \) (also known as the dependent variable), varies as a function of some experimentally controlled value \( x \) (the independent variable) and one or more parameters \( p_1, p_2, p_3, \) etc. The exact form of the equation depends on the experiment and the conditions that are used: it might be a simple linear equation,

\[ y = ax + b \]

or a more complex function. In either case, the purpose of data fitting is find values for the parameters in this equation that best describe the data. For a simple linear equation, as shown above, this is done by linear regression. In general, however, a more complex equation will apply. Such data are fitted by non-linear regression.
GraFit allows non-linear equations of arbitrary complexity to be used for data fitting.

3. A Systematic, But Uncharacterized Trend is Present

Occasionally, data may be collected that show a distinct trend, but no known equation describes this relationship. For example, an empirically determined calibration curve may be collected. If the physical basis for the shape of the data is not well defined, the appropriate equation is unknown. In such situations it can be useful to fit the data to a general-purpose equation, such as a polynomial. This will allow values to be extrapolated from the standard curve, although any parameter values that are obtained will not have physical meaning. The use of data fitting for this purpose is illustrated in Chapter 21.

Regression Analysis

Regression analysis finds the “best fit” line or curve through a series of data. This is considered to be the one that minimizes the sums of the squares deviations of the experimental data points from the theoretical curve. GraFit uses regression to allow the analysis of experimental data.

Practical Considerations

The Errors are in the y Data

It is the convention to assume that the $x$ data values represent the independent variable, and the $y$ data values represent the dependent variable, i.e. the $x$ data are what is varied in the experiment (for example time, concentration, etc.), and the $y$ data are the experimentally observed values.

The vertical distance (the gray lines in the above diagram) between the data point and the curve or line is that which is minimized by normal regression analysis, i.e., it is assumed that all errors are present in the $y$ data. An important aspect of experimental design is to ensure that the $x$ data are as accurate as possible so that this assumption is valid.
The Data Values Have A Suitable Numerical Range
A consequence of computer calculation is that rounding errors can occur, particularly if very large or very small numbers are used. This is because computers only store decimal numbers with a limited numerical precision. Although this should not affect most calculations, it is advisable to scale any set of very large or very small values prior to performing calculations. For example, if a series of time values were entered as 0 to $10^{-15}$ seconds, the rounding errors could be significant. Entering the data as 0 to 1 femtoseconds may be more appropriate.

Types of Regression Analysis
Regression acts to minimize the sum of the squares deviations of the experimental values from values calculated using some theoretical equation. However, the mechanics of the calculations are different for linear and non-linear equations.

Linear Regression
Linear regression is a technique that should be familiar to most scientists. It is the mathematical equivalent of using a ruler to draw the “best” line through a series of data points to obtain values for the slope and intercept of this line. The calculations needed to perform linear regression are relatively simple, and are even found on many scientific calculators.

Polynomial Regression
Polynomial regression is an extension of linear regression, where the equation is

$$y = a + bx + cx^2 + dx^3 + ex^4 + ...$$

Non-linear Regression
Non-linear regression allows data to be fitted in the more general case to any equation where the $y$ data value can be described as a function of the $x$ data and a series of parameters, i.e.

$$y = f(x, p_1, p_2, p_3, ...$$

As a result, it is applicable to many more situations than linear regression, and is more generally useful for analyzing experimental data. The only drawback to non-linear regression is that the calculations are too complex perform using a calculator, and require a computer program such as GraFit.

Additional Considerations for Non-linear Regression
The more complex nature of the non-linear regression calculations does require some further considerations compared with linear regression.
Equation to Use
Non-linear regression can employ a vast range of different equations. It is therefore necessary to select an equation that is appropriate to the particular experimental situation before fitting the data.

Initial Estimates
The mathematical method used to perform non-linear regression acts to take starting estimates for the parameters in the equation, and optimize them during the calculations. As described in Chapter 9, GraFit provides a mechanism for providing these initial estimates automatically for some equations, but in principle it is necessary to give the calculations some rough estimates prior to data fitting.

Convergence Criteria
Unlike linear regression, non-linear regression does not provide an exact solution, but, by an iterative process, calculates successively better parameter values until a suitable tolerance is reached. The criteria for defining this tolerance are determined by the program, and can be specified when using GraFit.

Weighting Scheme
Both linear and non-linear regression analyses incorporate assumptions about the accuracy of the data points. Normally, they assume that all data points are equally accurate, and so carry equal weighting in the analysis. It is also possible to use other weighting schemes that give different weighting to one or more data values. A full description of weighting is found in Chapter 20.

Linear Regression of Transformed Data
A familiar method of analyzing non-linear data graphically is to rearrange the data to a linear form, find the “best line” through the points, and so derive the parameter values. This is illustrated in the following example. Enzyme kinetic data are described by a hyperbolic equation of the form:

\( y = \frac{Ax}{B+x} \)

This can be linearized by plotting \(1/y\) versus \(1/x\), as

\[ \frac{1}{y} = \frac{1}{x} \cdot \frac{B}{A} + \frac{1}{A} \]

The ease of linear regression analysis makes it tempting to use in order to fit data that have been rearranged in this way. However, the results that are obtained are not statistically optimal. This is because the regression calculations make assumptions about the error distribution that are not usually valid after transformation. The distortion of the experimental errors by the above transformation is easily demonstrated in the following graphs.
Enzyme kinetics plot. The error is present only in the Rate (y axis) measurement. Errors are simple, i.e. all data points have the same error.

Double reciprocal (Lineweaver Burk) plot of the data above. Note the large distortion of the error bars resulting from this plot.

Here, the error involved in the high data points of the transformed plot is much greater than in the low data points — this is simply a consequence of the reciprocal transformation. Linear regression (unless suitable compensation is made for the distorted errors) is therefore not an appropriate way to analyze the data, and the original data should be fitted to the appropriate non-linear equation.

**Information Obtained from Data Fitting**

Data fitting provides the following information regarding the experimental data that are analyzed.

1. The values of the parameters in the equation used that best describe the data. These parameters may include (for example) rate constants, inhibition constants etc. whose values need to be determined.

2. The accuracy of these calculated parameters.

From this information it is possible to judge how well the data fit the experimental model (equation) that was used. In most cases, however, it is the numerical values of the parameters that are important, and whose values are required from the analysis.
Multiple Regression

The most common form of non-linear equation that is analyzed by GraFit is of the form

\[ y = f(x) \]

where the right hand side of this expression may contain one or several parameters. Such an equation has one dependent \( y \) and one independent variable \( x \). In addition, GraFit can be used to analyze equations with more than one independent variable, i.e.

\[ y = f(x_1, x_2, x_3...) \]

In this case the analysis is termed multiple non-linear regression. GraFit allows unlimited independent \( x \) variables, as well as unlimited numbers of parameters. Note, however, in all cases it is assumed that only the \( y \) axis data contain errors.

Note: Multiple regression is sometimes also referred to as "global analysis."

Uses for Multiple Regression

Multiple regression is essential when the data to be examined are inherently multidimensional. Examples include peak-shape analysis of 2D spectra. However, there are several situations where multidimensional data are collected, but are traditionally analyzed by a performing a series of normal two-dimensional \((x, y)\) curve fitting.

Example

The progress of an enzyme-catalyzed reaction at a fixed concentration of substrate is given by the equation:

\[ A_t = A_\infty (1 - e^{-kt}) \]

Here, \( A_t \) is the extent of reaction at time \( t \), \( A_\infty \) the maximum extent of reaction, and \( k \) the rate constant at this concentration of substrate. The value of \( k \) from this equation is related to the kinetic parameters by the equation:

\[ k = \frac{V_{max}[S]}{K_m + [S]} \]

In this equation, \( V_{max} \) and \( K_m \) are the parameters that we need to obtain from data fitting. The usual way of analyzing these data is to collect a series of progress curves \((A_\infty \) as a function of \( t \)) at varying concentrations of substrate. For each concentration of substrate the data are fitted to the first equation, and a value for \( k \) obtained. The resulting \( k \) values are then fitted to the second equation to find \( V_{max} \) and \( K_m \). A better solution is to recast the equation as a three-dimensional one, where the progress of the reaction varies with \( t \) and \([S]\), which are the two independent variables. The equation is obtained by combining the previous ones:
This allows $V_{\text{max}}$ and $K_m$ to be determined directly from the raw data, which has two $x$ variables ($t$ and $[S]$).

A sample set of data that has been fitted in this way can be found in the Examples data subdirectory, and is named "Multiple rate."

### Advantages of Multiple Regression

Use of multiple regression simplifies the analysis, as the curve fitting need only be carried out once. In the above example, the value of $A_\infty$ is fixed for the entire experiment and only found once for the multidimensional equation. However, if the data are analyzed by several applications of the first equation, the $A_\infty$ value would be determined several times.

### Disadvantages of Multiple Regression

The disadvantages of multiple regression are as follows.

- Conceptual. It is often difficult to visualize the problem in more than two dimensions.
- Finding initial estimates. This is sometimes difficult for the same reasons.
- Difficulty of display. The current version of GraFit does not support three-dimensional plotting; the display of four-dimensional data is even more problematic!

### Defining Equations

Definition of equations having multiple independent variables is achieved in the same way as the definition of normal two-dimensional $x/y$ equations, but the equations have more that one $x$ variable.

### Fitting Data by Multiple Non-linear Regression

For a normal data set that contains $x/y$ data, these data must be present in the data table with the $x$ data and the $y$ data in separate columns. When multiple independent variables are involved, there are special considerations as to how the data should be arranged.

**Case 1: The equation has only two independent variables**

In many circumstances there will be just two independent variables in an equation. In these circumstances, it is common to collect one set of $\{x_1, y\}$ data at a particular $x_2$ value, then the next set of $\{x_1, y\}$ data at a different $x_2$ value etc. In
the case of the example described above, this would entail collecting $A$ versus $t$ at one particular $[S]$, then another set of $A$ versus $t$ at the next $[S]$ and so on.

When this arrangement of data is present, it is convenient to enter the $\{x_1, y\}$ data into the data table, and to associate the $x_2$ value with the $y$ data column. For example, the data can be entered as shown below.

Note that the $y$ data each have an associated $x_2$ value. For this particular data set, all the $y$ data are associated with the same $x_1$ data, which corresponds to the Non-linear Fit data layout type:

$x(2)$ from $y$ header $\boxed{x_1 \ y_1 \ y_2 \ ...}$

(See Chapter 6 for more details about the Non-linear Fit window.)

It is also possible to have a separate set of $x_1$ data for each $y$ data, corresponding to the Non-linear Fit data layout type:

$x(2)$ from $y$ header $\boxed{x_1 \ | \ y_1 \ x_2 \ | \ y_2 \ ...}$

Case 2: The equation has several independent variables

When an equation has several independent variables it is necessary to have the $x_1$, $x_2$, $x_n$, $y$ data in separate columns. This corresponds to the Non-linear Fit data layout type:

$x(n)$ from table $\boxed{x(1) \ x(2) \ x(n) \ y}$

In order to distinguish the various data types, it is essential that all the $x$ data columns are set to “$x(n)$ Data” with the “$n$” value representing the order of the $x$ variable found in the equation definition. See Chapter 5 for further details on column types.
Data Fitting

Apart from the considerations above, fitting data that have multiple independent variables is no different from fitting standard equations. A sample set of data that has been fitted in this way can be found in the Examples data subdirectory, and is named "Multiple rate."

Plotting Results from Multiple Regression

The data that form the basis for multiple regression have three or more dimensions. To represent such data would, strictly speaking, require a multidimensional plot, which is not available. However, the usual representation for such data is to plot multiple curves, representing the raw data as collected, on the same graph. This is particularly simple for the situation noted as “Case 1” above. Choosing to create a graph to display the non-linear fit will automatically generate a suitable plot. In the case of the sample data set, the fitted curve is shown below.
To make best use of GraFit, it is helpful to know some of the theory behind regression analysis. Chapter 19 provided a general overview; this section describes more of the theoretical background.

Regression Analysis

Regression analysis is a technique used to calculate the "best fit" line or curve through a data set by minimizing the deviation of the data from the curve. Mathematically, it finds values for various unknown parameters in an equation (for example, the slope and intercept of a straight line) that produce the smallest possible sum of the squares deviations of the experimental values from the calculated ones. This quantity that is minimized is denoted by the symbol $\chi^2$ (chi-squared). The value of $\chi^2$ includes the variance of the data point (the variance of data point $i$ is $\sigma_i$), so that data points that have greater errors contribute less to the analysis. It is calculated as:

$$\chi^2 = \sum \left( \frac{\Delta y_i}{\sigma_i} \right)^2$$

$\Delta y_i$ is the difference between the experimental and calculated $y$ data values (the subscript "$i$" is used to indicate the "$i$th" data value).

A further useful statistic is $\chi^2_{\nu}$, or the reduced chi-squared. This is defined as below.

$$\chi^2_{\nu} = \frac{\chi^2}{\nu}$$

Here, $\nu$ is the number of degrees of freedom, which is given by $\nu = N - n - 1$; $N$ is the number of data points and $n$ is the number of variables in the equation.

Regression analysis is the mathematical equivalent of finding the best line by eye—it has the advantage, however, of being non-subjective. It is also possible to fit the "best curve" through the data by non-linear regression. This has no manual equivalent (because humans are very poor at judging accurate curvature), but is equally simple mathematically using computational methods.
Assumptions in Regression Analysis

Regression analysis is probably the most powerful method to analyze data. However, such analysis involves several assumptions about the function chosen and the error structure of the data. These assumptions are listed below.

**The Correct Equation is used**

This assumption is often overlooked, but should be borne in mind when using any data analysis technique. It is important to be aware that deviations from ideality are often caused by use of an inappropriate equation. Graphical methods provide a useful means to see whether the chosen model equation is appropriate. This is because use of an inappropriate equation often results in systematic deviations from the curve, which is easy to see in a graph.

Residual plots of $\Delta y$ versus $x$ are useful to assess whether the equation is appropriate. Systematic deviations in the residuals can mean that the equation used was inappropriate to describe the data. The differences between experimental and calculated values can be calculated using options available in the data table (see Chapter 5). The data shown below have been fitted to a single exponential decay, and to a double exponential decay, and the residuals from each have been plotted. Clearly, the residuals from the double exponential fit are smaller and more randomly distributed, and show that this fit is superior.
Only the Y Data Contain Errors

Only the dependent variable, which by convention is always the y variable \((y_i)\), is subject to error; the other \((x_i)\) is known exactly. This requirement should be satisfied by suitable experimental design — the x data values often comprise time or concentration values, which should be known with precision.

The Errors are Normally Distributed

The errors in the y data values should follow a normal distribution function, i.e. if sufficient replicates were taken they would have a Gaussian spread about the true y value. Two common factors that invalidate this assumption are the presence of \((i)\) systematic errors, and \((ii)\) outliers (data points that are wildly inaccurate, usually due to operator or machine failure). Systematic errors invalidate any data analysis, and should be removed by correct experimental design. Outliers can be eliminated by use of “robust” techniques, as will be described later in this chapter.

The Correct Weighting is used

An explanation of what “weighting” of data in regression analysis is, why it is incorporated into all such analysis (including the subjective regression performed by drawing the “best line” using a ruler), and how the appropriate weighting can be determined are described later.

Linear Regression

The simplest case for regression analysis is when the equation is linear. For the linear equation:

\[ y = a + bx \]

\(\chi^2\) is defined as:

\[ \chi^2 \equiv \sum \left( \frac{\Delta y_i}{\sigma_i} \right)^2 \]

\[ \chi^2 = \sum \left( \frac{1}{\sigma_i^2} (y_i - a - bx_i)^2 \right) \]

In this equation, \(\sigma_i^2\) is the standard deviation of the data point \(i\).

The best fit to this equation will yield parameter values for \(a\) and \(b\) that produce the minimum possible value of \(\chi^2\). This is equivalent to saying that the first derivative of \(\chi^2\) with respect to \(a\) and \(b\) is equal to zero:
\[ \frac{\partial}{\partial a} \chi^2 = \frac{\partial}{\partial a} \sum \left( \frac{1}{\sigma_i^2} (y_i - a - bx_i)^2 \right) \]
\[ = -2 \sum \left( \frac{1}{\sigma_i^2} (y_i - a - bx_i) \right) = 0 \]
\[ \frac{\partial}{\partial b} \chi^2 = \frac{\partial}{\partial b} \sum \left( \frac{1}{\sigma_i^2} (y_i - a - bx_i)^2 \right) \]
\[ = -2 \sum \left( \frac{x_i}{\sigma_i^2} (y_i - a - bx_i) \right) = 0 \]

If we rearrange these equations it is possible to solve for \( a \) and \( b \) exactly to give values for these parameters that minimize \( \chi^2 \). This is shown in the equations below.

\[
\begin{align*}
    a &= \frac{1}{\Delta} \left( \sum \frac{y_i}{\sigma_i^2} \sum \frac{x_i}{\sigma_i^2} \right) - \left( \sum \frac{x_i y_i}{\sigma_i^2} \right) \\
    b &= \frac{1}{\Delta} \left( \sum \frac{1}{\sigma_i^2} \sum \frac{y_i}{\sigma_i^2} \right) - \left( \sum \frac{x_i y_i}{\sigma_i^2} \right) \\
    \Delta &= \left( \sum \frac{x_i}{\sigma_i^2} \right) \left( \sum \frac{x_i y_i}{\sigma_i^2} \right) - \left( \sum \frac{x_i y_i}{\sigma_i^2} \right) \left( \sum \frac{x_i}{\sigma_i^2} \right)
\end{align*}
\]

**Weighting**

This analysis presupposes that we know the standard deviation, \( \sigma_i^2 \), for each data point. In general, we will not have such information available. However, only relative uncertainties need be known, and if we assume that all the data points have the same inherent errors, the equations simplify to give:

\[
\begin{align*}
    a &= \frac{1}{\Delta} \left( \sum y_i \sum x_i \right) - \left( \sum x_i y_i \right) \\
    b &= \frac{1}{\Delta} \left( N \sum y_i \sum x_i \right) - \left( \sum x_i y_i \right) \\
    \Delta &= \left( \sum y_i \right) \left( \sum x_i \right) - \left( \sum x_i y_i \right)^2
\end{align*}
\]
This assumption that the errors are constant is often made, for example in the simple linear regression calculations performed by pocket calculators. Although often true, this assumption is not always valid. In many experiments the uncertainty varies with the magnitude of the $y$ value, such that the percentage error is constant. To account for the different types of error distribution we introduce a weighting factor, which is related to $1/\sigma_i^2$ and is used to multiply all elements of the above matrices.

**Weighting Types**

The following types of error distribution are easily accounted for, and can be selected for use in the GraFit program within the Linear Fit or Non-linear Fit item windows.

**Constant error**

The standard error, $\sigma_i^2$, is the same for each data point and therefore a weighting factor of 1 is used (“Simple weighting”). This type of error is often given by instrumental variations (for example, a gauge may be read to an accuracy of 0.1 units, etc.).

**Statistical error**

For statistical variation, where $\sigma_i^2$ varies in proportion to $y_i$, the weighting factor is $1/y_i$. This type of error distribution is uncommon, but is found in systems where the main errors arise from sampling, for example counting low numbers of radioactive disintegrations.

**Proportional error**

For many experiments the percentage error is constant. In this case, $\sigma$ is proportional to $y$, leading to a weighting factor of $1/y_i^2$. A typical example of such errors might be when, for instance, a measuring instrument is accurate to 2% of the delivered volume, and the so error is proportional to the recorded value.

**Individually determined error**

All the above cases make assumptions about the error of each measurement. However, if sufficient replicates of each data point are available, or a complex error function is applicable, it is possible to calculate $\sigma_i^2$ for each point and use these values explicitly. This method can also be used if you know that certain values are less accurate than others (for example if they were measured in a different way) as again only relative $\sigma_i^2$ values need be given.

In practice, the use of simple weighting or proportional weighting is most often appropriate. If the errors are small the weighting function chosen has only a small effect on the calculated values. We will see later how it is possible to estimate which type of error function best describes a set of data. If any data values are
close to 0, it is not appropriate to use proportional weighting, and simple weighting should be selected.

Non-linear Regression

For an equation that is not a linear function the determination of best-fit parameters becomes slightly more difficult, although the principles discussed above still apply. The difficulty arises because it is not possible to derive an exact analytical expression for minimizing $\chi^2$. It is possible, however, to take initial estimates for the best-fit parameter values and to improve on them by a series of iterative calculations until values are obtained that approach the minimum $\chi^2$ value.

Apart from this mathematical inconvenience, non-linear regression functions in the same way as linear regression. We still need to know the weighting that has to be applied to the data, and the calculations still aim to minimize $\chi^2$. The advantage is that non-linear regression may be used to analyze any function that may be written $y = f(x)$, i.e. the $y$ data value is dependent upon some arbitrary single-valued function of the $x$ data value.

GraFit performs non-linear regression using the method of Marquart\(^7\) using a numerical second order method to calculate partial differentials. In this way it is possible to incorporate equations of arbitrary form. For an excellent explanation of regression analysis the reader is referred to the text by Bevington\(^8\).

Standard Errors of the Calculated Parameters

As well as giving the best-fit values for the parameters, regression analysis can provide estimates of the standard error of each parameter. GraFit calculates these errors by the matrix inversion method. These estimated standard errors are useful to show how accurate the calculated parameters are. As a rough guide, the standard error should not be greater than about 10\% of the parameter value if you are to have confidence in the calculated parameters. High standard errors will be obtained if the data are of poor quality, or if the data do not allow accurate estimation of one or more of the parameters.

Robust Weighting

One of the assumptions of regression analysis is that all the data points have a normal error distribution. However, a common feature of actual experimental data is the presence of one or two observations that are well outside the error range of the other observations. The stray data points are usually due to mistakes by the experimentalist (incorrect addition of reagents, inaccurate keying in of data, etc.)

---

The Marquart method is sometimes also referred to as the Marquart-Levenburg method. It is perhaps best explained in reference 2.

\(^8\) Bevington, P.R. (1969) *Data Reduction and Error Analysis for the Physical Sciences.*
and are termed outliers. If these points are included in the analysis they will disproportionately affect the results, since the square of the residuals for these points will dominate the fit. It is possible to edit the data manually to remove such points, but it is preferable to eliminate them in a less subjective manner. Robust methods achieve this by applying an additional weighting factor varying, for example, from 1.0 for points that have low residuals, to 0 for extreme outliers — effectively eliminating such points.

GraFit employs optional robust weighting using the algorithm of Mosteller & Tukey$^9$ as implemented by Duggleby$^10$. An additional 'bisquare' weight, $b$, is incorporated into the analysis, and is calculated as:

$$b_i = \begin{cases} 
(1 - u_i^2)^2 & \text{if } |u_i| \leq 1 \\
0 & \text{if } |u_i| > 1
\end{cases}$$

Here, with $z$ being the residual weighted by the a priori weight and $N$ the number of observations:

$$u_i = \frac{z_i}{6 \sum |z_i| / N}$$

Including robust weighting will result in improved estimates for the parameters in the presence of outliers. This is, however, gained at the expense of more calculation, which will slow down the fitting procedure.

The effect of using robust weighting is seen in the graph below:

---


The data, which contain a single outlier, have been fitted to a straight line with and without robust weighting enabled. When robust weighting is omitted, the presence of this outlier markedly affects the calculated results. With robust weighting selected, however, the rogue data point is rejected, and the calculated line now correctly follows the main trend.

**Determining the Most Appropriate Weighting**

For most experimental data the error is commonly either independent of the value of the observation (simple or constant errors) or is proportional to the $y$ data value (proportional errors). Simple errors may be caused by instrumental uncertainties (for instance, a machine reading may be only accurate to $\pm$ some intrinsic error, independent of the magnitude of the reading). Providing sufficient data points have been sampled, it is possible to determine the correct weighting by examination of the residual error (the experimental minus the calculated value). A plot of the residuals versus the observed value ($\Delta y$ versus $y$) is diagnostic of the type of error involved. For simple errors by definition, the residual is independent of $y$, as is seen in the plot (a). If the errors are of a proportional nature the residual plot will be as plot (c). A plot of the relative residual ($\Delta y/y$ versus $y$) results in the profiles (b) and (d) for simple and proportional errors respectively, and confirms the error distribution.
Plot of Residual Errors

Above is shown the type of residuals plots obtained when the error is constant or proportional in nature. It must be stressed that visualization of clear-cut plots of this kind depends upon having many data values to define the curves. The dotted lines on the plots show the envelope within which all points are expected to be found. Residuals can be calculated using options available in the data table (see Chapter 5).

Testing Goodness of Fit — $F$ Test

There are situations where it is necessary to know whether a set of data is fitted better by one particular equation or another. The $F$ test is a statistical way of judging the goodness of fit by two different equations. This test compares the $\chi^2$ values obtained from the two fits and the degrees of freedom in each, and calculates the probability that the fits are equally good. The $F$ statistic is calculated from the equation below.

$$ F = \frac{(\chi^2_1 - \chi^2_2) / (v_1 - v_2)}{\chi^2_2 / v_2} $$

A low probability value indicates that one of the two equations (that giving the lower $\chi^2$) fits the data significantly better. To be significant the probability should
be lower than 0.1, and preferably lower than 0.05. To perform the $F$ test, use the column type options available in the data table (see Chapter 5).

**Mean and Standard Deviation**

For a full description of means and standard deviations, see any text on statistics (for example, that by Bevington8). A brief description follows.

The mean value of a set of data points is defined as:

$$\mu \approx \bar{x} = \frac{1}{N} \sum x_i$$

Here, $\mu$ is the mean of the parent distribution, and $\bar{x}$ is the mean of our experimental sample. The uncertainty, or standard deviation, of the data points, $\sigma$, is estimated from the data as follows:

$$\sigma \approx s = \sqrt{\frac{1}{N-1} \sum (x_i - \bar{x})^2}$$

The uncertainty of the mean, $\sigma_{\mu}$, is given by the equation:

$$\sigma_{\mu} = \frac{\sigma}{\sqrt{N}} \approx \frac{s}{\sqrt{N}}$$

All the above equations assume that the uncertainties of all the data points are equal. If they are not, for reasons described earlier, we must use equations that incorporate weighting. For example, calculation of the mean becomes:

$$\mu \approx \bar{x} = \frac{\sum (x_i / \sigma_i^2)}{\sum (1 / \sigma_i^2)}$$
CHAPTER 21

Worked Data Fitting Examples

This chapter provides some further examples of data fitting to help acquaint you with the program. The examples are presented so that they can be worked through in a step-by-step manner. The data files that are used can be found in the “Examples” sub-directory of your data directory. Don’t worry if the examples do not seem relevant to the type of data that you need to analyze — the same principles are involved in all data fitting.

This chapter assumes that you are familiar with the basic functioning of the program, and if not you may like to consult the earlier chapters.

Using One of the Equations Provided

We will fit the data obtained from an NMR titration curve to obtain the $pK_a$ of an ionizable group.

**Background** The position of a peak in the NMR spectrum (the chemical shift position) resulting from a magnetic nucleus that is part of a titratable group depends upon the equilibrium between the two ionized forms. For example, in the following equilibrium:

$$A^- + H^+ \rightleftharpoons AH$$

Nuclei close to the ionizable group, $A$, will have chemical shift values that depend on the ratio of $A^-$ and $AH$. By definition, the acid dissociation constant, $K_a$ is given by

$$K_a = \frac{[A^-][H^+]}{[A]}$$

It is usually more convenient to use $pK_a$ values, where

$$pK_a = -\log_{10}K_a$$

The variation of the ratio of $A^-$ and $AH$ is given by the Henderson-Hasselbalch equation:

$$pH = pK_a + \log_{10} \frac{[A^-]}{[HA]}$$

The chemical shift observed for the nucleus varies between that measured at the extreme acid range, $\delta_{AH}$, and that at the extreme alkaline range, $\delta_A$, depending on the ratio of $[A^-]/[HA]$.

The data obtained are chemical shift values (in units of ppm, or parts per million) at various pH readings. These values need to be fitted to a single ionization curve.
where the start and end chemical shift values and the pK_a are the unknown parameters.

**Fitting the Data**

The example data are in the file “pH Titration”, which can be opened using the **File ➔ Open** command. Two columns are present in the data table: pH and Chemical Shift. No other workspace items are present.

**Load the Equation**

The first action to take is to load the correct equation. Use the **File ➔ Add Stock Item** command; select the “pH” tab and choose the “pKa, Single” equation definition item.

**Add a Non-linear Fit Item to the Workspace**

Use the **Add ➔ Non-linear Fit** command to add a non-linear fit item to the GraFit workspace.

**Fill out the Non-linear Fit Item Settings**

Complete the Settings page as shown below:

---

**Set up Initial Estimates**

The “pKa, Single” equation is one for which initial estimates for the parameter values are difficult to provide automatically. Therefore it is necessary to enter these initial estimates explicitly. For equations that require initial estimates it is essential to set these from the Estimatrix page. Click on the Estimatrix tab, then on the **Interactive Estimator** button.
Enter values into the **Estimated value** grid; as you move the entry position, the new values will be used to create a theoretical curve (red) on the plot. As described in Chapter 20, the starting estimates for non-linear regression should be reasonably close to the true values, but it is not necessary to be too exact. The program then iterates to find successively better values until a satisfactory fit is found. When you are satisfied with your estimated values, click **OK** to return these as the starting estimates on the Estimatrix page.

**Fit the Data**

To fit the data, choose the **Calculate ➔ Fit Data** command. The results are then calculated, and can be displayed using the **File ➔ Print Preview** command, or viewed from the Results page.
**Graph the Fit**

To plot a graph of the fitted data, add a new graph to the workspace using the **Add ➔ Graph** command. Elect to create an X/Y Scatter Graph, then use the newly-created non-linear fit item as the source of the data:

![GraphWizard.png](attachment:GraphWizard.png)

Show the Results on the Graph

It is often a good idea to display the data fitting results on the graph. To do this, select the **Draw ➔ Results Listing** command, and elect to display the results of your non-linear fit item.

![ResultsListing.png](attachment:ResultsListing.png)

The Final Result

For these data, the final result is shown below. Here, the results listing has been added to the graph, and in addition the \( pK_a \) value has been indicated visually using the “\( pK_a, \) Single, Show pKa” transformation. It is clear in this instance that the fitted curve describes the data well.
Checking the Weighting

It is often useful when performing an experiment for the first time to estimate the type of weighting that should be used. It must be stressed that for these checks to be meaningful a large number of data points should be available, and the equation describing the data must be well established.

As was described in Chapter 20, plots of residual error ($\Delta y$) versus $y$ or $\Delta y/y$ versus $y$ give characteristic patterns for the common simple and proportional error distributions. We will produce these plots for the data that have been fitted above.

Drawing Residual Plots

We will plot the residual plot $\Delta y$ versus $y$. To make this plot we need a column of data containing the $\Delta y$ values. This can be created after data fitting by setting the
Table ➤ Column Type of one of the columns to Calculated Values ➤ Difference.

Select the Non-linear fit that was generated above, and click OK.

It is advisable to set the column name so that you can identify it; in the current example it has been set to “Differences”

To create a graph of the residuals on a new graph page, select the Add ➤ Graph command, and create an X/Y Scatter Graph. Create this graph using the data table as the source, the Chemical Shift for the x data and the Differences column for the y data:

Elect to join the points with a straight line, as below.
The resulting graph is shown below.

As is clear from the shape of this plot (see the discussions in Chapter 20), it was probably correct to use simple weighting with these data.

$\Delta y$ versus $x$ plots are easily made by plotting pH against the Differences. To make $\Delta y/y$ versus $y$ plots, it is possible to create a new column to hold the result of dividing the Differences column by the original $y$ data column (Chemical Shift). This can be created after data fitting by setting the **Table ➔ Column Type** of one of the next available columns to **Column Combinations ➔ A/B**.
Using Robust Weighting

Robust weighting is additional weighting that is applied to a data set. It acts to reject data points that are very much in error, and so removes the occasional rogue data point or “outlier” that may be present in a data set. A complete description of the background to robust weighting can be found in Chapter 20.

To show the detrimental effects of outliers on curve fitting, and see how robust weighting eliminates these effects, an analysis has been created which can be found in the file “Robust weighting”. The data being have a linear relationship, but are fitted using a linear equation defined as a non-linear equation in order to make use of the robust weighting option that is available for non-linear fitting.

*Note* It is not possible to use a linear fitting item when using robust weighting.

The graph obtained by plotting the data with the best-fit lines obtained with and without robust weighting is shown below.
As is apparent, without robust weighting selected the presence of the outlier biases the fit considerably. This is because the large sum-of-squares residual from this point has a disproportionate effect on the regression analysis. However, using robust weighting eliminates the outlier, and the regression line is drawn through the majority of the data points.

**Defining a New Equation (1)**

There are very few examples found in the literature where both raw data and calculated values are included. However, the paper by Roughton et al. (1955)\(^\text{11}\) is notable because the raw data are presented with a set of calculated results. Also the equation to be fitted is somewhat complex. Because of this, these data provide a good test for a data analysis package. The Roughton paper examines the binding of oxygen to sheep hemoglobin, as a function of the pressure of oxygen.

Hemoglobin has four non-equivalent sites, and the binding is described by the equation:

\[
\text{Saturation} = \frac{K_1p + 2K_1K_2p^2 + 3K_1K_4K_3p^3 + 4K_1K_2K_3K_4p^4}{4(1 + K_1p + K_1K_2p^2 + K_1K_2K_3p^3 + K_1K_2K_3K_4p^4)} \times 100\%
\]

In this equation, \(p\) is the pressure of oxygen, and \(K_1\) to \(K_4\) are the equilibrium constants for the binding of four successive moles of oxygen per mole of hemoglobin.

The data are in the file “Hemoglobin saturation”. Read this file in using the File ➔ Open command. An interesting feature of these data is that some data points were

---

collected with greater accuracy than others. To account for this it is necessary to use Explicit weighting.

**Defining the Oxygen Binding Equation**

To define this equation we need to create a new definition in our workspace using the **Add ➤ Equation** command. (See Chapter 9 for a complete description of defining equations.)

Definition of the new equation requires that we make appropriate entries in this item window.

### X Variables

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>( p )</td>
<td>( p \text{O}_2 )</td>
</tr>
</tbody>
</table>

### Parameters

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>( K_1 )</td>
<td>( K_1 ) value</td>
</tr>
<tr>
<td>( K_2 )</td>
<td>( K_2 ) value</td>
</tr>
<tr>
<td>( K_3 )</td>
<td>( K_3 ) value</td>
</tr>
<tr>
<td>( K_4 )</td>
<td>( K_4 ) value</td>
</tr>
</tbody>
</table>

**Y name:** Sat

**Definition:**

\[
Sat = 100 \left( K_1p + 2*K_1*K_2*p*p + 3*K_1*K_2*K_3*p*p*p + 4*K_1*K_2*K_3*K_4*p*p*p*p \right) / (4 \left( 1 + K_1*p + K_1*K_2*p*p + K_1*K_2*K_3*p*p*p + K_1*K_2*K_3*K_4*p*p*p*p \right))
\]

The appearance of the equation definition item after entering this definition, and changing the name of the item, is shown below.

---

12 As this definition is for demonstration purposes only, it is defined in this way as this is the nearest form to that of the equation given. Although the definition would function in this form, it is rather inefficient to write it like this, and a better approach would be to enter the mathematically simpler:

\[
Sat = 100 * K_1*p*(1 + K_2*p*(2 + K_3*p*(3 + K_4*p*4))) / (4*(1 + K_1*p*(1 + K_2*p*(1 + K_3*p*(1 + K_4*p)))))
\]
To fit these data, add a new non-linear fitting item using the **Add ➤ Non-linear fit** command, then complete the Settings page as below:

Note the use of Explicit weighting, which requires the selection of the column that holds the error values. The results of the analysis are as follows:
For comparison, the results quoted by Roughton et al. are given below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Std. Error</th>
</tr>
</thead>
<tbody>
<tr>
<td>K1</td>
<td>0.0961</td>
<td>0.0049</td>
</tr>
<tr>
<td>K2</td>
<td>0.1040</td>
<td>0.0293</td>
</tr>
<tr>
<td>K3</td>
<td>0.3352</td>
<td>0.1018</td>
</tr>
<tr>
<td>K4</td>
<td>0.9263</td>
<td>0.0648</td>
</tr>
</tbody>
</table>

It should be borne in mind that Roughton et al. performed their regression analysis without the aid of personal computers or even pocket calculators!

**Defining a New Equation (2)**

The hybridization of RNA and cDNA molecules is used to provide information about the genome organization and complexity of an organism. This hybridization can be described by the equation:

\[
\frac{d}{D_0} = B + \sum_{i=1}^{n} P_i \left[ 1 - e^{-0.693(\text{Rot} / \text{Rot}_{0.5(i)})} \right]
\]

Here, \(d/D_0\) is the fractional hybridization at any given value of Rot (moles second L\(^{-1}\) of nucleotides of RNA), B is a background value, \(P_i\) is the proportion of the total cDNA hybridized to the \(i\)th component, and Rot\(_{0.5(i)}\) is the Rot value at which 50% of the cDNA of the \(i\)th component is hybridized. In practice, the data obtained may be fitted assuming three binding components, giving a total of seven independent
variables. Green et al.\textsuperscript{13} have presented a sample of such data; these can be found in the file "DNA hybridization".

**Defining the Equation**

The equation can be defined as follows:

<table>
<thead>
<tr>
<th>X Variables</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rot</td>
<td>Rot</td>
<td>Rot value</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>B</td>
<td>Background</td>
</tr>
<tr>
<td>P\textsubscript{1}</td>
<td>P1</td>
<td>Proportion Component 1</td>
</tr>
<tr>
<td>Rot\textsubscript{0.5(1)}</td>
<td>R1</td>
<td>Rot 0.5 (1)</td>
</tr>
<tr>
<td>P\textsubscript{2}</td>
<td>P2</td>
<td>Proportion Component 2</td>
</tr>
<tr>
<td>Rot\textsubscript{0.5(2)}</td>
<td>R2</td>
<td>Rot 0.5 (2)</td>
</tr>
<tr>
<td>P\textsubscript{3}</td>
<td>P3</td>
<td>Proportion Component 3</td>
</tr>
<tr>
<td>Rot\textsubscript{0.5(3)}</td>
<td>R3</td>
<td>Rot 0.5 (3)</td>
</tr>
</tbody>
</table>

**Y name:** Sat

**Definition:**

\[
\text{Sat} = B + P_1 \times (1 - \exp(-0.693 \times \text{Rot}/R_1)) + P_2 \times (1 - \exp(-0.693 \times \text{Rot}/R_2)) + P_3 \times (1 - \exp(-0.693 \times \text{Rot}/R_3))
\]

**Fitting the Equation**

The following initial estimates are appropriate to analyze the data.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>0.05</td>
</tr>
<tr>
<td>P\textsubscript{1}</td>
<td>0.3</td>
</tr>
<tr>
<td>Rot\textsubscript{0.5(1)}</td>
<td>0.2</td>
</tr>
<tr>
<td>P\textsubscript{2}</td>
<td>0.3</td>
</tr>
<tr>
<td>Rot\textsubscript{0.5(2)}</td>
<td>40.0</td>
</tr>
<tr>
<td>P\textsubscript{3}</td>
<td>0.3</td>
</tr>
<tr>
<td>Rot\textsubscript{0.5(3)}</td>
<td>600.0</td>
</tr>
</tbody>
</table>

It is interesting to note that when Green et al. published their results in 1982, using an Apple II computer and employing a "Patternsearch" algorithm they reported that these data were fitted in approximately two hours of calculation. Compare this to the amount of time taken by GraFit using a modern PC, which should fit the data in a couple of seconds.

The calculated result is displayed below.

Multiple Regression

Multiple regression is used when the observed data values depend on more than one dependent (x) value. As an example of this, we will examine the data listed by Toney & Kirsch\(^\text{14}\). These data consist of observations of the rate constant of a reaction, \(k\), as a function of the pK\(_a\) of the group involved in the reaction and the molecular volume of this group, Vol. The data are described by the equation:

\[
\log k = \beta . K_a + V . Vol + c
\]

Here, \(\beta\), \(V\) and \(c\) are unknowns in the equation, which is a multiple linear equation having two independent variables. The data presented in the paper are in the file “Multiple linear.” It is possible to fit these data by defining a new specific equation. The required definitions are as follows.

Equation Name: Multilinear kinetics

<table>
<thead>
<tr>
<th>X Variables</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$pK_a$</td>
<td>pKa</td>
<td>pKa value</td>
</tr>
<tr>
<td>Vol</td>
<td>Vol</td>
<td>Molecular volume</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\beta$</td>
<td>Beta</td>
<td>Beta</td>
</tr>
<tr>
<td>$V$</td>
<td>V</td>
<td>V</td>
</tr>
<tr>
<td>$c$</td>
<td>C</td>
<td>Constant</td>
</tr>
</tbody>
</table>

Definition: $\beta pK_a + V\text{Vol} + C$

The results obtained from fitting these data are:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Value</th>
<th>Standard Error</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\beta$</td>
<td>0.39</td>
<td>0.05</td>
</tr>
<tr>
<td>$V$</td>
<td>-0.055</td>
<td>0.005</td>
</tr>
<tr>
<td>$c$</td>
<td>-0.7</td>
<td>0.5</td>
</tr>
</tbody>
</table>

Displaying Multidimensional Data

Displaying data sets that have more than one $x$ axis can be difficult. One solution is to remove all but one dimension from a plot. For example, in the above data, a plot of $(\log k - V\text{Vol})$ versus $pK_a$ will result in a linear graph with a slope $\beta$ and intercept $c$. We can create the $(\log k - V\text{Vol})$ data using the data manipulation abilities of GraFit; the result for $V$ is obtained from the curve fitting.

The first step (assuming that the data have already been fitted) is to allow the calculated $V$ value to be accessed. This can be done by creating a data column that displays the fitting results. To do this, select a blank column and choose the Table ➪ Column Type ➪ Data Fitting ➪ Results command, and select the appropriate Non-linear Fit item.

The second step is to select the next blank column and choose the Table ➪ Column Type ➪ Data Processing ➪ Calculated Function command to set up a calculation. The following calculated function allows the column to be filled with the $(\log k - V\text{Vol})$ entries.
Note the use of the `data()` function to access data present in the data table. The appearance of the data table that uses this calculated function is shown below.

The result, plotting \((\log k - V.\text{Vol})\) versus \(pK_a\) and using a transformation definition to display the appropriate line through the data, is shown below.
Reading Values from a Calibration Curve

A calibration curve records the variation of an observed value when an experimental condition is altered in a defined manner. For example, an instrumental reading may be measured for various known concentrations of a solution. The standard curve that is produced can then be used to allow, in this example, the concentrations present in an unknown solution to be determined by extrapolating values from the curve.

These processes can be performed using GraFit by the following procedure.

1. Fit the data to an equation that describes the observed trend.
2. Use the Table ➔ Column Type ➔ Calculated Values ➔ x Values or Table ➔ Column Type ➔ Calculated Values ➔ y Values commands to read values from the fitted curve.

The sample data file “Standard curve” holds the analysis described below.

Choosing an Equation to Fit the Data

In many circumstances, the relationship between the x and y data values will be well defined. In these cases, the data will be fitted by linear or non-linear regression in the usual manner. However, some calibration data show a clear trend of how y varies with x, but are not necessarily defined by a well-characterized equation.
For example, the data below show the absorbance reading given by varying concentrations of a compound, and a straight line fit to the data.

In theory, the plot of absorbance versus concentration should be linear, but the data shown above describe a shallow curve. While it might be of interest to find out why this effect occurs, the only important consideration here is to allow readings to be taken from the calibration curve. Quite clearly, fitting the data to a straight line is not suitable.

Under these circumstances, the best recourse is to fit the data to an arbitrary equation that allows a smooth curve to be drawn through the data. As there is no theoretical basis for the equation, any calculated parameter values will have no physical significance. The choice of equation will depend upon the shape of the data, and it is possible that more than one equation would prove suitable. In the case shown above it might be appropriate to use a polynomial, or any equation that can produce a gentle curve. Below is shown the results of fitting the data to a second order polynomial ($y = a + bx + cx^2$) using a Linear Fit item, and to a first order rate equation by non-linear regression. The latter equation has no possible theoretical justification, but has a suitable mathematical form to allow a smooth curve to run through the data.
Reading Values from the Fitted Curve

Either of the fitted curves shown above will allow the concentration values that correspond to a series of measured absorbance values to be read from the curve. This is performed by entering the unknown absorbance values into a data column, then generated the calculated values in a separate column using the Table ➤ Column Type ➤ Calculated Values ➤ x Values command.

Fitting Several Data Sets with Some Parameters
Common and Some Specific

To illustrate, imagine that you have collected two linear data sets, and that you already know that for this experiment the slope is the same for each although the intercepts are different. Using GraFit it is possible to fit these two data sets to find the best slope that is common to each, and the two intercept values that are specific to the two data sets. Indeed, it is possible to fit two or more data sets to any of the normal equations that GraFit can use and to share one or several parameters between the data sets.

The example below shows how this is done for the paired linear data. Two raw data sets are illustrated below (these data are in the example file “Paired linear regression”). Fitting these two data sets individually results in similar, but not identical, values for the slope. This is shown in the figure below.
If the data sets are known to have the same slope, this can be incorporated into the data fitting as follows.

**Method Used to Share Variables Between Data Sets**

Sharing variables between data sets involves using an equation with a second independent \((x)\) variable, which is defined in such a way that that this value acts as a switch to decide which parameters apply to the data value. For the simple example described above, the independent variables are \(x\) and \(\text{dataset}\); parameters \(a_1\) and \(a_2\) are the two intercepts, and \(b\) is the common slope. The equation is then defined as

\[
\begin{align*}
\text{If } \text{dataset}=1 & \text{ Then} \\
\quad y &= a_1 + b \times x \\
\quad \text{Return} \\
\quad \text{Endif} \\
\quad y &= a_2 + b \times x
\end{align*}
\]

How does this work? When data from the first data set are accessed, the value of \(\text{dataset}\) is 1 and the equation returns \(a_1 + b \times x\).

When data from the second data set are accessed, the value of \(\text{dataset}\) is 2 and the equation returns \(a_2 + b \times x\).

Therefore the value of \(a_1\) is determined, in effect, from only the first set of data, and \(a_2\) from the second. However, the slope \(b\) is applicable to all the data. The graph below shows these data fitted to a common slope in this manner.
The dataset setting is set using the **Table ➔ Column Type ➔ Data Types ➔ y Data with Associated Value** command, resulting in the appearance shown below.

It is simple to extend this approach to many data sets. The equation to find the best slope through four data sets and a separate intercept for each is:
Example — Paired Denaturation Curves

This technique of sharing parameters between two or more data sets is not limited to linear equations. Any equation may be recast in this manner. For example, the equation below describes the denaturation of a protein as a function of the concentration of a denaturing solvent\textsuperscript{15}.

\[
F = 1 - \frac{\exp\left(\frac{m[D] - \Delta G}{RT}\right)}{1 + \exp\left(\frac{m[D] - \Delta G}{RT}\right)}
\]

In this equation, \(F\) is the fraction of the protein that is denatured, \([D]\) is the concentration of denaturant (e.g. guanidinium hydrochloride or urea), \(R\) is the gas constant, \(T\) is the temperature, \(\Delta G\) is the stability of the protein, and \(m\) is a slope factor. Finding the difference in stability between two proteins is often more important than determining the absolute stability. If the proteins are highly related, it can be assumed that the value for \(m\) is the same for each, but \(\Delta G\) differs.

Using the technique described above, it is possible to fit two data sets to a common \(m\) value but different \(\Delta G\) values. In this case, the equation to be used can be defined as

\[
\begin{align*}
\text{If dataset=1 Then} & \\
a &= \exp\left(\frac{(m*D - G1)}{(8.314*T)}\right) \\
\text{Else} & \\
a &= \exp\left(\frac{(m*D - G2)}{(8.314*T)}\right) \\
\text{Endif} & \\
y &= (1 - a/(1 + a))
\end{align*}
\]

The \(x\) variable is the concentration of denaturant, \(D\), the slope factor is \(m\) and the two values of \(\Delta G\) are \(G1\) and \(G2\). The temperature is \(T\), and should be defined as a

constant. The dataset column \( x_2 \) must hold the value 1.0 if the \( x \) and \( y \) columns are from the first data set, and 2.0 if they are from the second. (Clearly, this can be extended to further data sets if required.) The value \( a \) in the above definition is a temporary value used to simplify the calculation.

The figure below shows the guanidinium hydrochloride unfolding of a native protein, and of a mutant variant of this protein. The mutation has caused the protein to become less stable, making it unfold at lower concentrations of denaturant. The solid lines indicate the fitted curves, using the above equation. The difference in stability can therefore be determined.
CHAPTER 22

Equations Provided

GraFit comes with a large number of equations provided. These equations may be edited to see how they have been defined, and further equations can be added. This chapter briefly describes the equations that come with the program. It does not attempt to discuss the detailed background of each equation, as it is assumed that the user of a specific equation will be familiar with this.

The equations and transformations that come with the program are installed into the Group Item Store directory, and can be accessed using the File ➔ Add Stock Item command. Equations are grouped into separate sub-directories, which appear as different pages on the Add Item dialog box.

Equation and transformation definitions are distinguished by the nature of their icons. The following sections describe the contents of these various pages.
2 Substrates
The definitions on this page are designed to analyze enzyme kinetic data involving two substrates.

Ping pong
Use this equation where a ping pong mechanism applies. The equation relating the rate of reaction, $v$, to the concentration of substrates A and B and the constants $K_A$ and $K_B$ is:

$$v = \frac{V_{\text{max}} [A][B]}{K_B[A]+K_A[B]+[A][B]}$$

Ping pong Lineweaver Burk
Generates a Lineweaver Burk plot for the fitted data.

Ternary
Use this equation where a ternary complex is formed. The equation relating the rate of reaction, $v$, to the concentration of substrates A and B and the constants $K_A'$, $K_A$ and $K_B$ is:

$$v = \frac{V_{\text{max}} [A][B]}{K_A'K_B' + K_B[A'] + K_A[B'] + [A][B]}$$

Ternary Lineweaver Burk
Generates a Lineweaver Burk plot for the fitted data.
Enzyme Inhibition

**Competitive Inhibition**

In this multidimensional equation, rate is monitored versus [substrate] and [inhibitor]. The equation for competitive inhibition is:

\[
v = \frac{[S][E_0]k_{\text{cat}}}{[S] + K_m (1 + [I]/K_i)}
\]

**Competitive Eadie Hofstee**

Use this to display the Eadie Hofstee plot.

**Competitive Lineweaver Burk**

Displays the Lineweaver Burk plot.

**Mixed Inhibition**

In this most general inhibition equation, rate is monitored versus [substrate] and [inhibitor], using the equation:

\[
v = \frac{V_{\text{max}}[S]}{K_m \left(1 + \frac{[I]}{K_i} + \left(1 + \frac{[I]}{K_i'}\right)[S]\right)}
\]

**No inhibition**

The normal Michaelis Menten enzyme kinetics equation.
Non-competitive Inhibition

In this multidimensional equation, rate is monitored versus [substrate] and [inhibitor]. The equation for non-competitive inhibition is:

\[
v = \frac{V_{\text{max}} [S]}{K_m + [S] + [I]/K_i}\]

Non-competitive Eadie Hofstee

Use this to display the Eadie Hofstee plot.

Non-competitive Lineweaver Burk

Displays the Lineweaver Burk plot.

Enzyme Kinetics

Allosteric kinetics (Hill)

The Hill equation describes enzyme kinetics for an allosteric enzyme. For equation is:

\[
v = \frac{V_{\text{max}} [S]^n}{K^n + [S]^n}\]

The Hill coefficient, \( n \), equals 1 if standard kinetic behavior is followed, but differs significantly from 1 if the enzyme kinetics are cooperative.

Allosteric kinetics (Hill), Linear plot

This transformation is used to display the linearized Hill plot where \( v/(V_{\text{max}} - v) \) is plotted versus [S]. The slope is \( [S]^n / K^n \).
Enzyme Kinetics

This equation fits the basic Michaelis-Menten enzyme kinetics equation:

$$v = \frac{V_{\text{max}}[S]}{K_m + [S]}$$

In this equation, the rate, $v$, varies with the concentration of substrate, $[S]$, depending upon the maximal rate, $V_{\text{max}}$, and the Michaelis constant, $K_m$.

Enzyme Kinetics, Eadie Hofstee

This transformation draws the linear Eadie-Hofstee plot for fitted enzyme kinetic data.

Enzyme Kinetics, Lineweaver Burk

This transformation draws the linear Lineweaver Burk plot for fitted enzyme kinetic data.

Enzyme Kinetics, show $K_m$

Displays the Michaelis constant, $K_m$. For best results set the curve resolution to High when using this transformation.

Enzyme Kinetics, show $V_{\text{max}}$

Displays the limiting rate, $V_{\text{max}}$ ($= k_{\text{cat}}[E_0]$).

Enzyme Kinetics, show $V_{\text{max}}$ over $K_m$

Displays the linear portion at the beginning of the graph where $[\text{Substrate}] << K_m$. 

Enzyme Kinetics

This equation fits the basic Michaelis-Menten enzyme kinetics equation:

$$v = \frac{V_{\text{max}}[S]}{K_m + [S]}$$

In this equation, the rate, $v$, varies with the concentration of substrate, $[S]$, depending upon the maximal rate, $V_{\text{max}}$, and the Michaelis constant, $K_m$.

Enzyme Kinetics, Eadie Hofstee

This transformation draws the linear Eadie-Hofstee plot for fitted enzyme kinetic data.

Enzyme Kinetics, Lineweaver Burk

This transformation draws the linear Lineweaver Burk plot for fitted enzyme kinetic data.

Enzyme Kinetics, show $K_m$

Displays the Michaelis constant, $K_m$. For best results set the curve resolution to High when using this transformation.

Enzyme Kinetics, show $V_{\text{max}}$

Displays the limiting rate, $V_{\text{max}}$ ($= k_{\text{cat}}[E_0]$).

Enzyme Kinetics, show $V_{\text{max}}$ over $K_m$

Displays the linear portion at the beginning of the graph where $[\text{Substrate}] << K_m$. 

Enzyme Kinetics

This equation fits the basic Michaelis-Menten enzyme kinetics equation:

$$v = \frac{V_{\text{max}}[S]}{K_m + [S]}$$

In this equation, the rate, $v$, varies with the concentration of substrate, $[S]$, depending upon the maximal rate, $V_{\text{max}}$, and the Michaelis constant, $K_m$.

Enzyme Kinetics, Eadie Hofstee

This transformation draws the linear Eadie-Hofstee plot for fitted enzyme kinetic data.

Enzyme Kinetics, Lineweaver Burk

This transformation draws the linear Lineweaver Burk plot for fitted enzyme kinetic data.

Enzyme Kinetics, show $K_m$

Displays the Michaelis constant, $K_m$. For best results set the curve resolution to High when using this transformation.

Enzyme Kinetics, show $V_{\text{max}}$

Displays the limiting rate, $V_{\text{max}}$ ($= k_{\text{cat}}[E_0]$).

Enzyme Kinetics, show $V_{\text{max}}$ over $K_m$

Displays the linear portion at the beginning of the graph where $[\text{Substrate}] << K_m$. 

Chapter 22: Equations Provided
Kinetics, contaminating S

Occasionally the reagents etc. used in an enzyme assay will contain traces of contaminating substrate. Therefore the rate will vary with added substrate, $S_{\text{add}}$ as:

$$v = \frac{V_{\text{max}} ([S_{\text{add}}] + [S_{\text{con}}])}{K_m + [S_{\text{add}}] + [S_{\text{con}}]}$$

In this equation, $[S_{\text{con}}]$ is the concentration of contaminating substrate.

Exponential

This page contains equations for calculating the rate constants of various exponential decay processes.

Double Exponential

If two decay processes occur simultaneously the observed values decay with time following the double exponential decay equation:

$$y = A_{0(1)} e^{-k_1 t} + A_{0(2)} e^{-k_2 t}$$

Here, the two processes have separate $A_0$ and $k$ values.

Double Exponential - phase 1

This displays the first of the two phases in isolation.

Double Exponential - phase 2

This displays the second of the two phases in isolation.

Double Exponential with offset

This equation is used when a double exponential process decays to a non-zero limit value.
**Single Exponential**

The equation for a single exponential decay is:

\[ y = A_0 e^{-kt} \]

The observed values decay with time, \( t \), from an initial value, \( A_0 \), at \( t = 0 \), to 0 at \( t = \infty \). The rate constant for the decay is \( k \). (The half-life for the process, \( T_{1/2} \), is given by \( \log_2 2/k \).) To display a linearized plot of this equation, set the y axis to have a logarithmic scale.

**Single Exponential with offset**

If the observed values do not decay to 0, but to some defined offset or background value the equation for a single exponential process is

\[ y = A_0 e^{-kt} + \text{offset} \]

In this equation, 'offset' is the limit of the decay.

**Triple Exponential**

For a triple exponential decay process the equation is:

\[ y = A_{0(1)} e^{-k_1 t} + A_{0(2)} e^{-k_2 t} + A_{0(3)} e^{-k_3 t} \]

**Triple Exponential with offset**

This equation is used when a triple exponential process decays to a non-zero limit value.

**IC 50**

These equations are used for analyzing radio-immuno assays or Dose-response curves.

**IC50 0-100%**

This equation fits inhibition data to a 2-parameter equation, where the lower data limit is 0, and the upper data limit is 100, i.e. the data are both background and range corrected.

\[ y = \frac{100\%}{1 + \left( \frac{x}{IC_{50}} \right)} \]
In this equation, $s$ is a slope factor. The equation assumes that $y$ falls with increasing $x$.

IC50 0-100% - show IC50

Displays the IC50 value on the plot. For best results set the curve resolution to High when using this transformation.

IC50 background corrected

This equation fits inhibition data to a 3-parameter equation, where the lower data limit is 0, i.e. the data are background corrected.

\[ y = \frac{100\%}{1 + \left( \frac{x}{IC_{50}} \right)^s} \]

In this equation, $s$ is a slope factor. The equation assumes that $y$ falls with increasing $x$.

IC50 background corrected - show IC50

Displays the IC50 value on the plot. For best results set the curve resolution to High when using this transformation.

IC50 background corrected - show limit

Displays the limit value on the plot.

IC50 full 4 param

Fits data to a full 4-parameter equation, which is usually the best way to fit results from RIA analysis or inhibition data (see Halfman, 198116). The binding or inhibition is then characterized in terms of an IC50 value:

\[ y = \frac{\text{Range}}{1 + \left( \frac{x}{IC_{50}} \right)^s} + \text{background} \]

Here Range is the maximum $y$ range, and $s$ is a slope factor. The $x$ axis represents the concentration of analyte. Data fitted to this equation are usually displayed with a logarithmically scaled $x$ axis. For convenience, the equation as defined attempts to provide initial estimates for the parameter values.

Note  Estimating starting values is difficult when there are 4 unknown parameters. The method used within this definition works most of the time, but can give occasional poor fits. Under such circumstances, enter initial estimates explicitly in the non-linear fit window.

The curve displays inhibition with increasing dose. It is also possible to use the same equation for increasing response with dose. In this case, the \( y \) range is a negative value, and the “Background” is the maximum response.

- **IC50 full 4 param - show background**
  This displays the calculated background value.

- **IC50 full 4 param - show IC50**
  This displays the calculated background value.

- **IC50 full 4 param - show limit**
  This displays the limiting value of the data.

**Ligand Binding**

This page contains various equations describing the binding of ligands to surfaces, receptors, enzymes etc.

- **1 Site**
  This is the simplest form of binding equation. The equation is

  \[
  y = \frac{[L]\text{Cap}}{K_d + [L]}
  \]

  Here, \( y \) is either the amount bound or is some factor proportional to it (e.g. radioactivity, absorbance etc.), or the number of moles bound per mole of receptor. The capacity for binding ligand, \( \text{Cap} \), is either an amount bound in terms of moles of ligand, or a stoichiometric quantity in terms of moles of ligand per mole receptor depending upon the definition of \( y \). The dissociation constant of ligand from the receptor is \( K_d \).

  The concentration of free ligand, \([L]\), is the \( x \) data axis.
1 Site – Scatchard Plot

The Scatchard plot is the usual way to linearize binding data. This display equation takes the Cap and $K_d$ values calculated by fitting to a single-site binding curve, and draws the line for the Scatchard plot. Use this display curve with the Scatchard data transformation.

1 Site – Show Capacity

This transformation shows the capacity on the plot.

1 Site – Show $K_d$ (1 site)

This transformation shows the dissociation constant, $K_d$. For best results set the curve resolution to **High** when using this transformation.

1 Site (with background)

Often binding experiments have an inherent background $y$ value. This value can usually be determined separately by control experiments. However, such controls sometimes do not accurately reflect the real experiment, and it can be preferable to treat this background as a separate parameter to be obtained from the data fitting. The equation is:

$$y = \frac{[L].\text{Cap}}{K_d + [L]} + \text{background}$$

Here, the parameters are the same as for the single site ligand binding except for the inclusion of a background or offset value.

1 Site (with background) - Scatchard

Use this transformation to display Scatchard plots for binding data containing a background value.

1 Site (with background) - Show background

This transformation shows the background value.

1 Site (with background) - Show Capacity

This transformation shows the capacity.
1 Site (with background) - Show Kd

This transformation shows the dissociation constant, $K_d$. For best results set the curve resolution to High when using this transformation.

2 Site

Often there is more than one type of site involved in binding the ligand. This equation describes the case of two sites characterized by individual $K_d$ and Capacity values. The equation is:

$$y = \frac{[L] \cdot \text{Cap}_{(1)}}{K_{d(1)} + [L]} + \frac{[L] \cdot \text{Cap}_{(2)}}{K_{d(2)} + [L]}$$

2 Site - Show Capacity (total)

This transformation shows the total binding capacity for ligand.

2 Site - Show Capacity 1

This transformation shows the capacity of the first binding site.

2 Site - Show Curve 1

This transformation shows the binding curve for the first binding site in isolation.

2 Site - Show Curve 2

This transformation shows the binding curve for the second binding site in isolation.

2 Site (with background)

This equation describes the situation where two independent binding sites are present, but the $y$ value at zero ligand concentration is not zero. The equation for this is:

$$y = \frac{[L] \cdot \text{Cap}_{(1)}}{K_{d(1)} + [L]} + \frac{[L] \cdot \text{Cap}_{(2)}}{K_{d(2)} + [L]} + \text{background}$$

2 Site (with background) - Show background

This transformation shows the background binding.
2 Site (with background) - Show Capacity 1

This transformation shows the capacity of the first binding site. This value is on top of the background.

2 Site (with background) - Show Capacity (total)

This transformation shows the total binding capacity for ligand, on top of the background value.

2 Site (with background) - Show Curve 1

This transformation shows the binding curve for the first binding site in isolation.

2 Site (with background) - Show Curve 2

This transformation shows the binding curve for the second binding site in isolation.

Adair (2 sites)

The Adair equation describes the binding of ligands to multiple sites on a receptor when the dissociation constants for binding of successive ligands are to be individually defined from the data. The equation for \( n \) sites is:

\[
B = \frac{\text{Cap}.\{L/K_{d1} + 2L^2/(K_{d1}K_{d2}) + \ldots + nL^n/(K_{d1}K_{d2} \ldots K_{dn})\}}{n.\{1 + L/K_{d1} + L^2/(K_{d1}K_{d2}) + \ldots + L^n/(K_{d1}K_{d2} \ldots K_{dn})\}}
\]

In this equation, \( B \) is the amount bound, \( L \) the concentration of free ligand, \( \text{Cap} \) the maximum capacity of the system to bind ligand, and \( K_{d1}, K_{d2} \) etc. the successive dissociation constants for ligand.

Adair (3 sites)

Use this equation for 3 binding sites.

Adair (4 sites)

Use this equation for 4 binding sites.
**Bound vs Total**

The previous equations require the unbound ligand concentration to be known. However, although the total ligand concentration is always known (this is what you have added), the proportion bound and free is not always certain. This is particularly the case if the $y$ axis is an observation that is not directly related to the bound concentration, for example fluorescence intensity or absorbance. Here the equation relates the $y$ axis to the total ligand added, $t$.

$$y = -\frac{(K_d + t + \text{Cap}) + \sqrt{(K_d + t + \text{Cap})^2 - 4t\cdot\text{Cap}}}{2}$$

**Bound vs Total - tight binding limit**

This transformation shows the maximum possible amount bound (or change in absorbance etc.) for a given total amount of ligand added if the binding were infinitely tight.

**Cooperative**

A generalized equation describing cooperative binding (or multiple binding sites of differing affinities) is:

$$y = \frac{[L]^n \cdot \text{Cap}}{K^n + [L]^n}$$

Here, $n$ is a measure of the cooperativity. For normal binding to a single site, $n$ should not differ significantly from 1.0.

**Cooperative (with background)**

This is the same as the equation above, but includes an unknown background level in the $y$ axis observations, i.e.

$$y = \frac{[L]^n \cdot \text{Cap}}{K^n + [L]^n} + \text{background}$$
**pH**

These equations are used when the observed value varies with pH. They usually involve the determination of one or more pKₐ values from the experimental data.

∑ **pKₐ, (min = 0)**

This equation is used when the observed parameter varies with pH from 0 at low pH to a limiting value at high pH. Examples include various enzymatic activities. The equation is:

\[ y = \frac{\text{Limit} \cdot 10^{(\text{pH}-pK_a)}}{1 + 10^{(\text{pH}-pK_a)}} \]

∑ **pKₐ, (min = 0), Linearized Plot**

Displays the line for the linearized titration curve. The linearized equation is:

\[ y = -\frac{K_y}{[H^+]} + \text{Limit} \]

∑ **pKₐ, (min = 0), Show Limit**

This displays the limit value of the y axis at high pH.

∑ **pKₐ, (min = 0), Show pKₐ**

This transformation is used to represent the position of the pKₐ on the curve where there is a single ionization and the starting value is 0. For best results set the curve resolution to High.

∑ **pKₐ, (min = 0), High to Low**

This equation is used when the observed parameter varies with pH from a limiting value at low pH to 0 at high pH.

∑ **pKₐ, (min = 0), High to Low, Show Limit**

This displays the limit value of the y axis at low pH.
pKa, (min = 0), High to Low, Show pKa

This transformation is used to represent the position of the pKa on the above curve. For best results set the curve resolution to High.

pKa, Double

This equation is used when the observed parameter varies from one value at low pH to another at high pH, with the variation depending upon the ionization of two groups. The pKa values of these groups determine the shape of the curve.

pKa, Double, Show Curve 1

This shows the first of the two ionization curves in isolation.

pKa, Double, Show Curve 2

This shows the second of the two ionization curves in isolation.

pKa, Double, Show Limit 1

Displays the lower limit of the double curve.

pKa, Double, Show Limit 2

Displays the middle limit of the double curve.

pKa, Double, Show Limit 3

Displays the upper limit of the double curve.

pKa, Double Bell

Sometimes two ionizations determine the value of the observed parameter. If the first ionization results in increasing activity and the second destroys activity this results in a bell-shaped curve. The equation assumes that activity is zero at low and high pH.
pKa, Double Bell, Curve 1

This display equation is used to display the effect of the first ionization in the bell-shaped curve.

pKa, Double Bell, Curve 2

This display equation is used to display the effect of the second ionization in the bell-shaped curve.

pKa, Double Bell, Limit

This shows the upper limit of the bell-shaped activity profile.

pKa, Single

This equation is used when the observed parameter varies from one value at low pH to another at high pH, with the variation depending upon the ionization of a group. The pKₐ value of this group determines the inflection point of the curve. The equation is:

\[ y = \frac{\text{Lim}_1 + \text{Lim}_2 \cdot 10^{(\text{pH} - pK_a)}}{10^{(\text{pH} - pK_a)} + 1} \]

In this equation, Lim₁ and Lim₂ are the limits of the titration curve at low and high pH.

pKa, Single, Linearized plot

Displays the line for the linearized titration curve.

pKa, Single, Show Limit 1

Displays the limiting y value at one extreme of pH.

pKa, Single, Show Limit 2

Displays the limiting y value at the other extreme of pH.

pKa, Single, Show pKa

This transformation is used to represent the position of the pKₐ on the general ionization curve. For best results set the curve resolution to High.
Rate

This set of equations fits data describing a first order rate equation.

**1st order**

The equation for a process where the observed value increases with time is:

\[ A_t = A_\infty (1 - e^{-kt}) \]

Here, \( A_t \) is the amount of A at time \( t \), \( A_\infty \) is the maximum amount of A formed, and \( k \) is the rate constant that describes the process.

**1st order, decay curve**

This transformation converts the data into an exponential decay curve. To linearize the curve, display the \( y \) axis with a logarithmic scale.

**1st order, show limit**

This displays the limiting value, \( A_\infty \).

**1st order, show initial**

The initial part of the full curve (approximately the first 10%) is linear, with the slope being \( kA_\infty \). This transformation shows the initial linear portion.

**1st order (offset)**

If the observed \( y \) value has a background or offset at time \( t=0 \) (due to experimental constraints, for example a starting absorbance may not be zero) the equation becomes:

\[ A_t = A_\infty (1 - e^{-kt}) + \text{offset} \]

**1st order (offset), decay curve**

This display equation plots the rate equation as an exponential decay. Use it with ‘Decay Curve (+Offset)’ transformed data.
**1st order (offset), show limit**

This displays the limiting value for the equation containing an offset.

**1st order (offset), show offset**

Use this transformation to show the offset value.

**1st order rate versus [S]**

To find enzyme kinetics parameters, it is often necessary to carry out a series of first order rate reactions at different substrate concentrations. The rate constant versus [S] is then analyzed using the Michaelis Menten equation. Using this 3D equation allows these procedures to be combined, giving:

\[
A_t = A_\infty \left(1 - \exp\left(-\frac{V_{\text{max}} [S]}{K_m + [S]} t\right)\right)
\]

**1st order rate versus [S] (offset)**

This equation is the same as that above, but also includes an unknown background value:

\[
A_t = A_\infty \left(1 - \exp\left(-\frac{V_{\text{max}} [S]}{K_m + [S]} t\right)\right) + \text{background}
\]
Data fitting templates provide a quick way of analyzing data and plotting graphs. In general, you are recommended to construct your own specific templates that are best suited to the data you wish to analyze. However, GraFit comes with a few standard templates that can be used for common data fitting situations.

About the Standard Templates

All the standard data fitting templates are defined so that as the data values are entered, the results are calculated and data plotted in the background.

Accessing Templates

To access one of the data fitting templates, select the File ➨ New command. Choose the template from the list shown.

![Template List]

- Enzyme Kinetics
- IC 50
- Ligand Binding
- Linear Regression
- Single Exponential
**Template Layout**

All the standard templates are formatted so that the data are entered into a data table that is on the left of the screen, and the fitted data and results are updated in the graph on the right. This graph is plotted as the data are being typed into the program.

![GraFit User's Guide](image)

**Screen Size**

To ensure compatibility with the majority of systems, the standard templates are formatted so that they display correctly when GraFit is run as a maximized window at a screen resolution of $800 \times 600$.

**Using Your Own Templates**

In general, we recommend that you build your own templates for common data fitting situations. The advantages of building your own templates are summarized as follows:

- Specific data analyses can be created.
- Graphs can incorporate user-specific features such as corporate logos or the name of the user.
• Graphs can be customized to use specific fonts and/or styles. Users with color printers may wish to incorporate color into their graphs; those with monochrome printers will probably wish to create graphs in black and white.

• Users with high-resolution displays can make best use of the available screen resolution when laying out the various windows.

**Description of the Standard Templates**

**Enzyme Kinetics**

This template analyzes enzyme kinetic data to the basic Michaelis-Menten enzyme kinetics equation:

\[ v = \frac{V_{\text{max}} [S]}{K_m + [S]} \]

A graph is made of the fitted data together with an inset Lineweaver Burk plot, as shown below.

**Enzyme Kinetics Data**

\[
\begin{array}{c|c|c}
\text{Parameter} & \text{Value} & \text{Std. Error} \\
\hline
V_{\text{max}} & 8.5415 & 0.4185 \\
K_m & 2.0890 & 0.2750 \\
\end{array}
\]
**IC 50**

This fits data to a full 4-parameter equation. The binding or inhibition is then characterized in terms of an IC$_{50}$ value using the following equation:

$$y = \frac{\text{Range}}{1 + \left(\frac{x}{\text{IC}_{50}}\right)^s} + \text{background}$$

A graph is made of the fitted data, as shown below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Std. Error</th>
</tr>
</thead>
<tbody>
<tr>
<td>Y Range</td>
<td>75.0926</td>
<td>6.9937</td>
</tr>
<tr>
<td>IC 50</td>
<td>1.47142e-007</td>
<td>3.99433e-008</td>
</tr>
<tr>
<td>Slope factor</td>
<td>0.7194</td>
<td>0.1517</td>
</tr>
<tr>
<td>Background</td>
<td>26.0055</td>
<td>4.5106</td>
</tr>
</tbody>
</table>
**Ligand Binding**

This template analyzes ligand binding data to single-site saturation equation:

\[ y = \frac{[L] \cdot \text{Cap}}{K_d + [L]} \]

A graph is made of the fitted data together with an inset Scatchard plot, as shown below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Std. Error</th>
</tr>
</thead>
<tbody>
<tr>
<td>Capacity</td>
<td>20.7680</td>
<td>1.3173</td>
</tr>
<tr>
<td>Kd value</td>
<td>38.5816</td>
<td>5.0571</td>
</tr>
</tbody>
</table>
Linear Regression

This template allows data to be fitted using linear regression, and the results plotted.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Std. Error</th>
</tr>
</thead>
<tbody>
<tr>
<td>a (intercept)</td>
<td>3.4167</td>
<td>0.6251</td>
</tr>
<tr>
<td>b (gradient)</td>
<td>0.3833</td>
<td>0.1111</td>
</tr>
</tbody>
</table>
Single Exponential

This template fits data to a single exponential decay function, using the following equation:

\[ y = A_0 e^{-kt} \]

A graph is created showing the fit.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Std. Error</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial value</td>
<td>130.1490</td>
<td>1.2017</td>
</tr>
<tr>
<td>Rate constant</td>
<td>0.3799</td>
<td>0.0066</td>
</tr>
</tbody>
</table>
Overview of Hard-coded Equations

Hard-coded equation definitions use specialized pre-compiled equation libraries to increase data fitting speed and/or provide greater flexibility in generating initial estimates. The GraFit program provides the capability to use hard-coded equations, though none are supplied as standard. At present some equipment manufacturers use these to allow GraFit to fit very large quantities of data more quickly than would be possible with the standard equation definition items. Hard-coded equation items simply substitute for the normal equation definitions when fitting data by non-linear regression (see Chapter 9). It should be stressed, however, that for the vast majority of applications the normal user-defined equation definition is quite sufficient.

What are Hard-coded Equations?

Hard-coded equations are pre-compiled code library files. They are normally supplied for specialist applications; it is not possible to generate them yourself. If you believe that you have an application that might benefit from use of a hard-coded equation library, please contact Erithacus Software technical support for further information.

Advantages

- Pre-compiled code results in faster analysis.
- The partial derivative calculations that are intrinsic to non-linear regression analysis can be performed explicitly rather than by numerical approximation, resulting in greater speed and better precision.

Disadvantages

- The definitions cannot be modified.
- It is not possible to write your own hard-coded equations.
Enabling Hard-coded Equations

The menu commands to insert hard-coded equations are not present by default, and must be explicitly enabled. The View ➤ Options command, Options page controls this; to use hard-coded equations ensure that the Enable hard-coded equation definitions box is checked.

Inserting a Hard-coded Equation Item

Hard-coded equation items are added using the Add ➤ Hard-coded Equation command. The hard-coded equation window itself contains a tabbed dialog box with several panes that are used to define the equation. Each of the panes in this item window is discussed below.
Chapter 9: Equation Item

General Pane

The General pane is used to define the location of the hard-coded equation library file, and shows a description of the equation as provided by the library supplier.

![The General pane of the Hard-coded Equation item]

Locating the Equation Library File

Click the browse button to locate the equation definition library file. Once loaded, the full path of this file is shown, and a description of the equation is displayed.

X Variables Pane

The X Variables pane is used to show the names and number of the independent (x) variables that are used in the equation. These names are pre-defined by the equation library vendor, and cannot be edited.
The Parameters pane is used to show the parameters in the equation definition. These names are pre-defined by the equation library vendor, and cannot be edited.
The Constants pane is used to define constants in the equation definition. Constants are used to allow the entry of a value into an equation definition that is fixed in any single experiment, but varies from experiment to experiment. The presence of constants is optional, but when present an equation definition can include any number of constants. When constants are included in an equation used for non-linear regression, their values are entered into the non-linear fit item window as described in Chapter 6.

The Constants pane of the Hard-coded Equation item
GraFit is supplied with a font that can be used to represent the various graph drawing symbols used by the program. This can be useful when annotating graphs, for example, when labeling axes. The font is called **GraFit Symbols** and can be used just like any other Windows font.

The various symbols are associated with the characters as shown in the following table.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
<th>L</th>
<th>M</th>
<th>N</th>
<th>O</th>
<th>P</th>
</tr>
</thead>
<tbody>
<tr>
<td>O</td>
<td>□</td>
<td>△</td>
<td>▽</td>
<td>◊</td>
<td>◊</td>
<td>+</td>
<td>×</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>-</td>
<td>×</td>
<td>*</td>
<td>*</td>
<td>*</td>
</tr>
<tr>
<td>a</td>
<td>b</td>
<td>c</td>
<td>d</td>
<td>e</td>
<td>f</td>
<td>g</td>
<td>h</td>
<td>i</td>
<td>j</td>
<td>k</td>
<td>l</td>
<td>m</td>
<td>n</td>
<td>o</td>
<td>p</td>
</tr>
<tr>
<td>●</td>
<td>■</td>
<td>▲</td>
<td>▼</td>
<td>◆</td>
<td>◆</td>
<td>+</td>
<td>×</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>-</td>
<td>×</td>
<td>*</td>
<td>*</td>
<td>*</td>
</tr>
<tr>
<td>S</td>
<td>T</td>
<td>U</td>
<td>V</td>
<td>W</td>
<td>X</td>
<td>Y</td>
<td>Z</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>■</td>
<td>■</td>
<td>■</td>
<td>■</td>
<td>■</td>
<td>■</td>
<td>□</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Note** The GraFit symbols font does not contain any hinting information to assist reproduction on low-resolution displays. For this reason, it will not display well on screen, although it will print correctly.
Index

_ _
_grnd_ function, 51, 86
_rnd_ function, 51, 86

A
Adair Equation, 234
Add menu, 11
  Data Table command, 23
  Equation command, 77, 208, 250
  Graph command, 99, 105, 202, 204
  Insert New Object command, 177
  Linear Fit command, 71
  Non-linear fit command, 209
  Non-linear Fit command, 57, 200
  Notepad command, 97
  Transformation command, 91
Adobe Acrobat, 6
Allosteric Data, 207
Allosteric Kinetics, 226
Arithmetic operators, 84
Arrows, 116
ASCII format, 35
Axis manager, 152, 154, 155
Axis offset, 130
Axis scaling, 157

B
Bar charts, 102, 161, 168
Bezier curves, 126
Bitmap file, 118

C
Calculate menu
  Fit Data command, 57, 71
Calculated values, 46
Calibration Curve, 215
Chart Wizard, 161
Chi-squared, 189, 191
Clipboard
  Windows, 28, 173, 174, 175, 176, 177
Color toolbar, 111
Column charts, 99, 101, 161, 168
column constant, 51
Column types
  A - B, 39
  A / B, 39, 205
  A + B, 39
  A.B, 39
  A-B, 36
  Calculated Function, 50, 213
  Column Summary, 40
  Constants Entry, 46
  Derivative, 53
  Difference, 50, 204
  F Test, 41
  General, 37
  Information, 45
  Mean, 39
  No. Data Points, 40
  Parameter Entry, 45
  Results, 44, 213
  Series, 53
  Smooth, 54
  Standard Deviation, 40
Standard Error of the Mean, 40
Subset, 54
x Data, 37
x Values, 47, 215, 217
x(n) Data, 37
y Data, 38
y Data with Associated Value, 38, 219
y Values, 49, 215
Column Types, 35
Columns
  Copying and pasting, 28
  Deleting, 31
  Selecting, 28
Comment statements, 87
Constants, 61, 81, 147, 253
Context Help, 15
Cooperative binding, 235
CSV format, 35
Cursor shapes, 24, 109
Cut and paste, 173

Data
  Association, 156
  Copying, 28
  Deleting, 30
  Export, 35
  Fitting several data sets simultaneously, 217
  Import, 34
  Import / Export, 34
  Inserting values, 31
  Layout, 59, 73
  Missing, 25
  Numbers, 25
  Overlaying, 151
  Pasting, 28
  Rescaling, 50
  Selecting, 27
  Smoothing, 54
  Sorting, 32
  Text, 25
  Types, 24
Data entry position, 26

Data fitting
  Basics, 179
  Multiple Non-linear Regression, 186
Data function, 51
Data table, 23
  Appearance, 32
  Locking columns, 55
Degrees of freedom, 189
Denaturation Curves, 220
Derivative, 53
DIF format, 35
Difference calculation, 36
Directories, 17, 19
Dose-response Curves, 229
Double exponential decay, 228
Drag and drop, 11
Draw menu, 106
  Results Listing command, 66, 75, 202

E
Edit menu, 11
  Clear command, 11, 30, 31
  Copy command, 28, 29, 35, 174, 175, 177
  Edit Current Cell command, 24
  Font command, 78
  Hide Object command, 128, 156
  Insert New Object command, 78, 177
  Insert Object command, 176
  Paste command, 28, 29, 34, 174, 175, 176, 177
  Paste From command, 18, 34
  Paste Special command, 176, 177
  Properties command, 111, 112, 113, 126, 155, 156, 157
  Rename command, 12
  Select All command, 177
Editing item names, 12
Embedding objects, 173
Enhance metafile, 118
Enzyme Inhibition
  Competitive, 225
  Mixed, 225
Non-competitive, 226
Enzyme kinetics, 243
Enzyme Kinetics
  Ping Pong, 224
  Ternary Complex, 224
Equation definition, 77, 82, 83
Equation definition syntax, 80
Equation menu
  Compile command, 77, 90
Equations, 223
  Compiling, 90
  Defining, 207
  Error Messages, 90
  Functions, 85
  Multi-line Definitions, 86
  Multiple Regression, 186
  Temporary variables, 86
Erithacus Software
  Contacting, 2
Error bars, 143
Error Messages, 90, 96
Errors, 183, 189, 190, 191, 192, 194
Estimates
  Interactive, 62
Estimatrix, 49, 61, 62, 63, 200
Exponential decay, 229, 247

F
F test, 41, 197
Field Codes, 112
File menu, 11
Add Stock Item command, 14, 18, 200, 203, 223
Export Graph command, 118
Import Data command, 18, 34
New command, 15, 19, 20, 241
Open command, 17, 200, 207
Page Setup command, 14, 106
Print command, 13, 65, 74
Print Preview command, 13, 65, 69, 70, 74, 201
Save As command, 19
Save command, 18
Store Stock Item command, 14, 18
Files
  Creating new, 18
  Exporting graphs, 118
  Importing Data, 18
  Opening, 17
  Saving, 18
  Template, 19
Filters
  Import / Export, 19
Fitting criteria, 63, 64
Font selection, 67, 69
Font settings, 75, 97, 117, 118
Footers, 14
Formatting numbers, 32, 66, 134
Functions, 85

G
Global Analysis, 185
GraFit
  Installing, 6
  Running, 9
  Technical Support, 3
  Templates, 15
  Uninstalling, 7
GraFit Items, 11
GraFit Workspace, 10, 17
Graph
  Axis associations, 148
  X ticks, 129
Graph menu
  Add Data command, 148, 203
  New Graph command, 99
  Preferences command, 106, 111
Graph types, 99
Graphs
  Z ordering, 110
Graphs, 105
  Adding data, 148
  Aligning objects, 110
  Arrow properties, 116
  Axis association, 145
  Axis scale, 134
  Axis text, 136
  Chart bar style, 165
Colors, 111
Creating, 99
Curve resolution, 125
Data point style, 166
Data point styles, 122
Data/curve properties, 138
Default text properties, 112
Duplicating objects, 107
Error plots, 120, 143, 162, 170
Exporting, 118
Fill properties, 114
Font properties, 117
Grid settings, 131
Grouping objects, 110
Histogram bar style, 171
Join style, 167
Join styles, 125
Legend, 119, 162, 169
Legend box, 136, 148
Line properties, 114
Location, 133
Main graph region, 127
Multiple axes, 151, 160
Object locations, 115
Plotting equations, 123
Rotation properties, 115
Scaling, 163
Selectable regions, 127
Selecting objects, 107
Sizing objects, 108
Split axes, 152
Text, 111
Text objects, 108
Tick styles, 122, 164, 171
Transformations, 121
Visibility, 128
X scale, 131
Y scale, 133
Y ticks, 133

H
Hard-coded Equation definition, 249
Hard-coded Equations
   Enabling, 250
   Inserting, 250
   Library Files, 251
Hardware Requirements, 5
Headers, 14
Help commands, 15
Help menu
   Contents command, 15
Hill Plot, 226
Histogram, 102, 169, 172
Histogram Wizard, 169
IC50 equations, 229, 244
Icon
   Changing, 12
Indents, 67, 70, 75
Initial estimates, 62
Initial Estimates, 88, 200
Installation, 6
   Floppy, 7
Internet, 3
Internet Explorer, 5, 6
Items
   Loading and Saving, 18
L
Legend Box, 136
   Margin settings, 137
Ligand binding, 245
Ligand binding equations, 231
Limiting x data range, 61, 73
Linear fitting, 57, 71
Linear regression, 191, 246
   Basics, 182
Linking objects, 173
Logarithmic scaling, 132
Logical operators, 84
M
Marquart algorithm, 194
Mask curve option, 123
Mean, 39, 198
Metafile, 118
Michaelis-Menten Equation, 227
Multiple axes, 151, 160
Multiple Regression, 185, 212
  Advantages, 186
  Disadvantages, 186
  Plotting results, 188
  Uses, 185
Multiple x variables, 59, 81

N
NMR Titration Curve, 199
Non-linear fitting, 57
Non-linear regression, 194
Non-linear regression Basics, 182
Notepad item, 97
Number formatting, 32, 66, 74, 134

O
Object embedding and linking, 173
Object menu
  Align command, 110
  Bring to Front command, 110
  Group command, 110
  Move Back command, 111
  Move Forward command, 110
  Send to Back command, 110
  Ungroup command, 110
OLE objects, 79, 98, 105, 106, 173
Outliers, 191, 195

P
Page Settings, 14
Paired Data Sets, 217
Parameters, 81, 252
PDF files, 6
Ping Pong Kinetics, 224
pKa determination, 236
Polynomial regression
  Basics, 182
Print preview, 13
Print preview
  Changing, 14
  Printing, 13

R
Random numbers, 51
Rate equations, 239
Reduced chi-squared, 189
Regression analysis, 189
  Assumptions, 190
  Basics, 181
  Linear, 191
  Non-linear, 194
Requirements. see Hardware
  Requirements
Residual plots, 190, 196
Residuals, 197, 203
Residuals plot, 94
Results, 65, 74
Robust weighting, 58, 191, 194, 206
Rotation of objects, 115
row constant, 51
Rows
  Selecting, 28

S
Savitzky-Golay smoothing, 53, 54
Scaling power, 135
Screen resolution, 242
SetBlank function, 51, 52
Special menu
  Options command, 33
Spline curves, 126
Split axes, 152
Splitter box, 23
Standard Curve, 215
Standard deviation, 40, 198
Standard Error of the Mean, 40
Status Bar, 57, 71, 77, 92
Stock Items, 14
Symbol syntax, 80
Symbols font, 255
Syntax
  Symbol names, 80

**T**

Table menu
  Column Format command, 26, 32
  Column Properties command, 36
  Column Width command, 24
  Delete command, 31
  Insert command, 31
  Lock Column command, 55
  Preferences command, 32, 36
  Row Height command, 24
  Size Column to Fit command, 24
  Sort Column(s) command, 32
Technical Support. See GraFit, Technical Support
Template files, 17, 19
Templates, 15, 20, 241
  Standard, 241
Temporary variables, 86
Text settings, 135
Theory, 189
TIFF file, 118
Transformation menu
  Compile command, 91, 96
Transformations, 91, 121, 141, 142
  Compiling, 96
  Curves, 94
  Data points, 93
Defining, 95
  Error Messages, 96

**U**

Uninstalling GraFit, 7

**V**

ValidData function, 51, 52
View menu
  Grid Lines command, 106
  Options command, 17, 18, 19, 66, 134
  Show Outlines command, 106
  Zoom command, 34
Visibility
  Graph objects, 128

**W**

Weighting, 58, 72, 183, 191, 192, 193
  Checking, 203
  Determining weighting type, 196
  Explicit, 208
Window menu
  Icon command, 12
Windows metafile, 118

**X**

X Variables, 80, 251
X/Y Scatter Graph, 100, 119
XY graph wizard, 119, 138, 139, 140, 147, 148